aboutsummaryrefslogtreecommitdiffstats
path: root/mail/evolution-mapi
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2010-05-11 05:19:08 +0800
committerkwm <kwm@FreeBSD.org>2010-05-11 05:19:08 +0800
commit6a2a890c5cd397f9f0287409c2aa0244d50f3573 (patch)
treefc02bcba8bfa155b5cf452d6bafe1cb06aca4848 /mail/evolution-mapi
parent0e415a93a0424a4b284c88c39b19d93d80b66c8a (diff)
downloadfreebsd-ports-gnome-6a2a890c5cd397f9f0287409c2aa0244d50f3573.tar.gz
freebsd-ports-gnome-6a2a890c5cd397f9f0287409c2aa0244d50f3573.tar.zst
freebsd-ports-gnome-6a2a890c5cd397f9f0287409c2aa0244d50f3573.zip
Presenting GNOME 2.30.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.30/ . This release brings initial PackageKit support, Upower (replaces power management part of hal), cuse4bsd integration with HAL and cheese, and a faster Evolution. Sadly GNOME 2.30.x will be the last release with FreeBSD 6.X support. This will also be the last of the 2.x releases. The next release will be the highly-anticipated GNOME 3.0 which will bring with it a new UI experience. Currently, there are a few bugs with GNOME 2.30 that may be of note for our users. Be sure to consult the UPGRADING note or the 2.30 upgrade FAQ at http://www.freebsd.org/gnome/docs/faq230.html for specific upgrading instructions, and the up-to-date list of known issues. This release features commits by avl, ahze, bland, marcus, mezz, and myself. The FreeBSD GNOME Team would like to thank Anders F Bjorklund for doing the initual packagekit porting. And the following contributors & testers for there help with this release: Eric L. Chen Vladimir Grebenschikov Sergio de Almeida Lenzi DomiX walder crsd Kevin Oberman Michal Varga Pavel Plesov Bapt kevin and ITetcu for two exp-run PR: ports/143852 ports/145347 ports/144980 ports/145830 ports/145511
Diffstat (limited to 'mail/evolution-mapi')
-rw-r--r--mail/evolution-mapi/Makefile7
-rw-r--r--mail/evolution-mapi/distinfo6
-rw-r--r--mail/evolution-mapi/files/patch-src_account-setup-eplugin_exchange-mapi-account-setup.c24
-rw-r--r--mail/evolution-mapi/pkg-plist49
4 files changed, 57 insertions, 29 deletions
diff --git a/mail/evolution-mapi/Makefile b/mail/evolution-mapi/Makefile
index acbc1c8b3048..59aaace063a4 100644
--- a/mail/evolution-mapi/Makefile
+++ b/mail/evolution-mapi/Makefile
@@ -3,12 +3,11 @@
# Whom: Koop Mast <kwm@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/mail/evolution-mapi/Makefile,v 1.5 2009/10/19 18:17:14 kwm Exp $
+# $MCom: ports/mail/evolution-mapi/Makefile,v 1.14 2010/04/28 08:29:07 kwm Exp $
#
PORTNAME= evolution-mapi
-PORTVERSION= 0.28.2
-PORTREVISION= 3
+PORTVERSION= 0.30.1
CATEGORIES= mail gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -31,7 +30,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-EVO_VERSION= 2.28
+EVO_VERSION= 2.30
EDS_VERSION= 1.2
PLIST_SUB= EVO_VERSION=${EVO_VERSION} EDS_VERSION=${EDS_VERSION}
diff --git a/mail/evolution-mapi/distinfo b/mail/evolution-mapi/distinfo
index 1d324b56366b..5faa59ed4e99 100644
--- a/mail/evolution-mapi/distinfo
+++ b/mail/evolution-mapi/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/evolution-mapi-0.28.2.tar.bz2) = 6f1c61b28778983806d39214f717810f
-SHA256 (gnome2/evolution-mapi-0.28.2.tar.bz2) = 02be73656e0793388540f9eca2922742f8f87caba6a54fee2cbf09ea0f9f2b2b
-SIZE (gnome2/evolution-mapi-0.28.2.tar.bz2) = 482959
+MD5 (gnome2/evolution-mapi-0.30.1.tar.bz2) = 73577721e07b2a7f15f9c6dfefe7d4e0
+SHA256 (gnome2/evolution-mapi-0.30.1.tar.bz2) = b435225156cb533469c359e9ee659d4bbc21a72860ed15f6faa6835d305c1e9b
+SIZE (gnome2/evolution-mapi-0.30.1.tar.bz2) = 493037
diff --git a/mail/evolution-mapi/files/patch-src_account-setup-eplugin_exchange-mapi-account-setup.c b/mail/evolution-mapi/files/patch-src_account-setup-eplugin_exchange-mapi-account-setup.c
new file mode 100644
index 000000000000..b4123235e567
--- /dev/null
+++ b/mail/evolution-mapi/files/patch-src_account-setup-eplugin_exchange-mapi-account-setup.c
@@ -0,0 +1,24 @@
+--- src/account-setup-eplugin/exchange-mapi-account-setup.c.orig 2010-03-08 04:03:24.000000000 -0500
++++ src/account-setup-eplugin/exchange-mapi-account-setup.c 2010-03-13 17:49:17.000000000 -0500
+@@ -696,3 +696,21 @@ exchange_mapi_cal_commit (EPlugin *epl,
+ // Update the folder list in the plugin and ExchangeMAPIFolder
+ return;
+ }
++
++const char *g_module_check_init (gpointer module);
++const char *
++g_module_check_init (gpointer module) {
++ return NULL;
++}
++
++void g_module_unload (gpointer module);
++void
++g_module_unload (gpointer module) {
++ return;
++}
++
++GtkWidget *e_plugin_lib_get_configure_widget (EPlugin *plugin);
++GtkWidget *
++e_plugin_lib_get_configure_widget (EPlugin *plugin) {
++ return NULL;
++}
diff --git a/mail/evolution-mapi/pkg-plist b/mail/evolution-mapi/pkg-plist
index 26dcf1428520..6c21313f1fdc 100644
--- a/mail/evolution-mapi/pkg-plist
+++ b/mail/evolution-mapi/pkg-plist
@@ -21,7 +21,9 @@ lib/libexchangemapi-1.0.la
lib/libexchangemapi-1.0.so
lib/libexchangemapi-1.0.so.0
share/locale/as/LC_MESSAGES/evolution-mapi.mo
+share/locale/ast/LC_MESSAGES/evolution-mapi.mo
share/locale/bg/LC_MESSAGES/evolution-mapi.mo
+share/locale/bn/LC_MESSAGES/evolution-mapi.mo
share/locale/bn_IN/LC_MESSAGES/evolution-mapi.mo
share/locale/ca/LC_MESSAGES/evolution-mapi.mo
share/locale/ca@valencia/LC_MESSAGES/evolution-mapi.mo
@@ -30,6 +32,7 @@ share/locale/da/LC_MESSAGES/evolution-mapi.mo
share/locale/de/LC_MESSAGES/evolution-mapi.mo
share/locale/el/LC_MESSAGES/evolution-mapi.mo
share/locale/en_GB/LC_MESSAGES/evolution-mapi.mo
+share/locale/en@shaw/LC_MESSAGES/evolution-mapi.mo
share/locale/es/LC_MESSAGES/evolution-mapi.mo
share/locale/et/LC_MESSAGES/evolution-mapi.mo
share/locale/eu/LC_MESSAGES/evolution-mapi.mo
@@ -45,9 +48,11 @@ share/locale/ja/LC_MESSAGES/evolution-mapi.mo
share/locale/kn/LC_MESSAGES/evolution-mapi.mo
share/locale/ko/LC_MESSAGES/evolution-mapi.mo
share/locale/lt/LC_MESSAGES/evolution-mapi.mo
+share/locale/lv/LC_MESSAGES/evolution-mapi.mo
share/locale/mai/LC_MESSAGES/evolution-mapi.mo
share/locale/ml/LC_MESSAGES/evolution-mapi.mo
share/locale/mr/LC_MESSAGES/evolution-mapi.mo
+share/locale/ms/LC_MESSAGES/evolution-mapi.mo
share/locale/nb/LC_MESSAGES/evolution-mapi.mo
share/locale/nl/LC_MESSAGES/evolution-mapi.mo
share/locale/or/LC_MESSAGES/evolution-mapi.mo
@@ -75,27 +80,27 @@ share/locale/zh_TW/LC_MESSAGES/evolution-mapi.mo
libdata/pkgconfig/libexchangemapi-1.0.pc
share/evolution-data-server-%%EVO_VERSION%%/mapi/tz-mapi-to-ical
share/evolution-data-server-%%EVO_VERSION%%/mapi/tz-ical-to-mapi
-@dirrmtry share/local/zh_TW/LC_MESSAGES
-@dirrmtry share/local/zh_TW
-@dirrmtry share/local/zh_HK/LC_MESSAGES
-@dirrmtry share/local/zh_HK
-@dirrmtry share/local/zh_CN/LC_MESSAGES
-@dirrmtry share/local/zh_CN
-@dirrmtry share/local/te/LC_MESSAGES
-@dirrmtry share/local/te
-@dirrmtry share/local/sr@latin/LC_MESSAGES
-@dirrmtry share/local/sr@latin
-@dirrmtry share/local/si/LC_MESSAGES
-@dirrmtry share/local/si
-@dirrmtry share/local/mr/LC_MESSAGES
-@dirrmtry share/local/mr
-@dirrmtry share/local/mai/LC_MESSAGES
-@dirrmtry share/local/mai
-@dirrmtry share/local/ca@valencia/LC_MESSAGES
-@dirrmtry share/local/ca@valencia
-@dirrmtry share/local/bn_IN/LC_MESSAGES
-@dirrmtry share/local/bn_IN
-@dirrmtry share/local/as/LC_MESSAGES
-@dirrmtry share/local/as
@dirrm share/evolution-data-server-%%EVO_VERSION%%/mapi
@dirrm include/evolution-data-server-%%EVO_VERSION%%/mapi
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
+@dirrmtry share/locale/sr@latin/LC_MESSAGES
+@dirrmtry share/locale/sr@latin
+@dirrmtry share/locale/si/LC_MESSAGES
+@dirrmtry share/locale/si
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/mai/LC_MESSAGES
+@dirrmtry share/locale/mai
+@dirrmtry share/locale/en@shaw/LC_MESSAGES
+@dirrmtry share/locale/en@shaw
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
+@dirrmtry share/locale/as/LC_MESSAGES
+@dirrmtry share/locale/as