aboutsummaryrefslogtreecommitdiffstats
path: root/mail/evolution/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-12-14 22:26:43 +0800
committersobomax <sobomax@FreeBSD.org>2001-12-14 22:26:43 +0800
commit03a47b975d3fe1ac23821587284c65def6753273 (patch)
tree051c2601e56c459d42c97558569ae5f35b475c7d /mail/evolution/Makefile
parent9330123fcafe0dc1ea308ab79595d668e8a3c94a (diff)
downloadfreebsd-ports-gnome-03a47b975d3fe1ac23821587284c65def6753273.tar.gz
freebsd-ports-gnome-03a47b975d3fe1ac23821587284c65def6753273.tar.zst
freebsd-ports-gnome-03a47b975d3fe1ac23821587284c65def6753273.zip
Enable gnomepilot support.
Submitted by: Jan Stocker <Jan.Stocker@t-online.de>
Diffstat (limited to 'mail/evolution/Makefile')
-rw-r--r--mail/evolution/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index ed2e23a23b81..886095b0d7b7 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -7,16 +7,18 @@
PORTNAME= evolution
PORTVERSION= 1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/evolution
MAINTAINER= gnome@FreeBSD.org
+BUILD_DEPENDS= ${X11BASE}/lib/gnome-pilot/conduits/libemail_conduit.so:${PORTSDIR}/palm/gnomepilot-conduits
LIB_DEPENDS= bonobo_conf.0:${PORTSDIR}/devel/bonobo-conf
#ldap.1:${PORTSDIR}/net/openldap <- avoid extra dependency until
# it actually works
+RUN_DEPENDS= ${X11BASE}/lib/gnome-pilot/conduits/libemail_conduit.so:${PORTSDIR}/palm/gnomepilot-conduits
#BROKEN= "Out of sync with latest gal"
@@ -29,8 +31,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-db3-libs=${LOCALBASE}/lib \
--with-html-dir=${PREFIX}/share/gnome/html \
--with-openssl-includes=${OPENSSLBASE}/include \
- --with-openssl-libs=${OPENSSLBASE}/lib
-# --with-pisock=${LOCALBASE}/pilot --enable-pilot-conduits=yes
+ --with-openssl-libs=${OPENSSLBASE}/lib \
+ --with-pisock=${LOCALBASE}/pilot --enable-pilot-conduits=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"