aboutsummaryrefslogtreecommitdiffstats
path: root/mail/evolution/files
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-06-30 03:33:26 +0800
committerade <ade@FreeBSD.org>2000-06-30 03:33:26 +0800
commit6f4188c874b99e95f6838f69cdda73c4b7a66575 (patch)
tree8257338f44dde9a8795a891ec413bd52540f1cac /mail/evolution/files
parent5043ab9c0a7a9f565375f9f232d143fc65168c21 (diff)
downloadfreebsd-ports-gnome-6f4188c874b99e95f6838f69cdda73c4b7a66575.tar.gz
freebsd-ports-gnome-6f4188c874b99e95f6838f69cdda73c4b7a66575.tar.zst
freebsd-ports-gnome-6f4188c874b99e95f6838f69cdda73c4b7a66575.zip
Evolution is the integrated mail, calendar and address book
distributed suite for GNOME from Helix Code, Inc.
Diffstat (limited to 'mail/evolution/files')
-rw-r--r--mail/evolution/files/patch-aa48
-rw-r--r--mail/evolution/files/patch-ab94
-rw-r--r--mail/evolution/files/patch-ac35
3 files changed, 177 insertions, 0 deletions
diff --git a/mail/evolution/files/patch-aa b/mail/evolution/files/patch-aa
new file mode 100644
index 000000000000..f7c3576f597f
--- /dev/null
+++ b/mail/evolution/files/patch-aa
@@ -0,0 +1,48 @@
+--- configure.orig Fri Jun 2 15:13:10 2000
++++ configure Wed Jun 28 17:39:26 2000
+@@ -4079,7 +4079,7 @@
+ cat conftest.$ac_ext >&5
+ rm -rf conftest*
+ CATOBJEXT=.mo
+- DATADIRNAME=lib
++ DATADIRNAME=share
+ fi
+ rm -f conftest*
+ INSTOBJEXT=.mo
+@@ -5621,8 +5621,8 @@
+ fi
+
+ if $have_pthread; then
+- THREADS_LIBS="$PTHREAD_LIB `glib-config --libs gthread`"
+- THREADS_CFLAGS="`glib-config --cflags gthread`"
++ THREADS_LIBS="$PTHREAD_LIB `$GLIB_CONFIG --libs gthread`"
++ THREADS_CFLAGS="`$GLIB_CONFIG --cflags gthread`"
+ else
+ THREADS_LIBS=""
+ THREADS_CFLAGS=""
+@@ -5697,8 +5697,8 @@
+ { echo "configure: error: Did not find gdkpixbuf installed" 1>&2; exit 1; }
+ fi
+
+-GLIB_CFLAGS="`glib-config --cflags`"
+-GLIB_LIBS="`glib-config --libs`"
++GLIB_CFLAGS="`$GLIB_CONFIG --cflags`"
++GLIB_LIBS="`$GLIB_CONFIG --libs`"
+
+
+
+@@ -6771,10 +6771,10 @@
+ *) # Relative path.
+ ac_sub_cache_file="$ac_dots$cache_file" ;;
+ esac
+- case "$ac_given_INSTALL" in
+- [/$]*) INSTALL="$ac_given_INSTALL" ;;
+- *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
+- esac
++# case "$ac_given_INSTALL" in
++# [/$]*) INSTALL="$ac_given_INSTALL" ;;
++# *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
++# esac
+
+ echo "running ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir"
+ # The eval makes quoting arguments work.
diff --git a/mail/evolution/files/patch-ab b/mail/evolution/files/patch-ab
new file mode 100644
index 000000000000..5cf4506520d4
--- /dev/null
+++ b/mail/evolution/files/patch-ab
@@ -0,0 +1,94 @@
+--- addressbook/ename/Makefile.in.orig Fri Jun 2 15:48:59 2000
++++ addressbook/ename/Makefile.in Wed Jun 28 18:13:26 2000
+@@ -149,3 +149,3 @@
+
+-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -DG_LOG_DOMAIN=\"EName\" -I$(srcdir) -I$(srcdir)/.. -I$(top_srcdir) -I. -I.. -I$(top_builddir) -I$(includedir) $(GNOME_INCLUDEDIR)
++INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -DG_LOG_DOMAIN=\"EName\" -I$(srcdir) -I$(srcdir)/.. -I$(top_srcdir) -I. -I.. -I$(top_builddir) -I$(includedir) $(GNOME_INCLUDEDIR)
+
+--- addressbook/backend/ebook/Makefile.in.orig Fri Jun 2 15:49:01 2000
++++ addressbook/backend/ebook/Makefile.in Wed Jun 28 18:18:09 2000
+@@ -159,3 +159,3 @@
+
+-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -DG_LOG_DOMAIN=\"EBook\" -I$(top_srcdir) -I$(top_srcdir)/addressbook/backend -I$(top_srcdir)/addressbook/ename -I$(top_builddir)/addressbook/backend -I$(top_builddir)/addressbook/ename $(BONOBO_GNOME_CFLAGS)
++INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -DG_LOG_DOMAIN=\"EBook\" -I$(top_srcdir) -I$(top_srcdir)/addressbook/backend -I$(top_srcdir)/addressbook/ename -I$(top_builddir)/addressbook/backend -I$(top_builddir)/addressbook/ename $(BONOBO_GNOME_CFLAGS)
+
+--- addressbook/backend/pas/Makefile.in.orig Fri Jun 2 15:49:02 2000
++++ addressbook/backend/pas/Makefile.in Wed Jun 28 18:20:11 2000
+@@ -157,3 +157,3 @@
+
+-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -DG_LOG_DOMAIN=\"wombat-pas\" -I$(top_srcdir) -I$(top_srcdir)/addressbook/backend -I$(top_builddir)/addressbook/backend $(BONOBO_GNOME_CFLAGS)
++INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -DG_LOG_DOMAIN=\"wombat-pas\" -I$(top_srcdir) -I$(top_srcdir)/addressbook/backend -I$(top_builddir)/addressbook/backend $(BONOBO_GNOME_CFLAGS)
+
+--- addressbook/gui/component/Makefile.in.orig Fri Jun 2 15:49:05 2000
++++ addressbook/gui/component/Makefile.in Wed Jun 28 18:22:43 2000
+@@ -152,3 +152,3 @@
+
+-INCLUDES = -DG_LOG_DOMAIN=\"evolution-addressbook\" $(EXTRA_GNOME_CFLAGS) $(GNOME_INCLUDEDIR) -I$(top_srcdir) -I$(top_builddir) -I$(top_srcdir)/shell -I$(top_builddir)/shell -I$(top_srcdir)/widgets/e-text -I$(top_srcdir)/widgets/e-table -I$(top_srcdir)/addressbook/gui/minicard -I$(top_srcdir)/addressbook/contact-editor -I$(top_srcdir)/addressbook/backend -I$(top_builddir)/addressbook/backend $(BONOBO_HTML_GNOME_CFLAGS) -DEVOLUTION_VERSION=\""$(VERSION)"\" -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" -DEVOLUTION_LOCALEDIR=\""$(datadir)/locale"\" -DCAMEL_PROVIDERDIR=\""$(providerdir)"\"
++INCLUDES = -DG_LOG_DOMAIN=\"evolution-addressbook\" $(EXTRA_GNOME_CFLAGS) $(GNOME_INCLUDEDIR) -I$(top_srcdir) -I$(top_builddir) -I$(top_srcdir)/shell -I$(top_builddir)/shell -I$(top_srcdir)/widgets/e-text -I$(top_srcdir)/widgets/e-table -I$(top_srcdir)/addressbook/gui/minicard -I$(top_srcdir)/addressbook/contact-editor -I$(top_srcdir)/addressbook/backend -I$(top_builddir)/addressbook/backend $(BONOBO_HTML_GNOME_CFLAGS) -DEVOLUTION_VERSION=\""$(VERSION)"\" -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" -DEVOLUTION_LOCALEDIR=\""$(prefix)/share/locale"\" -DCAMEL_PROVIDERDIR=\""$(providerdir)"\"
+
+--- calendar/cal-client/Makefile.in.orig Fri Jun 2 15:49:10 2000
++++ calendar/cal-client/Makefile.in Wed Jun 28 17:58:32 2000
+@@ -161,3 +161,3 @@
+
+-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -DG_LOG_DOMAIN=\"cal-client\" -I$(top_srcdir)/calendar -I$(srcdir) -I$(top_srcdir) -I. -I.. -I$(top_builddir) -I$(includedir) $(BONOBO_GNOME_CFLAGS)
++INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -DG_LOG_DOMAIN=\"cal-client\" -I$(top_srcdir)/calendar -I$(srcdir) -I$(top_srcdir) -I. -I.. -I$(top_builddir) -I$(includedir) $(BONOBO_GNOME_CFLAGS)
+
+--- calendar/cal-util/Makefile.in.orig Fri Jun 2 15:49:08 2000
++++ calendar/cal-util/Makefile.in Wed Jun 28 17:41:18 2000
+@@ -151,3 +151,3 @@
+
+-INCLUDES = -DGNOMELOCALEDIR=\""$(datadir)/locale"\" -DG_LOG_DOMAIN=\"cal-util\" -I$(top_srcdir) -I$(top_srcdir)/calendar -I. -I.. -I$(top_builddir) $(GNOME_INCLUDEDIR)
++INCLUDES = -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\" -DG_LOG_DOMAIN=\"cal-util\" -I$(top_srcdir) -I$(top_srcdir)/calendar -I. -I.. -I$(top_builddir) $(GNOME_INCLUDEDIR)
+
+--- calendar/gui/Makefile.in.orig Fri Jun 2 15:49:11 2000
++++ calendar/gui/Makefile.in Wed Jun 28 19:39:03 2000
+@@ -151,3 +151,3 @@
+
+-help_base = $(datadir)/gnome/help/cal
++help_base = $(datadir)/help/cal
+
+@@ -156,3 +156,3 @@
+
+-INCLUDES = -DG_LOG_DOMAIN=\"calendar-gui\" -I$(top_builddir)/shell -I$(top_srcdir)/shell -I$(top_srcdir) -I$(top_srcdir)/calendar -I$(top_srcdir)/libical/src/libical -I$(includedir) $(BONOBO_VFS_GNOME_CFLAGS) $(GNOME_CONDUIT_INCLUDEDIR) $(PISOCK_INCLUDEDIR) -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" -DGNOMELOCALEDIR=\""$(datadir)/locale"\"
++INCLUDES = -DG_LOG_DOMAIN=\"calendar-gui\" -I$(top_builddir)/shell -I$(top_srcdir)/shell -I$(top_srcdir) -I$(top_srcdir)/calendar -I$(top_srcdir)/libical/src/libical -I$(includedir) $(BONOBO_VFS_GNOME_CFLAGS) $(GNOME_CONDUIT_INCLUDEDIR) $(PISOCK_INCLUDEDIR) -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\"
+
+@@ -766,3 +766,3 @@
+ install-data-local:
+- $(mkinstalldirs) $(DESTDIR)$(help_base)/C
++# $(mkinstalldirs) $(DESTDIR)$(help_base)/C
+
+--- calendar/pcs/Makefile.in.orig Fri Jun 2 15:49:09 2000
++++ calendar/pcs/Makefile.in Wed Jun 28 17:42:02 2000
+@@ -149,3 +149,3 @@
+
+-INCLUDES = -DG_LOG_DOMAIN=\"wombat-pcs\" -I$(top_srcdir) -I$(top_srcdir)/calendar -I$(top_srcdir)/libical/src/libical -I$(top_builddir)/libical/src/libical $(BONOBO_GNOME_CFLAGS) -DGNOMELOCALEDIR=\""$(datadir)/locale"\"
++INCLUDES = -DG_LOG_DOMAIN=\"wombat-pcs\" -I$(top_srcdir) -I$(top_srcdir)/calendar -I$(top_srcdir)/libical/src/libical -I$(top_builddir)/libical/src/libical $(BONOBO_GNOME_CFLAGS) -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\"
+
+--- calendar/gui/dialogs/Makefile.in.orig Fri Jun 2 15:49:12 2000
++++ calendar/gui/dialogs/Makefile.in Wed Jun 28 18:24:00 2000
+@@ -151,3 +151,3 @@
+
+-INCLUDES = -DG_LOG_DOMAIN=\"calendar-gui\" -I$(top_srcdir) -I$(top_srcdir)/calendar -I$(top_srcdir)/libical/src/libical -I$(includedir) -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" $(BONOBO_VFS_GNOME_CFLAGS) -DGNOMELOCALEDIR=\""$(datadir)/locale"\"
++INCLUDES = -DG_LOG_DOMAIN=\"calendar-gui\" -I$(top_srcdir) -I$(top_srcdir)/calendar -I$(top_srcdir)/libical/src/libical -I$(includedir) -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" $(BONOBO_VFS_GNOME_CFLAGS) -DGNOMELOCALEDIR=\""$(prefix)/share/locale"\"
+
+--- mail/Makefile.in.orig Fri Jun 2 15:48:53 2000
++++ mail/Makefile.in Wed Jun 28 17:44:12 2000
+@@ -157,3 +157,3 @@
+
+-INCLUDES = -I$(top_srcdir)/widgets -I$(top_srcdir)/widgets/e-text -I$(top_srcdir) -I$(top_srcdir)/camel -I$(top_builddir)/shell -I$(top_srcdir)/shell $(BONOBO_HTML_GNOME_CFLAGS) -DEVOLUTION_VERSION=\""$(VERSION)"\" -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" -DEVOLUTION_LOCALEDIR=\""$(datadir)/locale"\" -DEVOLUTION_DATADIR=\""$(datadir)"\" -DCAMEL_PROVIDERDIR=\""$(providerdir)"\" -DG_LOG_DOMAIN=\"evolution-mail\"
++INCLUDES = -I$(top_srcdir)/widgets -I$(top_srcdir)/widgets/e-text -I$(top_srcdir) -I$(top_srcdir)/camel -I$(top_builddir)/shell -I$(top_srcdir)/shell $(BONOBO_HTML_GNOME_CFLAGS) -DEVOLUTION_VERSION=\""$(VERSION)"\" -DEVOLUTION_GLADEDIR=\""$(gladedir)"\" -DEVOLUTION_ICONSDIR=\""$(iconsdir)"\" -DEVOLUTION_LOCALEDIR=\""$(prefix)/share/locale"\" -DEVOLUTION_DATADIR=\""$(datadir)"\" -DCAMEL_PROVIDERDIR=\""$(providerdir)"\" -DG_LOG_DOMAIN=\"evolution-mail\"
+
+--- shell/Makefile.in.orig Fri Jun 2 15:48:43 2000
++++ shell/Makefile.in Wed Jun 28 17:44:32 2000
+@@ -153,3 +153,3 @@
+
+-INCLUDES = -I$(top_srcdir)/widgets -I$(top_srcdir)/widgets/misc -I$(top_srcdir) $(BONOBO_GNOME_CFLAGS) -DEVOLUTION_IMAGES=\""$(imagesdir)"\" -DEVOLUTION_VERSION=\""$(VERSION)"\" -DEVOLUTION_LOCALEDIR=\""$(datadir)/locale"\" -DEVOLUTION_DATADIR=\""$(datadir)"\" -DG_LOG_DOMAIN=\"evolution-shell\"
++INCLUDES = -I$(top_srcdir)/widgets -I$(top_srcdir)/widgets/misc -I$(top_srcdir) $(BONOBO_GNOME_CFLAGS) -DEVOLUTION_IMAGES=\""$(imagesdir)"\" -DEVOLUTION_VERSION=\""$(VERSION)"\" -DEVOLUTION_LOCALEDIR=\""$(prefix)/share/locale"\" -DEVOLUTION_DATADIR=\""$(datadir)"\" -DG_LOG_DOMAIN=\"evolution-shell\"
+
+--- wombat/Makefile.in.orig Fri Jun 2 15:49:13 2000
++++ wombat/Makefile.in Wed Jun 28 17:45:11 2000
+@@ -149,3 +149,3 @@
+
+-INCLUDES = -DG_LOG_DOMAIN=\"wombat\" -I$(top_srcdir)/e-util -I$(top_srcdir) -I$(top_srcdir)/addressbook/backend -I$(top_builddir)/addressbook/backend -I$(top_srcdir)/calendar -I$(top_srcdir)/calendar/pcs $(EXTRA_GNOME_CFLAGS) $(GNOME_INCLUDEDIR) -DEVOLUTION_VERSION=\""$(VERSION)"\" -DEVOLUTION_LOCALEDIR=\""$(datadir)/locale"\"
++INCLUDES = -DG_LOG_DOMAIN=\"wombat\" -I$(top_srcdir)/e-util -I$(top_srcdir) -I$(top_srcdir)/addressbook/backend -I$(top_builddir)/addressbook/backend -I$(top_srcdir)/calendar -I$(top_srcdir)/calendar/pcs $(EXTRA_GNOME_CFLAGS) $(GNOME_INCLUDEDIR) -DEVOLUTION_VERSION=\""$(VERSION)"\" -DEVOLUTION_LOCALEDIR=\""$(prefix)/share/locale"\"
+
diff --git a/mail/evolution/files/patch-ac b/mail/evolution/files/patch-ac
new file mode 100644
index 000000000000..196b503da75b
--- /dev/null
+++ b/mail/evolution/files/patch-ac
@@ -0,0 +1,35 @@
+--- camel/providers/mbox/Makefile.in.orig Fri Jun 2 15:48:47 2000
++++ camel/providers/mbox/Makefile.in Wed Jun 28 18:54:19 2000
+@@ -167,3 +167,3 @@
+
+-libcamelmbox_la_LDFLAGS = -version-info 0:0:0 -rpath $(libdir)
++libcamelmbox_la_LDFLAGS = -avoid-version -rpath $(libdir)
+
+--- camel/providers/pop3/Makefile.in.orig Fri Jun 2 15:48:48 2000
++++ camel/providers/pop3/Makefile.in Wed Jun 28 18:54:35 2000
+@@ -167,3 +167,3 @@
+
+-libcamelpop3_la_LDFLAGS = $(KRB4_LDFLAGS) -version-info 0:0:0 -rpath $(libdir)
++libcamelpop3_la_LDFLAGS = $(KRB4_LDFLAGS) -avoid-version -rpath $(libdir)
+
+--- camel/providers/sendmail/Makefile.in.orig Fri Jun 2 15:48:49 2000
++++ camel/providers/sendmail/Makefile.in Wed Jun 28 18:54:52 2000
+@@ -167,3 +167,3 @@
+
+-libcamelsendmail_la_LDFLAGS = -version-info 0:0:0 -rpath $(libdir)
++libcamelsendmail_la_LDFLAGS = -avoid-version -rpath $(libdir)
+
+--- camel/providers/smtp/Makefile.in.orig Fri Jun 2 15:48:49 2000
++++ camel/providers/smtp/Makefile.in Wed Jun 28 18:55:06 2000
+@@ -167,3 +167,3 @@
+
+-libcamelsmtp_la_LDFLAGS = -version-info 0:0:0 -rpath $(libdir)
++libcamelsmtp_la_LDFLAGS = -avoid-version -rpath $(libdir)
+
+--- camel/providers/vee/Makefile.in.orig Fri Jun 2 15:48:50 2000
++++ camel/providers/vee/Makefile.in Wed Jun 28 18:55:19 2000
+@@ -167,3 +167,3 @@
+
+-libcamelvee_la_LDFLAGS = -version-info 0:0:0 -rpath $(libdir)
++libcamelvee_la_LDFLAGS = -avoid-version -rpath $(libdir)
+