aboutsummaryrefslogtreecommitdiffstats
path: root/mail/evolution
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2002-02-13 13:03:22 +0800
committerade <ade@FreeBSD.org>2002-02-13 13:03:22 +0800
commita4e490bb3c7e38ba226f0070ca555df234cb71c1 (patch)
tree19c7f4e0810e7b24bf6bd2c7d591dcaad2ea9517 /mail/evolution
parent08a55754f58530b8459196867f6fbef1ce2bbe7b (diff)
downloadfreebsd-ports-gnome-a4e490bb3c7e38ba226f0070ca555df234cb71c1.tar.gz
freebsd-ports-gnome-a4e490bb3c7e38ba226f0070ca555df234cb71c1.tar.zst
freebsd-ports-gnome-a4e490bb3c7e38ba226f0070ca555df234cb71c1.zip
Add OpenLDAP2 support if WITH_LDAP is defined - this is a candidate for
turning into a WITHOUT_LDAP switch to abide by accepted GNOME bloatware standards. PR: 32838 Submitted by: Joe Marcus Clarke <marcus@marcuscom.com>
Diffstat (limited to 'mail/evolution')
-rw-r--r--mail/evolution/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/mail/evolution/Makefile b/mail/evolution/Makefile
index e3bd363d2e29..cb5052f20f98 100644
--- a/mail/evolution/Makefile
+++ b/mail/evolution/Makefile
@@ -7,6 +7,7 @@
PORTNAME= evolution
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= mail gnome
MASTER_SITES= http://www.sleepycat.com/update/3.1.17/:db \
${MASTER_SITE_GNOME}
@@ -18,15 +19,15 @@ MAINTAINER= gnome@FreeBSD.org
LIB_DEPENDS= bonobo_conf.0:${PORTSDIR}/devel/bonobo-conf \
nss3.1:${PORTSDIR}/security/nss
-# ldap.2:${PORTSDIR}/net/openldap2
+.if defined(WITH_LDAP}
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap2
+.endif
RUN_DEPENDS= gnome-spell-component:${PORTSDIR}/textproc/gnomespell
.if !defined(WITHOUT_PILOT)
BUILD_DEPENDS+= ${X11BASE}/lib/gnome-pilot/conduits/libemail_conduit.so:${PORTSDIR}/palm/gnomepilot-conduits
RUN_DEPENDS+= ${X11BASE}/lib/gnome-pilot/conduits/libemail_conduit.so:${PORTSDIR}/palm/gnomepilot-conduits
.endif
-#BROKEN= "Out of sync with latest gal"
-
USE_GMAKE= yes
USE_BISON= yes
USE_X_PREFIX= yes
@@ -40,7 +41,11 @@ CONFIGURE_ARGS= --with-db3-libs=${DB3_WRKSRC} \
--with-nspr-libs=${LOCALBASE}/lib \
--with-nss-includes=${LOCALBASE}/include/nss/security \
--with-nss-libs=${LOCALBASE}/lib
-# --with-openldap=${LOCALBASE}
+
+.if defined(WITH_LDAP)
+CONFIGURE_ARGS+= --with-openldap=${LOCALBASE}
+.endif
+
.if !defined(WITHOUT_PILOT)
CONFIGURE_ARGS+= --with-pisock=${LOCALBASE} \
--enable-pilot-conduits=yes