aboutsummaryrefslogtreecommitdiffstats
path: root/mail/exact
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2003-06-03 10:15:01 +0800
committerwill <will@FreeBSD.org>2003-06-03 10:15:01 +0800
commitdc5e9bec4965f9d70c84e36285111971470a8d30 (patch)
treea5c4f62fb1a217f43488cd5dc978d7f437f58a7f /mail/exact
parentad4f84fd74c85d92b278b4493450b4601c0cf6da (diff)
downloadfreebsd-ports-gnome-dc5e9bec4965f9d70c84e36285111971470a8d30.tar.gz
freebsd-ports-gnome-dc5e9bec4965f9d70c84e36285111971470a8d30.tar.zst
freebsd-ports-gnome-dc5e9bec4965f9d70c84e36285111971470a8d30.zip
Add exact 1.33, a program that implements POP Before SMTP Relay
Authentication. PR: 52757 Submitted by: mwest@uct.ac.za
Diffstat (limited to 'mail/exact')
-rw-r--r--mail/exact/Makefile42
-rw-r--r--mail/exact/distinfo1
-rw-r--r--mail/exact/files/exact.sh23
-rw-r--r--mail/exact/pkg-descr9
-rw-r--r--mail/exact/pkg-plist2
5 files changed, 77 insertions, 0 deletions
diff --git a/mail/exact/Makefile b/mail/exact/Makefile
new file mode 100644
index 000000000000..63e5eb9e573e
--- /dev/null
+++ b/mail/exact/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: exact
+# Date created: 26/05/2003
+# Whom: mwest@uct.ac.za
+#
+# $FreeBSD$
+#
+
+PORTNAME= exact
+PORTVERSION= 1.33
+CATEGORIES= mail
+MASTER_SITES= http://www.britishsteal.com/dist/exact/
+
+MAINTAINER= mwest@uct.ac.za
+COMMENT= A program that implements POP Before SMTP Relay Authentication
+
+MAILUSER?= mailnull
+MAILGROUP?= mailnull
+MAILLOG?= /var/log/maillog
+EXACTDIR?= /var/exact
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-user=${MAILUSER} \
+ --with-group=${MAILGROUP} \
+ --with-watch=${MAILLOG}
+
+pre-install:
+ @${SED} -e "s,/usr/local/var,/var,g; s,/state,,g" ${WRKSRC}/exact.conf > ${WRKSRC}/exact.conf.sample
+ @${SED} -e "s,%%PREFIX%%,${PREFIX},g; s,%%EXACTDIR%%,${EXACTDIR},g" ${FILESDIR}/exact.sh > ${WRKSRC}/exact.sh
+
+do-install:
+ ${MKDIR} ${EXACTDIR}
+ ${CHOWN} ${MAILUSER}:${MAILGROUP} ${EXACTDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/exact ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/exact.sh ${PREFIX}/etc/rc.d
+ ${INSTALL_DATA} ${WRKSRC}/exact.conf.sample ${PREFIX}/etc
+ ${INSTALL_MAN} ${WRKSRC}/exact.conf.5 ${MAN5PREFIX}/man/man5
+ ${INSTALL_MAN} ${WRKSRC}/exact.8 ${MAN8PREFIX}/man/man8
+
+MAN5= exact.conf.5
+MAN8= exact.8
+
+.include <bsd.port.mk>
diff --git a/mail/exact/distinfo b/mail/exact/distinfo
new file mode 100644
index 000000000000..2893e278deec
--- /dev/null
+++ b/mail/exact/distinfo
@@ -0,0 +1 @@
+MD5 (exact-1.33.tar.gz) = 78e1f3554019492d97aaa412e901d600
diff --git a/mail/exact/files/exact.sh b/mail/exact/files/exact.sh
new file mode 100644
index 000000000000..8386b6b6396d
--- /dev/null
+++ b/mail/exact/files/exact.sh
@@ -0,0 +1,23 @@
+#!/bin/sh
+PIDFILE=%%EXACTDIR%%/exact.pid
+
+case "$1" in
+ start)
+ if [ -x %%PREFIX%%/sbin/exact ]; then
+ %%PREFIX%%/sbin/exact && echo -n ' exact'
+ fi
+ ;;
+ stop)
+ if [ -f ${PIDFILE} ]; then
+ /bin/kill `cat ${PIDFILE}` > /dev/null 2>&1 && echo -n 'exact'
+ else
+ echo "exact isn't running"
+ fi
+ ;;
+ *)
+ echo ""
+ echo "Usage: `basename $0` { start | stop }"
+ echo ""
+ exit 64
+ ;;
+esac
diff --git a/mail/exact/pkg-descr b/mail/exact/pkg-descr
new file mode 100644
index 000000000000..c3aef92eb719
--- /dev/null
+++ b/mail/exact/pkg-descr
@@ -0,0 +1,9 @@
+EXACT is a program that implements POP Before SMTP Relay Authentication.
+
+It will work as is with UW-IMAPD, Cyrus, Courier (imapd and popd),
+Perdition, Exim and Sendmail.
+
+WWW: http://www.britishsteal.com/dist/exact/
+
+--
+mwest@uct.ac.za
diff --git a/mail/exact/pkg-plist b/mail/exact/pkg-plist
new file mode 100644
index 000000000000..8786569de3bc
--- /dev/null
+++ b/mail/exact/pkg-plist
@@ -0,0 +1,2 @@
+sbin/exact
+etc/exact.conf.sample