aboutsummaryrefslogtreecommitdiffstats
path: root/mail/exim/Makefile
diff options
context:
space:
mode:
authorsheldonh <sheldonh@FreeBSD.org>2003-06-13 21:20:56 +0800
committersheldonh <sheldonh@FreeBSD.org>2003-06-13 21:20:56 +0800
commit045e5c9217d7f1b2ca8c68f6137d256ef880c55f (patch)
treeafb0ceb987533c39154b94a49e4bc1aced469b11 /mail/exim/Makefile
parentb1cbc2c68411cf4d871f011238d5d104d4d6ea37 (diff)
downloadfreebsd-ports-gnome-045e5c9217d7f1b2ca8c68f6137d256ef880c55f.tar.gz
freebsd-ports-gnome-045e5c9217d7f1b2ca8c68f6137d256ef880c55f.tar.zst
freebsd-ports-gnome-045e5c9217d7f1b2ca8c68f6137d256ef880c55f.zip
1) Update exiscan-acl patch to -09:
Improved clamd support. New FAQ/example documentation. 2) Enable wildlsearch lookups by default and add new WITHOUT_WILDLSEARCH knob for disabling them. 3) Issue a fat warning if 127.0.0.1 is found in the relay_from_hosts hostlist of an existing configure file on upgrade. This is important for IPv6 users and doesn't hurt IPv4-only users. 4) Attempt local deliveries as the owner of the mailbox (still group mail) and don't fail if the existing mailbox permissions are narrower than those with which we would have created it. This works around pw(8) creating mailboxes with 0600 permission (instead of 0660). Don't advertise Exim's configuration syntax as simple any more. This implies that you could leverage Exim's power with just a little reading, which is not the case. Bump PORTREVISION accordingly. Submitted by: Oliver Eikemeier <eikemeier@fillmore-labs.com> (1) PR: ports/52952 (2) Submitted by: Tim Bishop <tim@bishnet.net> (2) Reported by: Yann Golanski <yann@kierun.org> (3) Reported by: "Simon L. Nielsen" <simon@nitro.dk> (4)
Diffstat (limited to 'mail/exim/Makefile')
-rw-r--r--mail/exim/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 37d6b3eb8682..c9d14a17c7dc 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -7,7 +7,7 @@
PORTNAME= exim
PORTVERSION= ${EXIM_VERSION}
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/%SUBDIR%/ \
ftp://gd.tuwien.ac.at/infosys/mail/exim/%SUBDIR%/ \
@@ -60,7 +60,7 @@ MAN8= exim.8
EXIM_VERSION= 4.20
EXIM_DOCVERSION= 4.20
-EXISCAN_ACL_VERSION= ${EXIM_VERSION}-08
+EXISCAN_ACL_VERSION= ${EXIM_VERSION}-09
EXISCAN_VERSION= ${EXIM_VERSION}-26
PLIST_SUB+= EXIM_VERSION="${EXIM_VERSION}"
@@ -135,10 +135,12 @@ DB_LIB_VERSION?=1
#WITHOUT_MAILSTORE= yes
#WITHOUT_MBX= yes
#
-# Define WITHOUT_CDB, WITHOUT_DSEARCH and WITHOUT_NIS to disable support for
-# CDB-style, directory-list and NIS lookups respectively.
+# Define WITHOUT_CDB, WITHOUT_DSEARCH, WILD_LSEARCH and WITHOUT_NIS to
+# disable support for CDB-style, directory-list, wildcarded-file and NIS
+# lookups respectively.
#WITHOUT_CDB= yes
#WITHOUT_DSEARCH= yes
+#WITHOUT_WILDLSEARCH= yes
#WITHOUT_NIS= yes
#
# Disable support for the LMTP (RFC 2033 "SMTP over command pipe")
@@ -157,7 +159,7 @@ PORTDOC_FILES= Exim3.upgrade Exim4.upgrade OptionLists.txt README \
dbm.discuss.txt filter.txt pcrepattern.txt pcretest.txt \
spec.txt
.if defined(WITH_EXISCAN_ACL)
-PORTDOC_FILES+= exiscan-acl-spec.txt
+PORTDOC_FILES+= exiscan-acl-examples.txt exiscan-acl-spec.txt
PLIST_SUB+= EXISCAN_ACL=""
PLIST_SUB+= EXISCAN="@comment "
.elif !defined(WITHOUT_EXISCAN)
@@ -324,6 +326,10 @@ SEDLIST+= -e 's,^\# LOOKUP_CDB=,LOOKUP_CDB=,'
SEDLIST+= -e 's,^\# LOOKUP_DSEARCH=,LOOKUP_DSEARCH=,'
.endif
+.if !defined(WITHOUT_WILDLSEARCH)
+SEDLIST+= -e 's,^\# LOOKUP_WILDLSEARCH=,LOOKUP_WILDLSEARCH=,'
+.endif
+
.if !defined(WITHOUT_NIS)
SEDLIST+= -e 's,^\# LOOKUP_NIS=,LOOKUP_NIS=,'
.endif
@@ -372,5 +378,6 @@ post-install:
.endfor
.endif
@${CAT} ${PKGMESSAGE}
+ @PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.include <bsd.port.post.mk>