aboutsummaryrefslogtreecommitdiffstats
path: root/mail/exim/Makefile
diff options
context:
space:
mode:
authorsheldonh <sheldonh@FreeBSD.org>2001-06-13 02:05:59 +0800
committersheldonh <sheldonh@FreeBSD.org>2001-06-13 02:05:59 +0800
commit0fa6316593a4b6a1a29d04ff64c27c64ace2d338 (patch)
tree4c99b1ff8c309e78df4f49249b97725154877218 /mail/exim/Makefile
parent48fe5c0e5b7dd0c9e754fcc932ee7af81b901e5f (diff)
downloadfreebsd-ports-gnome-0fa6316593a4b6a1a29d04ff64c27c64ace2d338.tar.gz
freebsd-ports-gnome-0fa6316593a4b6a1a29d04ff64c27c64ace2d338.tar.zst
freebsd-ports-gnome-0fa6316593a4b6a1a29d04ff64c27c64ace2d338.zip
* Add a WITH_IPV6 knob. Exim breaks if compiled with IPv6 support and
run with a kernel that has had IPv6 ommitted from its configuration, so I can't make this a default (yet). * Remove crazy handling of exim.sh and replace it with something much simpler and more sane. This allows non-root users to build, even if they can't install (properly).
Diffstat (limited to 'mail/exim/Makefile')
-rw-r--r--mail/exim/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 6b9b62e06879..74e96187f5a1 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -36,6 +36,10 @@ MAKE_ENV+= OSTYPE=${OPSYS} ARCHTYPE=${MACHINE_ARCH}
#WITH_MYSQL= yes
#WITH_PGSQL= yes
+# Only define WITH_IPV6 on systems with IPv6 support compiled into the
+# kernel. Exim's IPv6 support is still experimental.
+#WITH_IPV6= yes
+
# If WITH_LDAP is defined, LDAP_LIB_TYPE must be one of UMICHIGAN,
# NETSCAPE or SOLARIS7.
LDAP_LIB_TYPE=UMICHIGAN
@@ -133,6 +137,10 @@ SEDLIST+= -e 's,XX_PGSQL_LIBS_XX,-L${PREFIX}/pgsql/lib -lpq,' \
SEDLIST+= -e 's,XX_PGSQL_[^ ]*_XX,,'
.endif
+.if defined(WITH_IPV6)
+SEDLIST+= -e 's,^\# HAVE_IPV6=,HAVE_IPV6=,'
+.endif
+
.if !defined(WITH_PGSQL) && !defined(WITH_MYSQL) && !defined(WITH_LDAP)
SEDLIST+= -e 's,^LOOKUP_LIBS,\#LOOKUP_LIBS,' \
-e 's,^LOOKUP_INCLUDE,\#LOOKUP_INCLUDE,'
@@ -166,12 +174,13 @@ do-configure:
done
post-build:
- ${INSTALL_SCRIPT} ${FILESDIR}/exim.sh \
- ${WRKSRC}/build-${OPSYS}-${MACHINE_ARCH}
${TOUCH} ${WRKSRC}/build-${OPSYS}-${MACHINE_ARCH}/eximon.bin
${TOUCH} ${WRKSRC}/build-${OPSYS}-${MACHINE_ARCH}/eximon
pre-install:
@PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+post-install:
+ ${INSTALL_SCRIPT} ${FILESDIR}/exim.sh ${PREFIX}/etc/rc.d
+
.include <bsd.port.mk>