aboutsummaryrefslogtreecommitdiffstats
path: root/mail/exim
diff options
context:
space:
mode:
authorrea <rea@FreeBSD.org>2011-01-28 05:23:33 +0800
committerrea <rea@FreeBSD.org>2011-01-28 05:23:33 +0800
commit3b940aee4414f5b639fae670e91eb7df46d09c68 (patch)
tree5c4993342e9bbb9837e650a3656fc7e3f4055abe /mail/exim
parent8a04ad4dd768df9d3b39d923296fe7b43d2ccd1e (diff)
downloadfreebsd-ports-gnome-3b940aee4414f5b639fae670e91eb7df46d09c68.tar.gz
freebsd-ports-gnome-3b940aee4414f5b639fae670e91eb7df46d09c68.tar.zst
freebsd-ports-gnome-3b940aee4414f5b639fae670e91eb7df46d09c68.zip
mail/exim: update to 4.74
Changelog is at http://ftp.exim.org/pub/exim/ChangeLogs/ChangeLog-4.74 Please, note that CVE-2011-0017 is not applicable to FreeBSD, because setuid() doesn't check RLIMIT_NPROC. Also fixed the periodic script for tidying the databases: now it won't produce errors if the lockfile is here, but the actual database file is gone. [2] And finally, synced the mirror list to the current one and pruned old unusable mirrors: - ftp.csx.cam.ac.uk: not synced anymore; - www.no.exim.org: no DNS record; - ftp.demon.nl: no longer mirrors Exim; - ftp.freenet.de: mirror of ftp.csx.cam.ac.uk; - ftp.esat.net: not synced anymore; - ftp.mirrorservice.org: mirror of ftp.csx.cam.ac.uk. Feature safe: yes PR: 154323 [1] Submitted by: Geraint Edwards <gedge@yadn.org> [2], Alexander Wittig <alexander@wittig.name> [1] Approved by: erwin (mentor), renato (mentor)
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile13
-rw-r--r--mail/exim/distinfo4
-rw-r--r--mail/exim/files/150.exim-tidydb.sh5
3 files changed, 16 insertions, 6 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index da94ded30274..1b0e580cdecf 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -25,6 +25,10 @@ WANT_GNOME= yes
WANT_PERL= yes
MAKE_JOBS_UNSAFE= yes
+.if make(makesum) && !defined(FETCH_ALL)
+.error "You forgot to define FETCH_ALL to create the sane distinfo"
+.endif
+
.include <bsd.port.pre.mk>
.if defined(WITH_SA_EXIM)
@@ -42,23 +46,26 @@ IGNORE= You cannot select both SA_KAS and SO_1024 options
.endif
.endif
-.if defined(WITH_SA_EXIM)
+.if defined(WITH_SA_EXIM) || defined(FETCH_ALL)
MASTER_SITES+= http://marc.merlins.org/linux/exim/files/:sa_exim \
SF/sa-exim/sa-exim/${SA_EXIM_VERSION}:sa_exim
MASTER_SITE_SUBDIR+= sa-exim/:sa_exim
DISTFILES+= sa-exim-${SA_EXIM_VERSION}.tar.gz:sa_exim
.endif
-.if defined(WITH_SO_1024)
+.if defined(WITH_SO_1024) || defined(FETCH_ALL)
MASTER_SITES+= ftp://ftp.renatasystems.org/pub/FreeBSD/ports/distfiles/:so_1024
DISTFILES+= spamooborona1024-src-${SO_1024_VERSION}.tar.gz:so_1024
+.endif
+
+.if defined(WITH_SO_1024)
LDFLAGS+= -lz
PLIST_SUB+= SO_1024=""
.else
PLIST_SUB+= SO_1024="@comment "
.endif
-EXIM_VERSION= 4.73
+EXIM_VERSION= 4.74
SA_EXIM_VERSION=4.2
SO_1024_VERSION=3.2
diff --git a/mail/exim/distinfo b/mail/exim/distinfo
index 7c146c97c29c..ed71b6a83bee 100644
--- a/mail/exim/distinfo
+++ b/mail/exim/distinfo
@@ -1,5 +1,5 @@
-SHA256 (exim/exim-4.73.tar.bz2) = a78f4a153f36ad13acf7fb9a3a99c1bc785d38bd757553704c9590afcc00bfd6
-SIZE (exim/exim-4.73.tar.bz2) = 1592788
+SHA256 (exim/exim-4.74.tar.bz2) = e55b51c87e0be920f7f5aee830261566a4def8820f318d14a822fe2ae2ff8e40
+SIZE (exim/exim-4.74.tar.bz2) = 1588636
SHA256 (exim/sa-exim-4.2.tar.gz) = 72e0a735547f18b05785e6c58a71d24623858f0f5234a5dc0e24cb453999e99a
SIZE (exim/sa-exim-4.2.tar.gz) = 66575
SHA256 (exim/spamooborona1024-src-3.2.tar.gz) = ab22a430f3860460045f6b213c68c89700a0cd10cbb6c7a808ece326c53787ee
diff --git a/mail/exim/files/150.exim-tidydb.sh b/mail/exim/files/150.exim-tidydb.sh
index 1fbfb8388f70..7f6522b24a9e 100644
--- a/mail/exim/files/150.exim-tidydb.sh
+++ b/mail/exim/files/150.exim-tidydb.sh
@@ -25,7 +25,10 @@ case "$exim_tidydb_enable" in
for db in "$exim_dbdir"/db/*.lockfile; do
[ "$db" = "$exim_dbdir/db/*.lockfile" ] && continue
echo
- "$exim_tidydb" "$exim_dbdir" `basename "$db" .lockfile`
+ db_name=`basename "$db" .lockfile`
+ if [ -e "${exim_dbdir}/db/${db_name}" ]; then
+ "$exim_tidydb" "$exim_dbdir" "$db_name"
+ fi
done
rc=1;;