aboutsummaryrefslogtreecommitdiffstats
path: root/mail/exim
diff options
context:
space:
mode:
authorsheldonh <sheldonh@FreeBSD.org>2003-06-30 19:46:43 +0800
committersheldonh <sheldonh@FreeBSD.org>2003-06-30 19:46:43 +0800
commit0bc8a5e395734bbaf98f7b95d04bd74831b4b1f7 (patch)
tree972d532b31422a9e06f72243d7b6dc195df0e517 /mail/exim
parentb49053352d220206192a9eb5294aceb3f703bad1 (diff)
downloadfreebsd-ports-gnome-0bc8a5e395734bbaf98f7b95d04bd74831b4b1f7.tar.gz
freebsd-ports-gnome-0bc8a5e395734bbaf98f7b95d04bd74831b4b1f7.tar.zst
freebsd-ports-gnome-0bc8a5e395734bbaf98f7b95d04bd74831b4b1f7.zip
Recognize named lists in hosts_treat_as_local.
Reported by: Oliver Eikemeier <eikemeier@fillmore-labs.com> Obtained from: author
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile2
-rw-r--r--mail/exim/files/patch-src::host.c13
2 files changed, 14 insertions, 1 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 6dc5355cec4b..0c1dffc8e7cc 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -7,7 +7,7 @@
PORTNAME= exim
PORTVERSION= ${EXIM_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/%SUBDIR%/ \
ftp://gd.tuwien.ac.at/infosys/mail/exim/%SUBDIR%/ \
diff --git a/mail/exim/files/patch-src::host.c b/mail/exim/files/patch-src::host.c
new file mode 100644
index 000000000000..b6e1e98e4207
--- /dev/null
+++ b/mail/exim/files/patch-src::host.c
@@ -0,0 +1,13 @@
+--- src/host.c.orig Mon May 12 15:39:19 2003
++++ src/host.c Fri Jun 20 14:54:12 2003
+@@ -817,8 +817,8 @@
+ int rc;
+ uschar *save = deliver_domain;
+ deliver_domain = h->name; /* set $domain */
+- rc = match_isinlist(string_copylc(h->name), &hosts_treat_as_local, 0, NULL,
+- NULL, MCL_DOMAIN, TRUE, NULL);
++ rc = match_isinlist(string_copylc(h->name), &hosts_treat_as_local, 0,
++ &domainlist_anchor, NULL, MCL_DOMAIN, TRUE, NULL);
+ deliver_domain = save;
+ if (rc == OK) goto FOUND_LOCAL;
+ }