aboutsummaryrefslogtreecommitdiffstats
path: root/mail/exim
diff options
context:
space:
mode:
authorrea <rea@FreeBSD.org>2013-06-23 04:00:56 +0800
committerrea <rea@FreeBSD.org>2013-06-23 04:00:56 +0800
commit569d9ddf20a90005612f94b21c663bd14724370c (patch)
tree7c318c3c715e74699d32f550f8833152e5cb3be3 /mail/exim
parent44652f5757c7d137e5fefd30e2877269bbadf912 (diff)
downloadfreebsd-ports-gnome-569d9ddf20a90005612f94b21c663bd14724370c.tar.gz
freebsd-ports-gnome-569d9ddf20a90005612f94b21c663bd14724370c.tar.zst
freebsd-ports-gnome-569d9ddf20a90005612f94b21c663bd14724370c.zip
mail/exim: fix handling of WITH_MYSQL_VER
- fix introduction of bogus MYSQL_VER option that appeared after blind conversion to OPTIONSng in r320120; - drop support for WITH_MYSQL_VER="auto": this is an obsolete setting that currently has the same effect as not defining WITH_MYSQL_VER at all; - don't set WANT_MYSQL_VER based on WITH_MYSQL_VER: setting the latter is enough, since we don't insist on any particular MySQL version. PR: ports/179719 QA page: http://codelabs.ru/fbsd/ports/qa/mail/exim/4.80.1_2-p1
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 9a6f29590a2d..cdf7490df45c 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -286,14 +286,13 @@ SEDLIST+= -e 's,^(DBMLIB=),\# \1,'
SEDLIST+= -e 's,XX_DB_LIBS_XX,${DB_LIBS:S/,/\\,/g},' \
-e 's,XX_DB_INCLUDES_XX,${DB_INCLUDES:S/,/\\,/g},'
-.if ${PORT_OPTIONS:MMYSQL_VER} && ${WITH_MYSQL_VER:L} != "auto"
-WANT_MYSQL_VER= ${WITH_MYSQL_VER}
-.else
-.undef WITH_MYSQL_VER
-.endif
-
.if ${PORT_OPTIONS:MMYSQL}
+.if defined(WITH_MYSQL_VER) && ${WITH_MYSQL_VER:L} == "auto"
+IGNORE= WITH_MYSQL_VER set to "${WITH_MYSQL_VER}" is no longer supported.
+IGNORE+= Just don't set WITH_MYSQL_VER if you want to use system-default version
+.else
USE_MYSQL= yes
+.endif
SEDLIST+= -e 's,XX_MYSQL_LIBS_XX,-L${LOCALBASE:S/,/\\,/g}/lib/mysql -lmysqlclient,' \
-e 's,XX_MYSQL_INCLUDE_XX,-I${LOCALBASE:S/,/\\,/g}/include/mysql,' \
-e 's,^\# (LOOKUP_MYSQL=),\1,'