aboutsummaryrefslogtreecommitdiffstats
path: root/mail/exim
diff options
context:
space:
mode:
authorsheldonh <sheldonh@FreeBSD.org>2001-11-03 01:11:14 +0800
committersheldonh <sheldonh@FreeBSD.org>2001-11-03 01:11:14 +0800
commit7af60ebbfc65f03dd76f7c72e47951f1d6a42552 (patch)
tree717e032fc4f515d43c2962a4d13afd4172e789b3 /mail/exim
parent90519498e63a9b73c57a6c39bc5d655d56649168 (diff)
downloadfreebsd-ports-gnome-7af60ebbfc65f03dd76f7c72e47951f1d6a42552.tar.gz
freebsd-ports-gnome-7af60ebbfc65f03dd76f7c72e47951f1d6a42552.tar.zst
freebsd-ports-gnome-7af60ebbfc65f03dd76f7c72e47951f1d6a42552.zip
Add the author's patch to fix a failure to reap children on BSD systems,
where SIG_IGN as the signal handler for SIGCHLD is bad. This is only an issue when a significant number of messages is received via pipe (e.g. with -bS) at a faster rate than they can be dealt with by parallel delivery agents (e.g. -odqs). Bump PORTREVISION to reflect the change. Obtained from: exim-users@exim.org Message-Id: Pine.SOL.4.33.0111021349170.19636-100000@virgo.cus.cam.ac.uk
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile2
-rw-r--r--mail/exim/files/patch-src::exim.c8
2 files changed, 9 insertions, 1 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index cd425afabe5d..9edb7afae006 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -7,7 +7,7 @@
PORTNAME= exim
PORTVERSION= 3.33
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/ \
http://www.exim.org/ftp/ \
diff --git a/mail/exim/files/patch-src::exim.c b/mail/exim/files/patch-src::exim.c
index e84e06bcff84..c16f4a861e8e 100644
--- a/mail/exim/files/patch-src::exim.c
+++ b/mail/exim/files/patch-src::exim.c
@@ -10,3 +10,11 @@
(list_queue && queue_list_requires_admin) ||
(queue_interval >= 0 && prod_requires_admin))
{
+@@ -3462,6 +3463,7 @@
+ }
+
+ /* The loop will repeat if more is TRUE. */
++ while (waitpid(-1, NULL, WNOHANG) > 0);
+ }
+
+ exim_exit(EXIT_SUCCESS); /* Never returns */