aboutsummaryrefslogtreecommitdiffstats
path: root/mail/exim
diff options
context:
space:
mode:
authorsheldonh <sheldonh@FreeBSD.org>2001-06-11 17:40:24 +0800
committersheldonh <sheldonh@FreeBSD.org>2001-06-11 17:40:24 +0800
commit83b561db00372b3e3602b95f0f2695c719c6c6c3 (patch)
tree4eb4d52f899e786b06e45a632116490b746e1321 /mail/exim
parente3bc6f8d116cd5e0cb8a780ef3a9b3783443d231 (diff)
downloadfreebsd-ports-gnome-83b561db00372b3e3602b95f0f2695c719c6c6c3.tar.gz
freebsd-ports-gnome-83b561db00372b3e3602b95f0f2695c719c6c6c3.tar.zst
freebsd-ports-gnome-83b561db00372b3e3602b95f0f2695c719c6c6c3.zip
Enable CDB-style lookups by default and provide a knob for disabling
this support. Fix the SEDLIST-building logic for disabling mbx and mailstore alternative mailbox formats. Bump PORTREVISION accordingly.
Diffstat (limited to 'mail/exim')
-rw-r--r--mail/exim/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index 968fcc3ee190..e74bffa631a6 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -7,7 +7,7 @@
PORTNAME= exim
PORTVERSION= 3.22
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail
MASTER_SITES= ftp://ftp.csx.cam.ac.uk/pub/software/email/exim/ \
http://www.exim.org/ftp/ \
@@ -60,6 +60,9 @@ LDAP_LIB_TYPE=UMICHIGAN
#WITHOUT_MAILDIR= yes
#WITHOUT_MAILSTORE= yes
#WITHOUT_MBX= yes
+#
+# Disable support for CDB-style lookups.
+#WITHOUT_CDB= yes
# You should not need to fiddle with anything below this point.
@@ -139,14 +142,18 @@ SEDLIST+= -e 's,^LOOKUP_LIBS,\#LOOKUP_LIBS,' \
SEDLIST+= -e 's,^\# SUPPORT_MAILDIR=,SUPPORT_MAILDIR=,'
.endif
-.if !defined(WITH_MAILSTORE)
+.if !defined(WITHOUT_MAILSTORE)
SEDLIST+= -e 's,^\# SUPPORT_MAILSTORE=,SUPPORT_MAILSTORE=,'
.endif
-.if !defined(WITH_MAILMBX)
+.if !defined(WITHOUT_MBX)
SEDLIST+= -e 's,^\# SUPPORT_MBX=,SUPPORT_MBX=,'
.endif
+.if !defined(WITHOUT_CDB)
+SEDLIST+= -e 's,^\# LOOKUP_CDB=,LOOKUP_CDB=,'
+.endif
+
do-configure:
${MKDIR} ${WRKSRC}/Local
${SED} ${SEDLIST} < ${WRKSRC}/src/EDITME > ${WRKSRC}/Local/Makefile