aboutsummaryrefslogtreecommitdiffstats
path: root/mail/exmh2/Makefile
diff options
context:
space:
mode:
authormarkm <markm@FreeBSD.org>1998-03-20 17:28:16 +0800
committermarkm <markm@FreeBSD.org>1998-03-20 17:28:16 +0800
commit8f0214c38b3c198a9fa6a149e8b38e60ad0f7886 (patch)
tree56ba5385b518b97639136ee42c4d19405f5f4817 /mail/exmh2/Makefile
parentddb690618acfe9ae01d40b9ee118282c9ad6c47e (diff)
downloadfreebsd-ports-gnome-8f0214c38b3c198a9fa6a149e8b38e60ad0f7886.tar.gz
freebsd-ports-gnome-8f0214c38b3c198a9fa6a149e8b38e60ad0f7886.tar.zst
freebsd-ports-gnome-8f0214c38b3c198a9fa6a149e8b38e60ad0f7886.zip
Allow this port to use NMH if USE_NMH is set.
Diffstat (limited to 'mail/exmh2/Makefile')
-rw-r--r--mail/exmh2/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/mail/exmh2/Makefile b/mail/exmh2/Makefile
index f7d307f385e2..92cb422e0567 100644
--- a/mail/exmh2/Makefile
+++ b/mail/exmh2/Makefile
@@ -3,7 +3,7 @@
# Date released: 1 Jan 97
# Whom: Peter Wemm <peter@freebsd.org>
#
-# $Id: Makefile,v 1.25 1998/02/15 05:36:54 peter Exp $
+# $Id: Makefile,v 1.26 1998/03/14 13:43:36 peter Exp $
#
DISTNAME= exmh-2.0.2
@@ -40,7 +40,12 @@ WISH= wish8.0
TCLSH= tclsh8.0
# exmh is pretty useless without this, but it's not needed to build it.
+.if defined(USE_NMH)
+RUN_DEPENDS+= repl:${PORTSDIR}/mail/nmh
+SCRIPTS_ENV+= USE_NMH=YES
+.else
RUN_DEPENDS+= repl:${PORTSDIR}/mail/mh
+.endif
# full mime support needs mmencode/mmdecode from metamail
RUN_DEPENDS+= mmencode:${PORTSDIR}/mail/metamail
@@ -57,7 +62,7 @@ MAN1= exmh.1
do-build:
@cd ${WRKSRC} && ${SETENV} PREFIX=${PREFIX} TCLSH=${TCLSH} \
WISH=${PREFIX}/bin/${WISH} WRKSRC=${WRKSRC} \
- FILESDIR=${FILESDIR} ${SH} ${SCRIPTDIR}/build
+ ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/build
do-install:
@cd ${WRKSRC} && ${SETENV} PREFIX=${PREFIX} \