aboutsummaryrefslogtreecommitdiffstats
path: root/mail/faces/files
diff options
context:
space:
mode:
authorlkoeller <lkoeller@FreeBSD.org>2001-02-27 04:49:01 +0800
committerlkoeller <lkoeller@FreeBSD.org>2001-02-27 04:49:01 +0800
commitf925c2a0755573bc7f95e8846335be118d1362ad (patch)
treeb77bf89dc2130dde7edb2ded6ab9d869bf99b088 /mail/faces/files
parent13787f365e313041780bc22024169f33462bf8b3 (diff)
downloadfreebsd-ports-gnome-f925c2a0755573bc7f95e8846335be118d1362ad.tar.gz
freebsd-ports-gnome-f925c2a0755573bc7f95e8846335be118d1362ad.tar.zst
freebsd-ports-gnome-f925c2a0755573bc7f95e8846335be118d1362ad.zip
- Respect PREFIX and X11BASE which wasn't done in some binaries and scripts
- Fix problem with gcc 2.95 (add -fwritable-strings) - Fix problem with display depth when printing username below icon (white text on white background ;-) - Add some documentation (READMEs) with respect to NOPORTDOCS - Define of USE_NAS environment variable builds faces with NAS (auplay) support (default is rplay) - Correct pkg-plist - Shorten pkg-desc below 24 lines - Bump PORTREVISION to 1 Changes were stimulated by: Mike Meyer <mwm@mired.org>
Diffstat (limited to 'mail/faces/files')
-rw-r--r--mail/faces/files/patch-ab2
-rw-r--r--mail/faces/files/patch-ag42
-rw-r--r--mail/faces/files/patch-ea20
3 files changed, 56 insertions, 8 deletions
diff --git a/mail/faces/files/patch-ab b/mail/faces/files/patch-ab
index 733c0ef60439..4b0acea11034 100644
--- a/mail/faces/files/patch-ab
+++ b/mail/faces/files/patch-ab
@@ -107,7 +107,7 @@
$(TTEXT) $(TOPIX) $(UPDATE) $(USE_BZERO) $(USE_GETWD) \
$(X11R3) $(X11INCDIR) $(XVIEWINCDIR) $(DEBUG)
-CCOMP = -O
-+CCOMP = -pipe -O2
++CCOMP = -pipe -O2 -fwritable-strings
CFLAGS = $(CCOMP) $(CDEFS)
#
#=======================================================================
diff --git a/mail/faces/files/patch-ag b/mail/faces/files/patch-ag
index 69a66e9cde7a..c3293263d870 100644
--- a/mail/faces/files/patch-ag
+++ b/mail/faces/files/patch-ag
@@ -1,6 +1,5 @@
-diff -c -N ../faces/x11.c ./x11.c
-*** ../faces/x11.c Tue Nov 19 05:00:50 1991
---- ./x11.c Tue Dec 10 20:43:06 1996
+*** x11.c.orig Tue Nov 19 05:00:50 1991
+--- x11.c Mon Feb 26 21:29:24 2001
***************
*** 58,64 ****
@@ -84,12 +83,41 @@ diff -c -N ../faces/x11.c ./x11.c
CWBackPixel | CWBorderPixel | CWEventMask, &winattrs) ;
***************
-*** 856,861 ****
---- 861,867 ----
+*** 818,823 ****
+--- 823,830 ----
+ int c, r ; /* Column and row position for this face. */
+ int x, y ; /* Position of start of this text string. */
+ int textwidth ;
++ Colormap cmap ;
++ XColor selcolor ;
+
+ c = column ;
+ r = row ;
+***************
+*** 852,861 ****
+ case RIGHT : x = (c + 1) * imagewidth - textwidth - 2 ;
+ y = (r + 1) * imageheight - 5 ;
+ }
+! XSetFunction(dpy, gc, GXandInverted) ;
+ XFillRectangle(dpy, pr[(int) dtype], gc, x, y-9,
+ (unsigned int) textwidth+2, 13) ;
+! XSetFunction(dpy, gc, GXxor) ;
+ XDrawImageString(dpy, pr[(int) dtype], gc, x, y, str, len) ;
+ XSetFunction(dpy, gc, GXcopy) ;
+ }
+--- 859,873 ----
+ case RIGHT : x = (c + 1) * imagewidth - textwidth - 2 ;
+ y = (r + 1) * imageheight - 5 ;
+ }
+! XSetForeground(dpy, gc, WhitePixel(dpy, screen));
+! XSetFunction(dpy, gc, GXcopy) ;
XFillRectangle(dpy, pr[(int) dtype], gc, x, y-9,
(unsigned int) textwidth+2, 13) ;
- XSetFunction(dpy, gc, GXxor) ;
-+ XSetForeground(dpy, gc, WhitePixel(dpy, screen));
+! XSetFunction(dpy, gc, GXcopy) ;
+! cmap = DefaultColormap(dpy, screen);
+! XParseColor(dpy, cmap, "red", &selcolor);
+! XAllocColor(dpy, cmap, &selcolor) ;
+! XSetForeground(dpy, gc, selcolor.pixel );
XDrawImageString(dpy, pr[(int) dtype], gc, x, y, str, len) ;
XSetFunction(dpy, gc, GXcopy) ;
}
diff --git a/mail/faces/files/patch-ea b/mail/faces/files/patch-ea
new file mode 100644
index 000000000000..d682b048b3b8
--- /dev/null
+++ b/mail/faces/files/patch-ea
@@ -0,0 +1,20 @@
+--- scripts/from.faces.orig Tue Nov 19 05:05:58 1991
++++ scripts/from.faces Sun Feb 18 17:57:50 2001
+@@ -17,7 +17,7 @@
+
+ $cols = 7;
+
+-;# from.faces - alternate, experimental faces script to monitor one's mail
++;# from.faces - alternate, experimental faces script to monitor ones mail
+ ;# spool file
+ ;# Steve Kinzler, kinzler@cs.indiana.edu, 28 Jan 1991
+
+@@ -58,7 +58,7 @@
+ ($from, $wday, $mon, $mday, $time, $year) =
+ split(/\s+/, $hdr{'from'});
+
+-#include "/usr/local/faces/lib/allrc";
++#include "/usr/local/share/faces/lib/allrc";
+
+ $from =~ s/.*<([^>]*)>.*/\1/;
+ $from =~ s/\(.*\)//;