aboutsummaryrefslogtreecommitdiffstats
path: root/mail/fetchmail
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-11-04 18:47:33 +0800
committermiwi <miwi@FreeBSD.org>2009-11-04 18:47:33 +0800
commit62d37077a212296d5e8de941bdfbd69cfa069ca9 (patch)
tree6bfcc25897d51c7f88d90352927c1ca69df82ab3 /mail/fetchmail
parente75cc8d4ab86334b2dc0f36d36e57af1277e2629 (diff)
downloadfreebsd-ports-gnome-62d37077a212296d5e8de941bdfbd69cfa069ca9.tar.gz
freebsd-ports-gnome-62d37077a212296d5e8de941bdfbd69cfa069ca9.tar.zst
freebsd-ports-gnome-62d37077a212296d5e8de941bdfbd69cfa069ca9.zip
- Update to 6.3.13 (updates translations and supports SMTP multiline replies)
- Remove Kerberos IV support, insecure and obsolete - Mark BROKEN if KRB5_HOME is set and invalid - Kill pre-configure, no longer needed - Kill obsolete POP2 from make config menu, still available if given on make command line - Auto-detect KRB5_HOME if it's $LOCALBASE or /usr - MARK_JOBS_SAFE=yes - Cease messing with @cwd in pkg-plist - Reduce asterisks on pkg-message.in, to avoid screen clutter on long $PREFIX Rely on krb-config instead. PR: 140100 Submitted by: Matthias Andree <matthias.andree@gmx.de> Approved by: maintainer
Diffstat (limited to 'mail/fetchmail')
-rw-r--r--mail/fetchmail/Makefile53
-rw-r--r--mail/fetchmail/distinfo6
-rw-r--r--mail/fetchmail/files/patch-configure11
-rw-r--r--mail/fetchmail/files/patch-socket.c15
-rw-r--r--mail/fetchmail/files/pkg-message.in8
-rw-r--r--mail/fetchmail/pkg-plist3
6 files changed, 33 insertions, 63 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index b9c497a97431..f423bdffdda5 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -10,8 +10,7 @@
# want fetchmailconf to work, define WITH_X11
PORTNAME= fetchmail
-PORTVERSION= 6.3.11
-PORTREVISION= 1
+PORTVERSION= 6.3.13
CATEGORIES= mail ipv6
MASTER_SITES= ${MASTER_SITE_BERLIOS} \
http://homepages.uni-paderborn.de/mandree/fetchmail/:ma \
@@ -33,6 +32,7 @@ SUB_FILES= pkg-message
USE_BZIP2= yes
USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
GNU_CONFIGURE= yes
USE_OPENSSL= yes
CONFIGURE_ARGS= --enable-opie --enable-RPA --enable-SDPS \
@@ -46,8 +46,7 @@ MLINKS= fetchmail.1 fetchmailconf.1
OPTIONS= X11 "Python/Tkinter dependencies for fetchmailconf" off \
NLS "National language support (NLS)." on \
NTLM "Build in support for NTLM/MSN authentication." off \
- POP2 "Build pop2 support (obsolete)." off \
- GSSAPI "Build GSSAPI support (requires KRB5_HOME to be set)" off
+ GSSAPI "Build GSSAPI/Kerberos 5 support" off
.include <bsd.port.options.mk>
@@ -78,20 +77,22 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.if defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libkrb5.a)
-CONFIGURE_ARGS += --with-kerberos5=${KRB5_HOME}
-
-.if defined(WITH_GSSAPI)
-CONFIGURE_ARGS+=--with-gssapi=${KRB5_HOME}
+.if !defined(KRB5_HOME)
+.if exists(${LOCALBASE}/lib/libkrb5.a)
+KRB5_HOME= ${LOCALBASE}
+.elif exists(/usr/lib/libkrb5.a)
+KRB5_HOME= /usr
+.endif
.endif
-.elif exists(/usr/lib/libkrb.a) && defined(MAKE_KERBEROS4)
-CONFIGURE_ARGS += --with-kerberos=/usr
+.if defined(KRB5_HOME) && !exists(${KRB5_HOME}/lib/libkrb5.a)
+BROKEN= KRB5_HOME is set but doesn't provide lib/libkrb5.a
+.endif
.if defined(WITH_GSSAPI)
-CONFIGURE_ARGS+=--with-gssapi=/usr
+.if defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libkrb5.a)
+CONFIGURE_ARGS += --with-gssapi=${KRB5_HOME}
.endif
-
.endif
.if defined(WITH_NTLM)
@@ -109,32 +110,6 @@ pre-patch:
@${REINPLACE_CMD} -e "s,@LOCALBASE@,${LOCALBASE},g" \
${WRKDIR}/fetchmailconf
-pre-configure:
-
- @${ECHO_CMD} ""
-
-.if defined(KRB5_HOME)
- @${ECHO_CMD} "Using Kerberos V support in ${KRB5_HOME}."
-.else
- @${ECHO_CMD} "Use KRB5_HOME=<directory> to enable Kerberos V support in <directory> (usually /usr)."
-.endif
-
-.if defined(WITH_GSSAPI)
-.if defined(KRB5_HOME)
- @${ECHO_CMD} "Enabling GSSAPI support in ${KRB5_HOME}."
-.elif defined(MAKE_KERBEROS4)
-.if exists(/usr/lib/libkrb.a)
- @${ECHO_CMD} "Enabling GSSAPI support in /usr."
-.else
- @${ECHO_CMD} "Unable to detect Kerberos in your system. Disabling GSSAPI support."
-.endif
-.else
- @${ECHO_CMD} "GSSAPI requires Kerberos, but Kerberos is disabled."
-.endif
-.endif
-
- @${ECHO_CMD} ""
-
pre-su-install:
@${SETENV} ${SCRIPTS_ENV} PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
diff --git a/mail/fetchmail/distinfo b/mail/fetchmail/distinfo
index d95592c18ee6..01536d98bc9f 100644
--- a/mail/fetchmail/distinfo
+++ b/mail/fetchmail/distinfo
@@ -1,3 +1,3 @@
-MD5 (fetchmail-6.3.11.tar.bz2) = 43b28f296cc0024d3c727319eacae324
-SHA256 (fetchmail-6.3.11.tar.bz2) = ba679cef82b9520bc5dbe9e2e54381e488b5712faf885deb7612393b5ab80c6f
-SIZE (fetchmail-6.3.11.tar.bz2) = 1608923
+MD5 (fetchmail-6.3.13.tar.bz2) = db792fb311bc358e95ed0437389269ac
+SHA256 (fetchmail-6.3.13.tar.bz2) = 206a299f7ced9d7359621cc8e590a22f9cfc9c713696474e2119a1340c2e98ee
+SIZE (fetchmail-6.3.13.tar.bz2) = 1614718
diff --git a/mail/fetchmail/files/patch-configure b/mail/fetchmail/files/patch-configure
new file mode 100644
index 000000000000..5ff84c46207a
--- /dev/null
+++ b/mail/fetchmail/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2009-10-30 10:40:08.971594149 +0100
++++ configure 2009-10-30 10:40:19.438656862 +0100
+@@ -14747,7 +14747,7 @@
+ _ACEOF
+
+ if test "$with_gssapi" != yes ; then
+- CPPFLAGS="$CPPFLAGS-I$with_gssapi/include"
++ CPPFLAGS="$CPPFLAGS -I$with_gssapi/include"
+ fi
+
+
diff --git a/mail/fetchmail/files/patch-socket.c b/mail/fetchmail/files/patch-socket.c
deleted file mode 100644
index 1220421515a1..000000000000
--- a/mail/fetchmail/files/patch-socket.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- socket.c.org 2009-08-08 16:01:49.000000000 +0200
-+++ socket.c 2009-08-08 16:03:17.000000000 +0200
-@@ -628,9 +628,10 @@
- report(stdout, GT_("Unknown Issuer CommonName\n"));
- }
- if ((i = X509_NAME_get_text_by_NID(subj, NID_commonName, buf, sizeof(buf))) != -1) {
-- if (outlevel >= O_VERBOSE)
-+ if (outlevel >= O_VERBOSE) {
- report(stdout, GT_("Server CommonName: %s\n"), (tt = sdump(buf, i)));
-- xfree(tt);
-+ xfree(tt);
-+ }
- if ((size_t)i >= sizeof(buf) - 1) {
- /* Possible truncation. In this case, this is a DNS name, so this
- * is really bad. We do not tolerate this even in the non-strict case. */
diff --git a/mail/fetchmail/files/pkg-message.in b/mail/fetchmail/files/pkg-message.in
index 7d79aa709075..94684dc86b12 100644
--- a/mail/fetchmail/files/pkg-message.in
+++ b/mail/fetchmail/files/pkg-message.in
@@ -1,4 +1,4 @@
-*********************************************************************
-*** For pointers how to configure fetchmail in daemon mode ***
-*** please consult %%PREFIX%%/etc/rc.d/fetchmail. ***
-*********************************************************************
+******************************************************
+For pointers how to configure fetchmail in daemon mode
+please consult %%PREFIX%%/etc/rc.d/fetchmail.
+******************************************************
diff --git a/mail/fetchmail/pkg-plist b/mail/fetchmail/pkg-plist
index d72f0766e271..935f24ef95ae 100644
--- a/mail/fetchmail/pkg-plist
+++ b/mail/fetchmail/pkg-plist
@@ -39,6 +39,5 @@ libexec/fetchmailconf.py
@unexec if cmp -s %D/etc/fetchmailrc.sample %D/etc/fetchmailrc; then rm -f %D/etc/fetchmailrc; fi
etc/fetchmailrc.sample
@exec if [ ! -f %D/etc/fetchmailrc ] ; then cp -p %D/%F %B/fetchmailrc; fi
-@cwd /
@unexec rm -f /var/run/fetchmail/fetchmail.pid 2>/dev/null || true
-@dirrm /var/run/fetchmail
+@unexec rmdir /var/run/fetchmail 2>/dev/null || true