aboutsummaryrefslogtreecommitdiffstats
path: root/mail/fetchmail
diff options
context:
space:
mode:
authorbarner <barner@FreeBSD.org>2005-12-12 05:24:18 +0800
committerbarner <barner@FreeBSD.org>2005-12-12 05:24:18 +0800
commit321a0a0e48f43b507a085bd9906398d06c6dc2b6 (patch)
tree545dece7bb8b8f4d2f1ebd42998aba69d861ebe1 /mail/fetchmail
parentfa5c892be69b152d19ce7253d56f6b457ba050d5 (diff)
downloadfreebsd-ports-gnome-321a0a0e48f43b507a085bd9906398d06c6dc2b6.tar.gz
freebsd-ports-gnome-321a0a0e48f43b507a085bd9906398d06c6dc2b6.tar.zst
freebsd-ports-gnome-321a0a0e48f43b507a085bd9906398d06c6dc2b6.zip
- Fix a null pointer dereference in multi-drop mode [1]
- Fix packaging if python is not present at compile time [2] - Sort targets in Makefile - Fix variable in the WITH_X11 case - Bump PORTREVISION (for [1]) Submitted by: Andreas Haakh <bugReporter@Haakh.de> [1] Reviewed by: Matthias Andree <matthias.andree@gmx.de> (upstream maintainer) [1] Reported by: pointyhat via kris [2]
Diffstat (limited to 'mail/fetchmail')
-rw-r--r--mail/fetchmail/Makefile20
-rw-r--r--mail/fetchmail/files/patch-Makefile.in26
-rw-r--r--mail/fetchmail/files/patch-checkalias.c14
3 files changed, 37 insertions, 23 deletions
diff --git a/mail/fetchmail/Makefile b/mail/fetchmail/Makefile
index 2b06079e06b8..27dd93ce9f3f 100644
--- a/mail/fetchmail/Makefile
+++ b/mail/fetchmail/Makefile
@@ -11,7 +11,7 @@
PORTNAME= fetchmail
PORTVERSION= 6.3.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail ipv6
MASTER_SITES= http://download.berlios.de/%SUBDIR%/ \
http://home.pages.de/~mandree/%SUBDIR%/ \
@@ -81,13 +81,6 @@ pre-patch:
@${CP} ${FILESDIR}/fetchmailconf ${WRKDIR}/fetchmailconf
@${REINPLACE_CMD} -e "s,@LOCALBASE@,${LOCALBASE},g" \
${WRKDIR}/fetchmailconf
-post-install:
-.if !defined(NOPORTDOCS)
- ${INSTALL} -d -m 555 -o ${DOCOWN} -g ${DOCGRP} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
-.endif
-
- ${INSTALL_SCRIPT} ${WRKDIR}/fetchmailconf ${PREFIX}/bin
pre-configure:
.if defined(WITH_NTLM)
@@ -96,7 +89,7 @@ pre-configure:
@${ECHO_CMD} "Add -DWITH_NTLM to add support for NTLM/MSN authentication."
.endif
.if defined(WITH_X11)
- @${ECHO_CMD) "Adding Python/Tkinter dependencies for fetchmailconf."
+ @${ECHO_CMD} "Adding Python/Tkinter dependencies for fetchmailconf."
.else
@${ECHO_CMD} "Add -DWITH_X11 to add Python/Tkinter dependencies for fetchmailconf."
.endif
@@ -106,4 +99,13 @@ pre-configure:
@${ECHO_CMD} "You can use -DWITHOUT_NLS to suppress national language support (NLS)."
.endif
+post-install:
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -m 555 -o ${DOCOWN} -g ${DOCGRP} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+ ${INSTALL_SCRIPT} ${WRKDIR}/fetchmailconf ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/fetchmailconf.py ${PREFIX}/libexec
+
.include <bsd.port.post.mk>
diff --git a/mail/fetchmail/files/patch-Makefile.in b/mail/fetchmail/files/patch-Makefile.in
index 601acf6e3e46..45ac0da45747 100644
--- a/mail/fetchmail/files/patch-Makefile.in
+++ b/mail/fetchmail/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Sat Sep 17 15:19:44 2005
-+++ Makefile.in Tue Sep 20 15:11:33 2005
+--- Makefile.in.orig Thu Dec 1 00:33:52 2005
++++ Makefile.in Sun Dec 11 21:58:15 2005
@@ -29,7 +29,7 @@
INSTALL = @INSTALL@
install_sh_DATA = $(install_sh) -c -m 644
@@ -9,23 +9,21 @@
INSTALL_HEADER = $(INSTALL_DATA)
transform = $(program_transform_name)
NORMAL_INSTALL = :
-@@ -837,23 +837,16 @@
+@@ -864,24 +864,6 @@
+ rm -f y.tab.c
uninstall-info-am:
install-pythonPYTHON: $(python_PYTHON)
- @$(NORMAL_INSTALL)
+- @$(NORMAL_INSTALL)
- test -z "$(pythondir)" || $(mkdir_p) "$(DESTDIR)$(pythondir)"
-+ $(mkdir_p) "$(libexecdir)"
- @list='$(python_PYTHON)'; dlist=''; for p in $$list; do\
- if test -f "$$p"; then b=; else b="$(srcdir)/"; fi; \
- if test -f $$b$$p; then \
- f=$(am__strip_dir) \
- dlist="$$dlist $$f"; \
+- @list='$(python_PYTHON)'; dlist=''; for p in $$list; do\
+- if test -f "$$p"; then b=; else b="$(srcdir)/"; fi; \
+- if test -f $$b$$p; then \
+- f=$(am__strip_dir) \
+- dlist="$$dlist $$f"; \
- echo " $(pythonPYTHON_INSTALL) '$$b$$p' '$(DESTDIR)$(pythondir)/$$f'"; \
- $(pythonPYTHON_INSTALL) "$$b$$p" "$(DESTDIR)$(pythondir)/$$f"; \
-+ echo " $(install_sh_SCRIPT) '$$b$$p' '$(libexecdir)/$$f'"; \
-+ $(install_sh_SCRIPT) "$$b$$p" "$(libexecdir)/$$f"; \
- else :; fi; \
- done; \
+- else :; fi; \
+- done; \
- if test -n "$$dlist"; then \
- if test -z "$(DESTDIR)"; then \
- PYTHON=$(PYTHON) $(py_compile) --basedir "$(pythondir)" $$dlist; \
diff --git a/mail/fetchmail/files/patch-checkalias.c b/mail/fetchmail/files/patch-checkalias.c
new file mode 100644
index 000000000000..1f6325ad7066
--- /dev/null
+++ b/mail/fetchmail/files/patch-checkalias.c
@@ -0,0 +1,14 @@
+--- checkalias.c.orig Thu Dec 1 00:33:18 2005
++++ checkalias.c Sun Dec 11 14:32:33 2005
+@@ -155,10 +155,11 @@
+ */
+ memset(&hints, 0, sizeof hints);
+ hints.ai_family=AF_UNSPEC;
+ hints.ai_protocol=PF_UNSPEC;
+ hints.ai_socktype=SOCK_STREAM;
++ hints.ai_flags=AI_CANONNAME;
+
+ e = getaddrinfo(name, NULL, &hints, &res);
+ if (e == 0)
+ {
+ int rr = (strcasecmp(ctl->server.truename, res->ai_canonname) == 0);