aboutsummaryrefslogtreecommitdiffstats
path: root/mail/getmail
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2003-06-21 16:39:40 +0800
committererwin <erwin@FreeBSD.org>2003-06-21 16:39:40 +0800
commit873a8183008e57af9a1ded187ad8a907c8b95f82 (patch)
tree87a9ecc36ca219f5778d50456ad8c1f8b724ae5c /mail/getmail
parentd719bd3cfbc551d6ed22ba3bb04e5ba0fa9535de (diff)
downloadfreebsd-ports-gnome-873a8183008e57af9a1ded187ad8a907c8b95f82.tar.gz
freebsd-ports-gnome-873a8183008e57af9a1ded187ad8a907c8b95f82.tar.zst
freebsd-ports-gnome-873a8183008e57af9a1ded187ad8a907c8b95f82.zip
- Update to 3.1.7
- Reword COMMENT and rewrite and update pkg-descr - Install additional documentation - Use macros in pkg-plist - Take maintainership PR: 53547 Submitted by: Sergei Kolobov <sergei@kolobov.com>
Diffstat (limited to 'mail/getmail')
-rw-r--r--mail/getmail/Makefile24
-rw-r--r--mail/getmail/distinfo2
-rw-r--r--mail/getmail/pkg-descr20
-rw-r--r--mail/getmail/pkg-plist38
4 files changed, 54 insertions, 30 deletions
diff --git a/mail/getmail/Makefile b/mail/getmail/Makefile
index 5aec32d42c0c..39ea57fffebf 100644
--- a/mail/getmail/Makefile
+++ b/mail/getmail/Makefile
@@ -6,34 +6,38 @@
#
PORTNAME= getmail
-PORTVERSION= 3.1.0
+PORTVERSION= 3.1.7
CATEGORIES= mail python
MASTER_SITES= http://www.qcc.ca/~charlesc/software/getmail-3.0/%SUBDIR%/
+MASTER_SITE_SUBDIR= . old-versions
-MAINTAINER= ports@FreeBSD.org
-COMMENT= POP3 mail retriever written in Python
+MAINTAINER= sergei@kolobov.com
+COMMENT= POP3 mail retriever with reliable Maildir and command delivery
USE_PYTHON= yes
USE_REINPLACE= yes
NO_BUILD= yes
-DOCS= CHANGELOG docs.txt faq.txt getmail.txt
+SCRIPTS= getmail getmail_maildir getmail_mbox
+MAN1= getmail.1
+DOCS= CHANGELOG THANKS TODO docs.txt faq.txt getmail.txt \
+ docs.html faq.html
post-patch:
- @${REINPLACE_CMD} -e 's!/usr/lib/getmail!${DATADIR}!' \
- -e 's!`which python`!${PYTHON_CMD}!' ${WRKSRC}/getmail
+ @cd ${WRKSRC} && \
+ ${REINPLACE_CMD} -e 's!/usr/lib/getmail!${DATADIR}!' \
+ -e 's!/usr/bin/python!${PYTHON_CMD}!' ${SCRIPTS}
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/getmail ${PREFIX}/bin
+ cd ${WRKSRC} && ${INSTALL_SCRIPT} ${SCRIPTS} ${PREFIX}/bin
+ cd ${WRKSRC} && ${INSTALL_MAN} ${MAN1} ${MANPREFIX}/man/man1
@${MKDIR} ${DATADIR}
${INSTALL_SCRIPT} ${WRKSRC}/*.py ${DATADIR}
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/getmailrc-example ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
-.for file in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/mail/getmail/distinfo b/mail/getmail/distinfo
index fd7f7444ee67..48c8c373fc36 100644
--- a/mail/getmail/distinfo
+++ b/mail/getmail/distinfo
@@ -1 +1 @@
-MD5 (getmail-3.1.0.tar.gz) = 3b461145a3516ff9a81b310ea70ac92d
+MD5 (getmail-3.1.7.tar.gz) = e5bffd36858ed4cdc98236b3b1f50594
diff --git a/mail/getmail/pkg-descr b/mail/getmail/pkg-descr
index cd4861624a3e..a79ac8ae2b40 100644
--- a/mail/getmail/pkg-descr
+++ b/mail/getmail/pkg-descr
@@ -1,4 +1,18 @@
-POP3 mail retriever written in Python. getmail includes many features
-similiar to fetchmail and intends to be a complete replacement.
+A POP3 mail retriever with reliable Maildir and command delivery.
-WWW: http://www.qcc.sk.ca/~charlesc/software/getmail-2.0/
+Summary of features:
+- Retrieve mail from an unlimited number of POP3 mailboxes and servers.
+- Support for multidrop or domain mailboxes.
+- Safe and reliable delivery to qmail-style Maildirs, as well as program
+ (pipe) delivery for use with arbitrary external MDAs. Includes an MDA
+ for mbox files that supports mboxrd format and fcntl-type flock locking.
+- Does not destroy information by rewriting mail headers.
+- Does not cause mail loops by doing SMTP injection, and therefore does
+ not require that you run an MTA (like qmail or sendmail) on your host.
+- Can remember which mail it has already retrieved, and can be set to
+ only download new messages.
+- Written in Python, and therefore easy to extend or customize.
+- Simple to install, configure, and use.
+
+Author: Charles Cazabon <getmail@discworld.dyndns.org>
+WWW: http://www.qcc.sk.ca/~charlesc/software/getmail-3.0/
diff --git a/mail/getmail/pkg-plist b/mail/getmail/pkg-plist
index ad14b4b5ab86..b3f5091befdc 100644
--- a/mail/getmail/pkg-plist
+++ b/mail/getmail/pkg-plist
@@ -1,17 +1,23 @@
bin/getmail
-%%PORTDOCS%%share/doc/getmail/CHANGELOG
-%%PORTDOCS%%share/doc/getmail/docs.txt
-%%PORTDOCS%%share/doc/getmail/faq.txt
-%%PORTDOCS%%share/doc/getmail/getmail.txt
-share/examples/getmail/getmailrc-example
-share/getmail/ConfParser.py
-share/getmail/getmail.py
-share/getmail/getmail_classes.py
-share/getmail/getmail_constants.py
-share/getmail/getmail_defaults.py
-share/getmail/getmail_mbox.py
-share/getmail/getmail_utilities.py
-share/getmail/timeoutsocket.py
-@dirrm share/getmail
-@dirrm share/examples/getmail
-%%PORTDOCS%%@dirrm share/doc/getmail
+bin/getmail_maildir
+bin/getmail_mbox
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
+%%PORTDOCS%%%%DOCSDIR%%/THANKS
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/docs.html
+%%PORTDOCS%%%%DOCSDIR%%/docs.txt
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/faq.txt
+%%PORTDOCS%%%%DOCSDIR%%/getmail.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%EXAMPLESDIR%%/getmailrc-example
+@dirrm %%EXAMPLESDIR%%
+%%DATADIR%%/ConfParser.py
+%%DATADIR%%/getmail.py
+%%DATADIR%%/getmail_classes.py
+%%DATADIR%%/getmail_constants.py
+%%DATADIR%%/getmail_defaults.py
+%%DATADIR%%/getmail_mbox.py
+%%DATADIR%%/getmail_utilities.py
+%%DATADIR%%/timeoutsocket.py
+@dirrm %%DATADIR%%