aboutsummaryrefslogtreecommitdiffstats
path: root/mail/getmail
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2011-03-18 10:27:04 +0800
committermandree <mandree@FreeBSD.org>2011-03-18 10:27:04 +0800
commitf6cabc7c2373bac0a0bb6bddde3a6643068c2561 (patch)
tree379a9241609f0143d48f65c166541702e633710b /mail/getmail
parent21c814ecf0e880659dd526dbc33ffdfc98ef9df3 (diff)
downloadfreebsd-ports-gnome-f6cabc7c2373bac0a0bb6bddde3a6643068c2561.tar.gz
freebsd-ports-gnome-f6cabc7c2373bac0a0bb6bddde3a6643068c2561.tar.zst
freebsd-ports-gnome-f6cabc7c2373bac0a0bb6bddde3a6643068c2561.zip
Don't mark messages retrieved through IMAP as \Seen.
PR: ports/155644 Submitted by: Matthias Andree Approved by: Linh Pham (maintainer)
Diffstat (limited to 'mail/getmail')
-rw-r--r--mail/getmail/Makefile1
-rw-r--r--mail/getmail/files/patch-getmailcore___retrieverbases.py16
2 files changed, 17 insertions, 0 deletions
diff --git a/mail/getmail/Makefile b/mail/getmail/Makefile
index 363a12895057..68280148df6e 100644
--- a/mail/getmail/Makefile
+++ b/mail/getmail/Makefile
@@ -7,6 +7,7 @@
PORTNAME= getmail
PORTVERSION= 4.20.0
+PORTREVISION= 1
CATEGORIES= mail python
MASTER_SITES= http://pyropus.ca/software/getmail/%SUBDIR%/ \
http://mirrors.closedsrc.org/getmail/
diff --git a/mail/getmail/files/patch-getmailcore___retrieverbases.py b/mail/getmail/files/patch-getmailcore___retrieverbases.py
new file mode 100644
index 000000000000..3423c356a7db
--- /dev/null
+++ b/mail/getmail/files/patch-getmailcore___retrieverbases.py
@@ -0,0 +1,16 @@
+--- ./getmailcore/_retrieverbases.py.orig 2010-06-29 18:03:42.000000000 +0200
++++ ./getmailcore/_retrieverbases.py 2011-03-18 00:25:54.000000000 +0100
+@@ -898,11 +898,11 @@
+
+ def _getmsgbyid(self, msgid):
+ self.log.trace()
+- return self._getmsgpartbyid(msgid, '(RFC822)')
++ return self._getmsgpartbyid(msgid, '(BODY.PEEK[])')
+
+ def _getheaderbyid(self, msgid):
+ self.log.trace()
+- return self._getmsgpartbyid(msgid, '(RFC822[header])')
++ return self._getmsgpartbyid(msgid, '(BODY.PEEK[header])')
+
+ def initialize(self):
+ self.log.trace()