aboutsummaryrefslogtreecommitdiffstats
path: root/mail/gmime2-sharp/Makefile
diff options
context:
space:
mode:
authortmclaugh <tmclaugh@FreeBSD.org>2005-10-05 10:17:58 +0800
committertmclaugh <tmclaugh@FreeBSD.org>2005-10-05 10:17:58 +0800
commited4c529a2c229458cc6cd2616f2791c8d4513749 (patch)
tree44b3acf8a4a8c0c7f7e59dc92192eb1623c5ae0c /mail/gmime2-sharp/Makefile
parent463dc530adb5b853cb4970fa55e6a975c0cfb089 (diff)
downloadfreebsd-ports-gnome-ed4c529a2c229458cc6cd2616f2791c8d4513749.tar.gz
freebsd-ports-gnome-ed4c529a2c229458cc6cd2616f2791c8d4513749.tar.zst
freebsd-ports-gnome-ed4c529a2c229458cc6cd2616f2791c8d4513749.zip
- Add gmime2-sharp, slave port of gmime2. This port provides the C#
bindings to the gmime2 library. Approved by: ahze (mentor)
Diffstat (limited to 'mail/gmime2-sharp/Makefile')
-rw-r--r--mail/gmime2-sharp/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/mail/gmime2-sharp/Makefile b/mail/gmime2-sharp/Makefile
new file mode 100644
index 000000000000..aa09a73756cd
--- /dev/null
+++ b/mail/gmime2-sharp/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: gmime2-sharp
+# Date Created: 20050513
+# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
+#
+# $FreeBSD$
+# $Id: Makefile,v 1.9 2005/09/25 00:56:46 tmclau02 Exp $
+#
+
+PORTREVISION= 0
+CATEGORIES= mail
+PKGNAMESUFFIX= -sharp
+
+MAINTAINER= bsd-sharp-list@forge.novell.com
+COMMENT= Mono bindings for gmime
+
+LIB_DEPENDS= gmime-2.0.3:${PORTSDIR}/mail/gmime2
+BUILD_DEPENDS= gapi2-parser:${PORTSDIR}/x11-toolkits/gtk-sharp20
+RUN_DEPENDS= gapi2-parser:${PORTSDIR}/x11-toolkits/gtk-sharp20
+
+MASTERDIR= ${.CURDIR}/../gmime2
+BUILD_WRKSRC= ${WRKSRC}/mono
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+USE_GNOME= gnomehack gnometarget glib20
+USE_REINPLACE= yes
+CONFIGURE_ARGS= --enable-mono=yes
+
+# Else we conflict with mail/gmime2
+NOPORTDOCS= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|.@GMIME_VERSION@||g' \
+ ${WRKSRC}/mono/gmime-sharp.dll.config.in
+ @${REINPLACE_CMD} -e 's|libglib-2.0.so.0|libglib-2.0.so|g' \
+ ${WRKSRC}/mono/ObjectStream.cs ${WRKSRC}/mono/Object.custom
+
+.include "${MASTERDIR}/Makefile"