aboutsummaryrefslogtreecommitdiffstats
path: root/mail/gmime2-sharp
diff options
context:
space:
mode:
authortmclaugh <tmclaugh@FreeBSD.org>2005-10-05 10:17:58 +0800
committertmclaugh <tmclaugh@FreeBSD.org>2005-10-05 10:17:58 +0800
commited4c529a2c229458cc6cd2616f2791c8d4513749 (patch)
tree44b3acf8a4a8c0c7f7e59dc92192eb1623c5ae0c /mail/gmime2-sharp
parent463dc530adb5b853cb4970fa55e6a975c0cfb089 (diff)
downloadfreebsd-ports-gnome-ed4c529a2c229458cc6cd2616f2791c8d4513749.tar.gz
freebsd-ports-gnome-ed4c529a2c229458cc6cd2616f2791c8d4513749.tar.zst
freebsd-ports-gnome-ed4c529a2c229458cc6cd2616f2791c8d4513749.zip
- Add gmime2-sharp, slave port of gmime2. This port provides the C#
bindings to the gmime2 library. Approved by: ahze (mentor)
Diffstat (limited to 'mail/gmime2-sharp')
-rw-r--r--mail/gmime2-sharp/Makefile39
-rw-r--r--mail/gmime2-sharp/pkg-descr3
-rw-r--r--mail/gmime2-sharp/pkg-plist10
3 files changed, 52 insertions, 0 deletions
diff --git a/mail/gmime2-sharp/Makefile b/mail/gmime2-sharp/Makefile
new file mode 100644
index 000000000000..aa09a73756cd
--- /dev/null
+++ b/mail/gmime2-sharp/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: gmime2-sharp
+# Date Created: 20050513
+# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
+#
+# $FreeBSD$
+# $Id: Makefile,v 1.9 2005/09/25 00:56:46 tmclau02 Exp $
+#
+
+PORTREVISION= 0
+CATEGORIES= mail
+PKGNAMESUFFIX= -sharp
+
+MAINTAINER= bsd-sharp-list@forge.novell.com
+COMMENT= Mono bindings for gmime
+
+LIB_DEPENDS= gmime-2.0.3:${PORTSDIR}/mail/gmime2
+BUILD_DEPENDS= gapi2-parser:${PORTSDIR}/x11-toolkits/gtk-sharp20
+RUN_DEPENDS= gapi2-parser:${PORTSDIR}/x11-toolkits/gtk-sharp20
+
+MASTERDIR= ${.CURDIR}/../gmime2
+BUILD_WRKSRC= ${WRKSRC}/mono
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+USE_GNOME= gnomehack gnometarget glib20
+USE_REINPLACE= yes
+CONFIGURE_ARGS= --enable-mono=yes
+
+# Else we conflict with mail/gmime2
+NOPORTDOCS= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|.@GMIME_VERSION@||g' \
+ ${WRKSRC}/mono/gmime-sharp.dll.config.in
+ @${REINPLACE_CMD} -e 's|libglib-2.0.so.0|libglib-2.0.so|g' \
+ ${WRKSRC}/mono/ObjectStream.cs ${WRKSRC}/mono/Object.custom
+
+.include "${MASTERDIR}/Makefile"
diff --git a/mail/gmime2-sharp/pkg-descr b/mail/gmime2-sharp/pkg-descr
new file mode 100644
index 000000000000..a2b58ba7ef0f
--- /dev/null
+++ b/mail/gmime2-sharp/pkg-descr
@@ -0,0 +1,3 @@
+C# assemblies for gmime
+
+WWW: http://spruce.sourceforge.net/gmime/
diff --git a/mail/gmime2-sharp/pkg-plist b/mail/gmime2-sharp/pkg-plist
new file mode 100644
index 000000000000..9e528480a64d
--- /dev/null
+++ b/mail/gmime2-sharp/pkg-plist
@@ -0,0 +1,10 @@
+lib/mono/gac/gmime-sharp/2.0.0.0__677013d4cb5910f0/gmime-sharp.dll
+lib/mono/gac/gmime-sharp/2.0.0.0__677013d4cb5910f0/gmime-sharp.dll.config
+lib/mono/gmime-sharp/gmime-sharp.dll
+lib/mono/gmime-sharp/gmime-sharp.dll.config
+lib/mono/gmime-sharp/gmime-sharp.dll.mdb
+libdata/pkgconfig/gmime-sharp.pc
+share/gapi-2.0/gmime-api.xml
+@dirrm lib/mono/gmime-sharp
+@dirrm lib/mono/gac/gmime-sharp/2.0.0.0__677013d4cb5910f0
+@dirrm lib/mono/gac/gmime-sharp
td>kwm2012-12-173-12/+8 * Fix typos and make small modifications in COMMENT (according to Porter'scs2012-08-031-1/+1 * Update to 3.37.kwm2012-07-182-3/+3 * Update to 3.35.kwm2012-05-063-27/+4 * Update to 3.32.2kwm2012-02-143-3/+5 * Update to 3.29kwm2011-10-233-4/+12 * Remove USE_GNOME=gnometarget from ports. It has been a empty keyword sincekwm2011-08-121-1/+1 * Update to 3.25.kwm2011-04-082-3/+3 * Update to 3.24.2.kwm2011-03-022-3/+3 * Update to 3.24.1.kwm2011-02-252-3/+3 * Update to 3.23.kwm2010-12-052-3/+3 * Update to 3.22.kwm2010-11-133-5/+6 * Update to 3.21.kwm2010-10-033-4/+5 * Update to 3.20.kwm2010-10-013-4/+7 * Update to 3.19.kwm2010-08-022-4/+4 * Update to 3.18.kwm2010-07-273-4/+12 * Update to 3.17.kwm2010-06-162-5/+6 * Bounce PORTREVISION for gettext-related ports. Have fun, ya'll.ade2010-05-311-0/+1 * Drop build dependancy on xmlproc_parse. Its not needed.kwm2010-05-281-2/+0 * Update to 3.16.kwm2010-05-213-4/+16 * Update to 3.11.1.kwm2009-11-024-5/+7 * Update to 3.11.kwm2009-10-023-38/+4 * Update to 3.10.3.kwm2009-09-052-4/+4 * Update to 3.10.2.kwm2009-08-133-4/+14 * Update to 3.10.1.kwm2009-07-122-4/+4 * Update to 3.10.kwm2009-06-022-4/+4 * Update to 3.9.kwm2009-05-133-6/+6 * Update to 3.8.kwm2009-04-123-4/+5 * Update to 3.7.kwm2009-03-103-4/+10 * Update to 3.6.kwm2009-03-023-6/+13 * Don't delete mtree generated directorieskwm2008-08-112-20/+1 * Update to 3.2.kwm2008-08-093-5/+26 * - Update to 3.1miwi2008-07-183-10/+6 * Bump portrevision due to upgrade of devel/gettext.edwin2008-06-061-1/+1 * Major autotools-related update:ade2008-06-062-2/+1 * - Update to 2.0tabthorpe2008-03-152-8/+6 * - Update to 1.9tabthorpe2008-02-115-132/+4 * - Update to 1.8tabthorpe2008-01-102-5/+4 * - Fix parse error under 7.0-RC1/sparc64tabthorpe2008-01-033-0/+21 * - Add mirrorsitetabthorpe2007-12-311-1/+3 * - Update to 1.7tabthorpe2007-12-303-4/+5 * - Update to 1.6tabthorpe2007-12-203-14/+8 * - Update to 1.5tabthorpe2007-10-073-5/+92 * - Clean up rw locate dir. Fixes leftover files for package userspav2007-10-042-0/+3 * - update to 1.4tabthorpe2007-08-302-4/+4 * - change maintainer address on ports I maintaintabthorpe2007-08-231-1/+1 * - Update to latest version - 1.3beech2007-07-304-27/+14 * Reset rainer.alves@gmail.com by request due to current lack of time tolinimon2007-06-301-1/+1 * - Welcome X.org 7.2 \o/.flz2007-05-202-42/+1 * - Update to 0.58miwi2006-12-063-5/+8 * - Update to 0.53bsam2006-09-244-33/+9 * Fix WRKSRC so port builds after previous update.shaun2006-06-221-1/+1 * - Update to 0.51.1.1 -> make fetchable again.shaun2006-06-223-5/+8 * - Update to 0.51pav2006-05-093-7/+11 * - Update to 0.50pav2006-04-258-51/+132 * Reset kwm due to no response about email.linimon2006-04-151-1/+1 * SHA256ifyedwin2006-01-221-0/+1 * eplace ugly "@unexec rmdir %D... 2>/dev/null || true" with @dirrmtryedwin2006-01-221-114/+114 * Fix plistkwm2005-10-221-2/+0 * Update 0.48.kwm2005-10-198-101/+69 * Portmgr was right in that the distfile HAS disappeared, and thereadamw2005-10-131-6/+4 * Mark as BROKEN: distfile needs to be updated.linimon2005-10-121-0/+4 * Be sure to create libdata/pkgconfig since this was only added to mtreemarcus2005-06-281-1/+2 * - libdata/pkgconfig is now included in mtreepav2005-05-172-2/+0 * Fix plist.kwm2005-04-252-4/+6 * Update to 0.46.kwm2005-04-132-8/+8 * At Kris's request, back out the MACHINE_ARCH spelling correction untilobrien2005-04-121-1/+1 * Assist getting more ports working on AMD64 by obeying theobrien2005-04-111-1/+1 * Fix fetch.kwm2005-04-081-1/+1