aboutsummaryrefslogtreecommitdiffstats
path: root/mail/greyfix/Makefile
diff options
context:
space:
mode:
authorsahil <sahil@FreeBSD.org>2011-05-21 11:01:54 +0800
committersahil <sahil@FreeBSD.org>2011-05-21 11:01:54 +0800
commitaa26b50b50fa820936f03df0eb003a2d03025baa (patch)
treed0009b4b2614c60fa2ad64390dee49dc7c7fc0d6 /mail/greyfix/Makefile
parent951663e044dd6853c0d449de28871b3f34245825 (diff)
downloadfreebsd-ports-gnome-aa26b50b50fa820936f03df0eb003a2d03025baa.tar.gz
freebsd-ports-gnome-aa26b50b50fa820936f03df0eb003a2d03025baa.tar.zst
freebsd-ports-gnome-aa26b50b50fa820936f03df0eb003a2d03025baa.zip
Greyfix is the greylisting policy daemon for Postfix written by Kim Minh
Kaplan. Greyfix uses Postfix policy mechanism to enable greylisting with Postfix. WWW: http://www.kim-minh.com/pub/greyfix/ PR: ports/157052 Submitted by: Keith Gaughan <k@stereochro.me>
Diffstat (limited to 'mail/greyfix/Makefile')
-rw-r--r--mail/greyfix/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/mail/greyfix/Makefile b/mail/greyfix/Makefile
new file mode 100644
index 000000000000..bc0c126fc947
--- /dev/null
+++ b/mail/greyfix/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: greyfix
+# Date created: 2011-05-14
+# Whom: Keith Gaughan <k@stereochro.me>
+#
+# $FreeBSD$
+#
+
+PORTNAME= greyfix
+PORTVERSION= 0.3.9
+CATEGORIES= mail
+MASTER_SITES= http://www.kim-minh.com/pub/greyfix/
+
+MAINTAINER= k@stereochro.me
+COMMENT= A greylisting policy daemon for Postfix
+
+SUB_FILES= pkg-message
+
+USE_BDB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-berkeleydb-libdir=${BDB_LIB_DIR} \
+ --with-berkeleydb-includedir=${BDB_INCLUDE_DIR} \
+ --localstatedir=/var
+
+post-patch:
+ @${REINPLACE_CMD} 's|-ldb|-l${BDB_LIB_NAME}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} 's|$$(localstatedir)/lib|$$(localstatedir)/db|' ${WRKSRC}/Makefile.in
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/greyfix ${PREFIX}/sbin
+ @${INSTALL} -o nobody -m 700 -d /var/db/greyfix
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>