aboutsummaryrefslogtreecommitdiffstats
path: root/mail/hbiff
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>1998-12-30 12:29:38 +0800
committerobrien <obrien@FreeBSD.org>1998-12-30 12:29:38 +0800
commit3b2824649eec6c89bfebfe6d17571294a153ffbf (patch)
tree75efb4917695383d49b7f0785b0ddde6a01d5df9 /mail/hbiff
parentefd9ddfd6ef9596ad266a62aeaf0e593438a020a (diff)
downloadfreebsd-ports-gnome-3b2824649eec6c89bfebfe6d17571294a153ffbf.tar.gz
freebsd-ports-gnome-3b2824649eec6c89bfebfe6d17571294a153ffbf.tar.zst
freebsd-ports-gnome-3b2824649eec6c89bfebfe6d17571294a153ffbf.zip
Replacement for xbiff that flashes when new mail arrives like the
traditional xbiff. In addition, if you click on the hbiff icon, a window will popup showing the mail headers. This makes hbiff better than xlbiff where privacy is an issue since the headers are only displayed when you request.
Diffstat (limited to 'mail/hbiff')
-rw-r--r--mail/hbiff/Makefile27
-rw-r--r--mail/hbiff/distinfo1
-rw-r--r--mail/hbiff/files/patch-0155
-rw-r--r--mail/hbiff/pkg-comment1
-rw-r--r--mail/hbiff/pkg-descr10
-rw-r--r--mail/hbiff/pkg-plist1
6 files changed, 95 insertions, 0 deletions
diff --git a/mail/hbiff/Makefile b/mail/hbiff/Makefile
new file mode 100644
index 000000000000..998ba676a070
--- /dev/null
+++ b/mail/hbiff/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: hbiff
+# Version required: 1.2
+# Date created: Mon Dec 23, 1998
+# Whom: David O'Brien (obrien@NUXI.com)
+#
+# $Id: Makefile,v 1.2 1997/01/25 18:08:40 obrien Exp $
+#
+
+DISTNAME= hbiff-1.2
+CATEGORIES= mail
+MASTER_SITES= ftp://ftp.nuxi.com/pub/misc/ \
+ http://www.freebsd.org/~obrien/Distfiles/
+
+MAINTAINER= obrien@FreeBSD.org
+
+USE_XLIB= yes
+MAN1= hbiff.1
+
+do-build:
+ cd ${WRKSRC} ; cc -I${X11BASE}/include hbiff.c -L${X11BASE}/lib -lX11
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/a.out ${PREFIX}/bin/hbiff
+ @cd ${WRKSRC} ; ${INSTALL_MAN} ${MAN1} ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/mail/hbiff/distinfo b/mail/hbiff/distinfo
new file mode 100644
index 000000000000..01b041d04332
--- /dev/null
+++ b/mail/hbiff/distinfo
@@ -0,0 +1 @@
+MD5 (hbiff-1.2.tar.gz) = 637e201c7851b7577897d9990323a730
diff --git a/mail/hbiff/files/patch-01 b/mail/hbiff/files/patch-01
new file mode 100644
index 000000000000..38e4cb7ac210
--- /dev/null
+++ b/mail/hbiff/files/patch-01
@@ -0,0 +1,55 @@
+--- hbiff.c.orig Sat Nov 22 19:17:50 1997
++++ hbiff.c Sat Dec 26 14:11:06 1998
+@@ -26,6 +26,7 @@
+ #include <string.h>
+ #include <signal.h>
+ #include <time.h>
++#include <utime.h>
+ #include <errno.h>
+
+ extern int errno;
+@@ -276,7 +277,7 @@
+ /*
+ | default mail command
+ */
+- mail_command = "xterm -e mailx";
++ mail_command = "xterm -e Mail";
+ x = 100;
+ y = 100;
+ sx = 50;
+@@ -517,7 +518,7 @@
+ | if no font was specified, set font to "6x10"
+ */
+ if (font_name == '\0')
+- font_name = "6x10";
++ font_name = "fixed";
+
+ /*
+ | get the font information
+@@ -544,7 +545,7 @@
+
+ if (mail_file[0] == '\0')
+ {
+- strcpy(mail_file, "/usr/mail/");
++ strcpy(mail_file, "/var/mail/");
+ strcat(mail_file, username);
+ }
+
+@@ -815,9 +816,14 @@
+ | set up bitmaps for the different mailboxes
+ | (no mail, old mail, or new mail)
+ */
+- pix[0] = XCreateBitmapFromData(disp_ptr, window_id, nomail_bits, 64, 64, foreground, background, XDefaultDepth(disp_ptr, screen));
+- pix[1] = XCreateBitmapFromData(disp_ptr, window_id, newmail_bits, 64, 64, foreground, background, XDefaultDepth(disp_ptr, screen));
+- pix[2] = XCreateBitmapFromData(disp_ptr, window_id, oldmail_bits, 64, 64, foreground, background, XDefaultDepth(disp_ptr, screen));
++ pix[0] = XCreateBitmapFromData(disp_ptr, window_id, nomail_bits, 64, 64);
++ pix[1] = XCreateBitmapFromData(disp_ptr, window_id, newmail_bits, 64, 64);
++ pix[2] = XCreateBitmapFromData(disp_ptr, window_id, oldmail_bits, 64, 64);
++/*
++ pix[0] = XCreatePixmapFromBitmapData(disp_ptr, window_id, nomail_bits, 64, 64, foreground, background, XDefaultDepth(disp_ptr, screen));
++ pix[1] = XCreatePixmapFromBitmapData(disp_ptr, window_id, newmail_bits, 64, 64, foreground, background, XDefaultDepth(disp_ptr, screen));
++ pix[2] = XCreatePixmapFromBitmapData(disp_ptr, window_id, oldmail_bits, 64, 64, foreground, background, XDefaultDepth(disp_ptr, screen));
++*/
+
+ /*
+ | set up values for window
diff --git a/mail/hbiff/pkg-comment b/mail/hbiff/pkg-comment
new file mode 100644
index 000000000000..e52431ca8db2
--- /dev/null
+++ b/mail/hbiff/pkg-comment
@@ -0,0 +1 @@
+A replacement for xbiff that handles popup window with mail headers.
diff --git a/mail/hbiff/pkg-descr b/mail/hbiff/pkg-descr
new file mode 100644
index 000000000000..e5f2c4bb27df
--- /dev/null
+++ b/mail/hbiff/pkg-descr
@@ -0,0 +1,10 @@
+Fancy biff program under X11 environment.
+
+Hbiff is a replacement for xbiff that flashes when new mail arrives like the
+traditional xbiff. In addition, if you click on the hbiff icon, a window
+will popup showing the mail headers. This makes hbiff better than xlbiff
+where privacy is an issue since the headers are only displayed when you
+request. hbiff can also run the MUA for you.
+
+-- David O'Brien
+ (obrien@nuxi.com)
diff --git a/mail/hbiff/pkg-plist b/mail/hbiff/pkg-plist
new file mode 100644
index 000000000000..305ac5344391
--- /dev/null
+++ b/mail/hbiff/pkg-plist
@@ -0,0 +1 @@
+bin/hbiff