aboutsummaryrefslogtreecommitdiffstats
path: root/mail/heirloom-mailx
diff options
context:
space:
mode:
authoravl <avl@FreeBSD.org>2010-05-12 06:05:32 +0800
committeravl <avl@FreeBSD.org>2010-05-12 06:05:32 +0800
commitc66df19c9357d579edd7ae63275bb7cc0877f2ff (patch)
tree1f95d0c9dd2bd10c651e3df4e330d848aa504df5 /mail/heirloom-mailx
parent6e0617c9ca67fcf9400a294572977e216430fe4b (diff)
downloadfreebsd-ports-gnome-c66df19c9357d579edd7ae63275bb7cc0877f2ff.tar.gz
freebsd-ports-gnome-c66df19c9357d579edd7ae63275bb7cc0877f2ff.tar.zst
freebsd-ports-gnome-c66df19c9357d579edd7ae63275bb7cc0877f2ff.zip
- Add a patch to fix "unignore" and similar commands
- Bump PORTREVISION PR: ports/146280 Submitted by: B. Smith <anon_101100 at yahoo.com> Obtained from: developers cvs
Diffstat (limited to 'mail/heirloom-mailx')
-rw-r--r--mail/heirloom-mailx/Makefile2
-rw-r--r--mail/heirloom-mailx/files/patch-cmd2.c22
2 files changed, 23 insertions, 1 deletions
diff --git a/mail/heirloom-mailx/Makefile b/mail/heirloom-mailx/Makefile
index 604f2871c197..7f03f4adfb3e 100644
--- a/mail/heirloom-mailx/Makefile
+++ b/mail/heirloom-mailx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mailx
PORTVERSION= 12.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail ipv6
MASTER_SITES= SF/heirloom/heirloom-${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= heirloom-
diff --git a/mail/heirloom-mailx/files/patch-cmd2.c b/mail/heirloom-mailx/files/patch-cmd2.c
new file mode 100644
index 000000000000..99441629030a
--- /dev/null
+++ b/mail/heirloom-mailx/files/patch-cmd2.c
@@ -0,0 +1,22 @@
+--- cmd2.c 2006/03/04 00:32:16 1.12
++++ cmd2.c 2010/05/09 21:50:54 1.13
+@@ -803,16 +803,17 @@
+ int h = hash(name);
+
+ for (ip = tab->i_head[h]; ip; ip = ip->i_link) {
+- if (asccasecmp(ip->i_field, name)) {
++ if (asccasecmp(ip->i_field, name) == 0) {
+ free(ip->i_field);
+ if (iq != NULL)
+ iq->i_link = ip->i_link;
+ else
+- tab->i_head[h] = NULL;
++ tab->i_head[h] = ip->i_link;
+ free(ip);
+ tab->i_count--;
+ break;
+ }
++ iq = ip;
+ }
+ }
+