aboutsummaryrefslogtreecommitdiffstats
path: root/mail/horde4-imp
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2005-02-15 04:53:47 +0800
committerthierry <thierry@FreeBSD.org>2005-02-15 04:53:47 +0800
commit2fd5d16dd4a6045bd845279cbb2f92f42ea512c6 (patch)
tree9a4ccb60d1f5849471c685175928a19c4ac8219f /mail/horde4-imp
parent3d5be8a8cfc8d351e698c54833cb0a19fc28e656 (diff)
downloadfreebsd-ports-gnome-2fd5d16dd4a6045bd845279cbb2f92f42ea512c6.tar.gz
freebsd-ports-gnome-2fd5d16dd4a6045bd845279cbb2f92f42ea512c6.tar.zst
freebsd-ports-gnome-2fd5d16dd4a6045bd845279cbb2f92f42ea512c6.zip
Fix bug #1367
(<http://bugs.horde.org/ticket/?id=1367&Horde=b45921c0a2f9cf7dd2ac4694dedf8191>). Tested by: Troy Dixler Obtained from: Horde CVS.
Diffstat (limited to 'mail/horde4-imp')
-rw-r--r--mail/horde4-imp/Makefile3
-rw-r--r--mail/horde4-imp/files/patch-bug136711
2 files changed, 13 insertions, 1 deletions
diff --git a/mail/horde4-imp/Makefile b/mail/horde4-imp/Makefile
index 15dd2c64fc68..84b29e53c5ab 100644
--- a/mail/horde4-imp/Makefile
+++ b/mail/horde4-imp/Makefile
@@ -7,6 +7,7 @@
PORTNAME= imp
PORTVERSION= 4.0.2
+PORTREVISION= 1
CATEGORIES= mail www
MASTER_SITES= ftp://ftp.horde.org/pub/imp/ \
ftp://ftp.planetmirror.com/pub/horde/imp/ \
@@ -201,7 +202,7 @@ pre-configure:
.for fc in ${PATCH2RM}
@${RM} ${WRKSRC}/config/${fc}
.endfor
- @${RM} ${WRKSRC}/lib/MIME/Headers.php.beforeIMP
+ @${RM} ${WRKSRC}/lib/MIME/Headers.php.beforeIMP ${WRKSRC}/lib/IMP.php.orig
pre-install:
.if !defined(BATCH) && !defined(WITHOUT_SSL)
diff --git a/mail/horde4-imp/files/patch-bug1367 b/mail/horde4-imp/files/patch-bug1367
new file mode 100644
index 000000000000..83db997b1782
--- /dev/null
+++ b/mail/horde4-imp/files/patch-bug1367
@@ -0,0 +1,11 @@
+--- lib/IMP.php.orig Wed Jan 26 10:23:02 2005
++++ lib/IMP.php Mon Feb 14 21:14:11 2005
+@@ -582,7 +582,7 @@
+
+ /* Add the list of mailboxes to the lists. */
+ $showmbox = false;
+- if (is_null($filter[0])) {
++ if (count($filter) && is_null($filter[0])) {
+ $showmbox = true;
+ array_shift($filter);
+ }