aboutsummaryrefslogtreecommitdiffstats
path: root/mail/horde4-ingo/Makefile
diff options
context:
space:
mode:
authorscrappy <scrappy@FreeBSD.org>2006-04-16 00:23:50 +0800
committerscrappy <scrappy@FreeBSD.org>2006-04-16 00:23:50 +0800
commit4ef678cedbb4c3da06124e9d9a32e2c1e2374fa5 (patch)
treeedbfa1dc81432dd1fbd6551821fba5553f2798c1 /mail/horde4-ingo/Makefile
parent2899b20061336fe346fe998f1cbe0d0389ff3022 (diff)
downloadfreebsd-ports-gnome-4ef678cedbb4c3da06124e9d9a32e2c1e2374fa5.tar.gz
freebsd-ports-gnome-4ef678cedbb4c3da06124e9d9a32e2c1e2374fa5.tar.zst
freebsd-ports-gnome-4ef678cedbb4c3da06124e9d9a32e2c1e2374fa5.zip
After a recent discussion on freebsd-ports, I have modified the Horde
ports, so that they now do not overwrite existing configuration files. Rather than backing up the old ones and allowing the user to merge the files by hand, config files are left untouched. Submitted by: Shaun Amott <shaun@inerd.com>
Diffstat (limited to 'mail/horde4-ingo/Makefile')
-rw-r--r--mail/horde4-ingo/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/mail/horde4-ingo/Makefile b/mail/horde4-ingo/Makefile
index a588201045ea..cb777f1eba0f 100644
--- a/mail/horde4-ingo/Makefile
+++ b/mail/horde4-ingo/Makefile
@@ -20,7 +20,7 @@ MASTER_SITES= ftp://ftp.horde.org/pub/ingo/ \
DISTNAME= ${PORTNAME}-h3-${PORTVERSION}
MAINTAINER= shaun@inerd.com
-COMMENT= Horde's email-filter management application
+COMMENT= Horde\'s email-filter management application
#-----------------------------------------------------------------------
# You may define this option:
@@ -39,7 +39,7 @@ USE_APACHE= 1.3+ # needed to test APACHE_VERSION
PLIST_SUB= INGODIR=${LINGODIR} HORDE_INC=${HORDE_INC:S|^${LOCALBASE}/||}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
-SUB_FILES= pkg-message pkg-deinstall
+SUB_FILES= pkg-message pkg-install pkg-deinstall
SUB_LIST= INGODIR=${INGODIR}
DOCS= LICENSE README docs/CHANGES docs/CREDITS docs/INSTALL \
@@ -76,11 +76,7 @@ do-install:
@${CP} -Rp ${WRKSRC}/${REP} ${INGODIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${INGODIR}
-.for FILE in ${CONFFILE}
- @if [ ! -f ${CONFDIR}/${FILE} ]; then \
- ${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
- fi
-.endfor
+
@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${INGODIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${INSTALL_DATA} ${WRKDIR}/httpd-ingo.conf ${HORDE_INC}
@@ -93,6 +89,7 @@ do-install:
.endif
post-install:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
@${ECHO_MSG}