aboutsummaryrefslogtreecommitdiffstats
path: root/mail/horde4-turba
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-26 11:54:09 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-26 11:54:09 +0800
commit34e89ab8392566d3214ac1b9ecc2dd006abed7b9 (patch)
treed2b01dd75b75edffecca9a30a9fb09a047d33386 /mail/horde4-turba
parentd34b2b1ee3faf8c842017e914405d2828b3c49d7 (diff)
downloadfreebsd-ports-gnome-34e89ab8392566d3214ac1b9ecc2dd006abed7b9.tar.gz
freebsd-ports-gnome-34e89ab8392566d3214ac1b9ecc2dd006abed7b9.tar.zst
freebsd-ports-gnome-34e89ab8392566d3214ac1b9ecc2dd006abed7b9.zip
${PERL} -> ${REINPLACE_CMD}
PR: 39856 Submitted by: maintainer
Diffstat (limited to 'mail/horde4-turba')
-rw-r--r--mail/horde4-turba/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/mail/horde4-turba/Makefile b/mail/horde4-turba/Makefile
index de7e2932ba40..850e007e9ae5 100644
--- a/mail/horde4-turba/Makefile
+++ b/mail/horde4-turba/Makefile
@@ -39,6 +39,9 @@ LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap2 \
RUN_DEPENDS+= ${LOCALBASE}/www/horde/index.php:${PORTSDIR}/www/horde2
NO_BUILD= yes
+USE_REINPLACE= yes
+
+REINPLACE_ARGS= -i.beforeTurba
DOCS= COPYING README docs/CHANGES docs/CREDITS \
docs/INSTALL docs/turba.dia docs/turba.pdf
CONFFILE= attributes.php conf.php html.php menu.php \
@@ -109,11 +112,10 @@ do-install:
@${CHOWN} -R www:www ${TURBADIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.turba ${HORDE_INC}
- @${PERL} -pi -e "s:/home/httpd/html/horde/turba:${TURBADIR}:g" \
+ @${REINPLACE_CMD} -e "s:/home/httpd/html/horde/turba:${TURBADIR}:g" \
${HORDE_INC}/httpd.conf.turba
- @${CP} -p ${HORDEDIR}/config/registry.php \
- ${HORDEDIR}/config/registry.php.beforeTurba
- @${PERL} -pi -e "s://UNCOMMENTWHENINSTTURBA::" \
+ @${RM} ${HORDE_INC}/httpd.conf.turba.beforeTurba
+ @${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTTURBA::" \
${HORDEDIR}/config/registry.php
@${CP} -p ${HORDEDIR}/config/registry.php \
${HORDEDIR}/config/registry.php.afterTurba