aboutsummaryrefslogtreecommitdiffstats
path: root/mail/im
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-06-01 23:59:44 +0800
committerpawel <pawel@FreeBSD.org>2014-06-01 23:59:44 +0800
commit2f487f1d7d4c8b032b53306783d6a657acbc974d (patch)
treed54c2a4f55fc41232d423fecdeb25a3a39581b67 /mail/im
parentf32ca2c043f996be01af431e261a60f1762bc098 (diff)
downloadfreebsd-ports-gnome-2f487f1d7d4c8b032b53306783d6a657acbc974d.tar.gz
freebsd-ports-gnome-2f487f1d7d4c8b032b53306783d6a657acbc974d.tar.zst
freebsd-ports-gnome-2f487f1d7d4c8b032b53306783d6a657acbc974d.zip
- Add staging support
- Convert to new options framework - Fix shebangs in scripts, bump PORTREVISION
Diffstat (limited to 'mail/im')
-rw-r--r--mail/im/Makefile31
1 files changed, 11 insertions, 20 deletions
diff --git a/mail/im/Makefile b/mail/im/Makefile
index 83b91c06f254..1e5d6884dcf1 100644
--- a/mail/im/Makefile
+++ b/mail/im/Makefile
@@ -3,6 +3,7 @@
PORTNAME= im
PORTVERSION= 151
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://tats.haun.org/im/
@@ -12,29 +13,19 @@ COMMENT= Set of user interfaces of Email and NetNews
USES= perl5
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-hostname=_domain_of_your_mail_address_
+CONFIGURE_ENV= im_path_perl=${PERL}
MAKE_ARGS= prefix=${PREFIX} imlibdir=${ETCDIR}
-# Use RPOP instead of APOP
-.if defined(WITH_RPOP)
-CONFIGURE_ARGS+= --enable-rpop
-.endif
+OPTIONS_DEFINE= DOCS EXAMPLES RPOP
-NO_STAGE= yes
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/00* ${DOCSDIR}
- @${MKDIR} ${DOCSDIR}/man
- ${INSTALL_DATA} ${WRKSRC}/man/* ${DOCSDIR}/man
-.endif
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/dot.im/* ${EXAMPLESDIR}
-.endif
+RPOP_DESC= Use RPOP instead of APOP
+RPOP_CONFIGURE_ENABLE= rpop
-## for make PLIST (only maintainer use)
-#arrange:
-# ${MAKE} -DPLIST_OVERRIDE \
-# DIRRMDEPTH=1 plist
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/man
+ ${INSTALL_DATA} ${WRKSRC}/00* ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/man/* ${STAGEDIR}${DOCSDIR}/man
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/dot.im/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>