aboutsummaryrefslogtreecommitdiffstats
path: root/mail/imap-uw/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
committerasami <asami@FreeBSD.org>1998-11-14 17:43:39 +0800
commit521807d38becba50804a00710cfa1b51c759a4f4 (patch)
tree26cfeb8a991d32014f9a30277d2ade973f1a937f /mail/imap-uw/Makefile
parentf4c70db8f8fed4684d8013755f0d23c5da34733e (diff)
downloadfreebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.gz
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.tar.zst
freebsd-ports-gnome-521807d38becba50804a00710cfa1b51c759a4f4.zip
Use bsd.port.{pre,post}.mk to move PORTOBJFORMAT to front, or change
shell loops to make loops. Use EXTRA_PKG_FLAGS to add install scripts instead of adding it to PKG_FLAGS after bsd.port.mk.
Diffstat (limited to 'mail/imap-uw/Makefile')
-rw-r--r--mail/imap-uw/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/mail/imap-uw/Makefile b/mail/imap-uw/Makefile
index 6b07f8ef59d0..c7ee09d22500 100644
--- a/mail/imap-uw/Makefile
+++ b/mail/imap-uw/Makefile
@@ -3,7 +3,7 @@
# Date created: 9 Jan 1997
# Whom: pst
#
-# $Id: Makefile,v 1.20 1998/10/23 18:42:49 asami Exp $
+# $Id: Makefile,v 1.21 1998/10/26 13:54:20 steve Exp $
#
DISTNAME= imap-4.2
@@ -18,6 +18,14 @@ MAINTAINER= imap-uw@freebsd.ady.ro
ALL_TARGET= bsf
MAN8= ipopd.8 imapd.8
+.include <bsd.port.pre.mk>
+
+.if ${PORTOBJFORMAT} == "elf"
+SHLIB= libc-client.so.2
+.else
+SHLIB= libc-client.so.2.1
+.endif
+
#pre-build:
# @chmod 755 ${WRKSRC}/src/osdep/unix/drivers ${WRKSRC}/src/osdep/unix/mkauths
@@ -42,10 +50,4 @@ do-install:
post-install:
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
-.include <bsd.port.mk>
-
-.if ${PORTOBJFORMAT} == "elf"
-SHLIB= libc-client.so.2
-.else
-SHLIB= libc-client.so.2.1
-.endif
+.include <bsd.port.post.mk>