aboutsummaryrefslogtreecommitdiffstats
path: root/mail/isync/Makefile
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2005-04-16 01:48:23 +0800
committerflz <flz@FreeBSD.org>2005-04-16 01:48:23 +0800
commitd94fdcc4ed9106e74d62b0ecec1cd867f75d891e (patch)
treee51102a66db8fc9a8dddc2eb56d783565e39985e /mail/isync/Makefile
parent1ec33df608a60eddf5ef9154d06f93703dbec9aa (diff)
downloadfreebsd-ports-gnome-d94fdcc4ed9106e74d62b0ecec1cd867f75d891e.tar.gz
freebsd-ports-gnome-d94fdcc4ed9106e74d62b0ecec1cd867f75d891e.tar.zst
freebsd-ports-gnome-d94fdcc4ed9106e74d62b0ecec1cd867f75d891e.zip
- Update to 1.0.1.
PR: ports/79975 Submitted by: Ports Fury
Diffstat (limited to 'mail/isync/Makefile')
-rw-r--r--mail/isync/Makefile27
1 files changed, 20 insertions, 7 deletions
diff --git a/mail/isync/Makefile b/mail/isync/Makefile
index 1c89d1ac57b8..49e87c6d4b80 100644
--- a/mail/isync/Makefile
+++ b/mail/isync/Makefile
@@ -5,26 +5,39 @@
# $FreeBSD$
PORTNAME= isync
-PORTVERSION= 0.9.1
+PORTVERSION= 1.0.1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3
-
MAINTAINER= ports@FreeBSD.org
COMMENT= Maintain local copies of remote IMAP folders w/synchronized flags
+LIB_DEPENDS= db-4.2.2:${PORTSDIR}/databases/db42
+
USE_GETOPT_LONG= yes
USE_OPENSSL= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-MAN1= isync.1
-PLIST_FILES= bin/isync
+MAN1= isync.1 mbsync.1 mdconvert.1
+PORTDOCS= AUTHORS ChangeLog NEWS README TODO
+PLIST_FILES= bin/get-cert bin/isync bin/mbsync bin/mdconvert
+
+CPPFLAGS= -I${LOCALBASE}/include/db42 -I${OPENSSLINC}
+LDFLAGS= -L${LOCALBASE}/lib/db42 -L${OPENSSLLIB} -lssl -lcrypto
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|: install-docDATA|:|g' ${WRKSRC}/Makefile.in
-CPPFLAGS= -I${LOCALBASE}/include/db3 -I${OPENSSLINC}
-LDFLAGS= -L${LOCALBASE}/lib -ldb3 -L${OPENSSLLIB} -lssl -lcrypto
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>