aboutsummaryrefslogtreecommitdiffstats
path: root/mail/jboss-mailservices
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2005-01-11 18:08:04 +0800
committerhq <hq@FreeBSD.org>2005-01-11 18:08:04 +0800
commita8dd4da4b904f73997add3d8a6ba68660e0964c1 (patch)
tree7af425b8580784654d92de0e4c78a2bc4819573d /mail/jboss-mailservices
parent46cd1981097a18b62ad4e9ea774d17fa116345a4 (diff)
downloadfreebsd-ports-gnome-a8dd4da4b904f73997add3d8a6ba68660e0964c1.tar.gz
freebsd-ports-gnome-a8dd4da4b904f73997add3d8a6ba68660e0964c1.tar.zst
freebsd-ports-gnome-a8dd4da4b904f73997add3d8a6ba68660e0964c1.zip
JBossMail was created to enable JBoss to serve as an email server.
JBossMail currently consists of: * Core Server - which provides thread pooling, connection handling, and timeout configuration. * POP Protocol Implementation - plugs into the Server MBean to provide a POP implementation. * SMTP Server - plugs into the Server MBean to provide an SMTP protocol implementation. * Mail Listeners - plug into the SMTP server to forward mail to the various backends. Currently the JMSMailListener is provided. It forwards mails to various JBossMQ queues. Message Driven Beans for remote and local delivery are also provided. * Mailbox implementations - provides backends to the mail server. Presently an EJB Entity-based version is provided. * SMTPSender - uses JavaMail to mail messages to remote servers * Test suite - JUnit tests for the various portions of mail services. Includes a few services including mock-jndi. WWW: http://www.jboss.org/products/mailservices
Diffstat (limited to 'mail/jboss-mailservices')
-rw-r--r--mail/jboss-mailservices/Makefile39
-rw-r--r--mail/jboss-mailservices/distinfo2
-rw-r--r--mail/jboss-mailservices/pkg-descr21
3 files changed, 62 insertions, 0 deletions
diff --git a/mail/jboss-mailservices/Makefile b/mail/jboss-mailservices/Makefile
new file mode 100644
index 000000000000..c4511233a04b
--- /dev/null
+++ b/mail/jboss-mailservices/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: JBoss Mail Services
+# Date created: Thu Jan 6 13:39:18 EET 2005
+# Whom: Anton Yudin <toha@toha.org.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jboss-mailservices
+PORTVERSION= m1
+CATEGORIES= mail java
+MASTER_SITES= http://www.jboss.org/wiki/attach?page=MailServicesMilestoneReleases/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-final
+
+MAINTAINER= toha@toha.org.ua
+COMMENT= JBoss Mail Services
+
+RUN_DEPENDS= ${LOCALBASE}/jboss4.0/server/default/conf/jboss-service.xml:${PORTSDIR}/java/jboss4
+
+USE_JAVA= YES
+JAVA_VERSION= 1.4+
+NO_BUILD= YES
+USE_ZIP= YES
+
+DEPLOY_PATH= ${LOCALBASE}/jboss4.0/server/default/deploy
+WRKSRC= ${WRKDIR}/deploy
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ cd ${WRKSRC} && ${FIND} . -type d -exec ${INSTALL} -d ${DEPLOY_PATH}/'{}' \; && \
+ ${FIND} . -type f -exec ${INSTALL_DATA} '{}' ${DEPLOY_PATH}/'{}' \;
+
+post-install:
+ @${FIND} -s ${WRKSRC}/mail.ear -not -type d 2>/dev/null | \
+ ${SED} -ne 's,^${WRKSRC},${DEPLOY_PATH:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${FIND} -s -d ${WRKSRC}/mail.ear -type d 2>/dev/null | \
+ ${SED} -ne 's,^${WRKSRC},@dirrm ${DEPLOY_PATH:S,^${PREFIX}/,,},p' >> ${TMPPLIST}
+
+.include <bsd.port.post.mk>
diff --git a/mail/jboss-mailservices/distinfo b/mail/jboss-mailservices/distinfo
new file mode 100644
index 000000000000..45434b8eded5
--- /dev/null
+++ b/mail/jboss-mailservices/distinfo
@@ -0,0 +1,2 @@
+MD5 (jboss-mailservices-m1-final.zip) = e584172003ccb7fdad215e432f5c1bb1
+SIZE (jboss-mailservices-m1-final.zip) = 1291084
diff --git a/mail/jboss-mailservices/pkg-descr b/mail/jboss-mailservices/pkg-descr
new file mode 100644
index 000000000000..651a88d91900
--- /dev/null
+++ b/mail/jboss-mailservices/pkg-descr
@@ -0,0 +1,21 @@
+JBossMail was created to enable JBoss to serve as an email server.
+
+JBossMail currently consists of:
+
+ * Core Server - which provides thread pooling, connection handling, and
+ timeout configuration.
+ * POP Protocol Implementation - plugs into the Server MBean to provide a
+ POP implementation.
+ * SMTP Server - plugs into the Server MBean to provide an SMTP protocol
+ implementation.
+ * Mail Listeners - plug into the SMTP server to forward mail to the various
+ backends. Currently the JMSMailListener is provided. It forwards mails
+ to various JBossMQ queues. Message Driven Beans for remote and local
+ delivery are also provided.
+ * Mailbox implementations - provides backends to the mail server. Presently
+ an EJB Entity-based version is provided.
+ * SMTPSender - uses JavaMail to mail messages to remote servers
+ * Test suite - JUnit tests for the various portions of mail services.
+ Includes a few services including mock-jndi.
+
+WWW: http://www.jboss.org/products/mailservices