aboutsummaryrefslogtreecommitdiffstats
path: root/mail/kiltdown
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2009-04-08 05:53:13 +0800
committermi <mi@FreeBSD.org>2009-04-08 05:53:13 +0800
commit6a3f0e277147bc57b4e591393c59868d65ef6e0d (patch)
tree74ec945bbb26ccee72a8202e03eeb3d4965340d8 /mail/kiltdown
parentb75d03217db8f9df0014ebdbba0e0f98c77481e7 (diff)
downloadfreebsd-ports-gnome-6a3f0e277147bc57b4e591393c59868d65ef6e0d.tar.gz
freebsd-ports-gnome-6a3f0e277147bc57b4e591393c59868d65ef6e0d.tar.zst
freebsd-ports-gnome-6a3f0e277147bc57b4e591393c59868d65ef6e0d.zip
Make it compile cleanly (with -Wall) on 64-bit platforms. It still does
not work right... Allow parallel build. The project seems dead (no releases in 8 years) and the port should, probably, be dropped...
Diffstat (limited to 'mail/kiltdown')
-rw-r--r--mail/kiltdown/Makefile6
-rw-r--r--mail/kiltdown/files/patch-Makefile.in30
-rw-r--r--mail/kiltdown/files/patch-fixes257
-rw-r--r--mail/kiltdown/files/patch-kmaillist.cc66
-rw-r--r--mail/kiltdown/files/patch-mailfolder.cc118
-rw-r--r--mail/kiltdown/files/patch-mailviewer.cc26
6 files changed, 469 insertions, 34 deletions
diff --git a/mail/kiltdown/Makefile b/mail/kiltdown/Makefile
index 80b9a22412fd..593dfd577785 100644
--- a/mail/kiltdown/Makefile
+++ b/mail/kiltdown/Makefile
@@ -14,20 +14,18 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Kiltdown is an UI independant Email Client for UNIX
-LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3
+LIB_DEPENDS= db3:${PORTSDIR}/databases/db3
PLIST_FILES= bin/kiltdown
USE_QT_VER= 3
USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
MY_CONFIGURE_ARGS= -release
MY_CONFIGURE_ARGS+= -qtinc ${LOCALBASE}/include -qtlib ${LOCALBASE}/lib
MY_CONFIGURE_ARGS+= -dbinc ${LOCALBASE}/include/db3 -dblib ${LOCALBASE}/lib
BUILD_ENV+= PATH=${PATH}:${LOCALBASE}/bin
-NOT_FOR_ARCHS= amd64 sparc64
-NOT_FOR_ARCHS_REASON= assumes 32-bit sized pointers
-
post-patch:
@${MV} ${WRKSRC}/configs/bsd-generic ${WRKSRC}/configs/bsd-generic.sed
${SED} \
diff --git a/mail/kiltdown/files/patch-Makefile.in b/mail/kiltdown/files/patch-Makefile.in
index 15bb5bb04398..c0ceaa6d5254 100644
--- a/mail/kiltdown/files/patch-Makefile.in
+++ b/mail/kiltdown/files/patch-Makefile.in
@@ -1,5 +1,12 @@
---- kiltdown/Makefile.in.orig Mon May 14 05:25:23 2001
+--- kiltdown/Makefile.in Mon May 14 05:25:23 2001
+++ kiltdown/Makefile.in Thu Dec 27 06:20:25 2001
+@@ -13,5 +61,5 @@
+ ###################################################################
+ #
+-.SUFFIXES: .cc .c .o .ui .hmoc .ccmoc
++.SUFFIXES: .cc .c .o .dlg.ui .hmoc .ccmoc .dlg.h dlg.cc
+
+
@@ -21,7 +21,7 @@
###################################################################
#
@@ -9,12 +16,27 @@
UIC=$(QTBIN)uic
RESCOMP=../tools/rescomp
DLGSTRIP=../tools/dlgstrip
-@@ -29,7 +29,7 @@
- CFLAGSBASE=-DQT_THREAD_SUPPORT $(OPT_DEFINES) $(SYS_CFLAGS) $(ALLINCLUDES) -Wall
+@@ -27,8 +75,8 @@
+ DLGSTRIP=../tools/dlgstrip
+ ALLINCLUDES=$(SYS_INCLUDE) $(USER_INC) -I$(DBINC) -I$(QTINC) -I$(X11INCLUDE) -I../include
+-CFLAGSBASE=-DQT_THREAD_SUPPORT $(OPT_DEFINES) $(SYS_CFLAGS) $(ALLINCLUDES) -Wall
++CFLAGSBASE=-DQT_THREAD_SUPPORT $(OPT_DEFINES) $(SYS_CFLAGS) $(ALLINCLUDES) -Wall -Wno-uninitialized -Werror
CFLAGS=$(CFLAGSBASE) -fno-implicit-templates
LDFLAGS= $(SYS_LDFLAGS) -L$(QTLIB) -L$(DBLIB) -L$(X11LIB) $(USER_LPATH)
-LIBS=-lSM -lX11 -lXext -lICE -lqt-mt -ldb $(JPEGLIB) $(SYS_LIBS) $(USER_LIBS)
+LIBS=-lSM -lX11 -lXext -lICE -lqt-mt -ldb3 $(JPEGLIB) $(SYS_LIBS) $(USER_LIBS)
#
- ###################################################################
+@@ -188,7 +236,9 @@
+ $(CXX) -c $(CFLAGS) $<
+
+-.ui.cc:
+- $(UIC) -o $*.h $<
+- $(UIC) -tr "" -i $*.h -o $*.cc $<
++%.dlg.h: %.dlg.ui
++ $(UIC) -o $*.dlg.h $<
++
++%.dlg.cc: %.dlg.h %.dlg.ui
++ $(UIC) -tr "" -i $*.dlg.h -o $*.dlg.cc $*.dlg.ui
+
+ .hmoc.h:
diff --git a/mail/kiltdown/files/patch-fixes b/mail/kiltdown/files/patch-fixes
new file mode 100644
index 000000000000..6156eda48ff7
--- /dev/null
+++ b/mail/kiltdown/files/patch-fixes
@@ -0,0 +1,257 @@
+--- kiltdown/accountdlg.cc 2001-05-13 23:25:23.000000000 -0400
++++ kiltdown/accountdlg.cc 2008-05-21 23:02:15.000000000 -0400
+@@ -141,9 +141,9 @@
+ void AccountsDialog::addNewAccount()
+ {
+- LinkList<unsigned int> list;
++ LinkList<void *> list;
+ const char *pstr, *pstr2;
+ ISubsystem *s = NULL;
+ SelectMeDialog smd;
+- unsigned int ui;
++ ISubsystem *ui;
+ ERRCODE er;
+ int ret;
+@@ -172,5 +172,5 @@
+ s->getDisplayName(&pstr);
+ if (pstr) {
+- smd.addItem(pstr, (unsigned int)s);
++ smd.addItem(pstr, (void *)s);
+ localFree(pstr);
+ }
+@@ -188,8 +188,8 @@
+ if (ret == QDialog::Accepted) {
+
+- ui = 0;
++ ui = NULL;
+ smd.getSelectedItems(list);
+- list.firstElement(&ui);
+- if ((ISubsystem *)ui) ((ISubsystem *)ui)->createNewAccount();
++ list.firstElement((void **)&ui);
++ if (ui) ui->createNewAccount();
+
+ LinkList<IAccount *> accts;
+--- kiltdown/attachment.cc 2001-05-13 23:25:23.000000000 -0400
++++ kiltdown/attachment.cc 2008-05-21 23:45:53.000000000 -0400
+@@ -363,5 +363,6 @@
+ * sequent calls to this will clobber old vals.
+ */
+-char * Attachment::getPrintableSize()
++const char *
++Attachment::getPrintableSize()
+ {
+ struct stat info;
+--- kiltdown/attachment.h 2001-05-13 23:25:23.000000000 -0400
++++ kiltdown/attachment.h 2008-05-21 23:46:11.000000000 -0400
+@@ -47,5 +47,5 @@
+ ERRCODE getFullPath(const char **);
+
+- char *getPrintableSize();
++ const char *getPrintableSize();
+
+ QPixmap *chooseIcon();
+--- kiltdown/base64.cc 2001-05-13 23:25:23.000000000 -0400
++++ kiltdown/base64.cc 2008-05-21 23:48:03.000000000 -0400
+@@ -146,5 +146,5 @@
+ */
+ if (inputBuf[cloop] != '=') {
+- holdVals[cheld] = byteFromChar[inputBuf[cloop]];
++ holdVals[cheld] = byteFromChar[(unsigned int)inputBuf[cloop]];
+ cheld++;
+ } else {
+@@ -445,5 +445,5 @@
+ */
+ if (decodeMe[cloop] != '=') {
+- holdVals[cheld] = byteFromChar[decodeMe[cloop]];
++ holdVals[cheld] = byteFromChar[(unsigned int)decodeMe[cloop]];
+ cheld++;
+ } else {
+--- kiltdown/foldersort.cc 2001-05-13 23:25:23.000000000 -0400
++++ kiltdown/foldersort.cc 2008-05-21 23:41:49.000000000 -0400
+@@ -12,5 +12,5 @@
+
+ #include <ctype.h>
+-
++#include <stdint.h>
+
+ #include "address.h"
+@@ -69,5 +69,5 @@
+ (
+ int col,
+- unsigned int itemData,
++ void * itemData,
+ KMailListItem *item1,
+ KMailListItem *item2
+@@ -76,5 +76,5 @@
+ time_t t1, t2;
+
+- switch ((MailColumn)itemData) {
++ switch ((MailColumn)(uintptr_t)itemData) {
+ case MC_SENT:
+ ((MailMessage *)item1->itemData)->getSent(&t1);
+@@ -116,5 +116,5 @@
+ (
+ int col,
+- unsigned int itemData,
++ void * itemData,
+ KMailListItem *item1,
+ KMailListItem *item2
+@@ -146,5 +146,5 @@
+ (
+ int col,
+- unsigned int itemData,
++ void * itemData,
+ KMailListItem *item1,
+ KMailListItem *item2
+@@ -167,5 +167,5 @@
+ return 1;
+ case 3:
+- switch ((MailColumn)itemData) {
++ switch ((MailColumn)(uintptr_t)itemData) {
+
+ case MC_SUBJECT:
+--- kiltdown/foldersort.h 2001-05-13 23:25:23.000000000 -0400
++++ kiltdown/foldersort.h 2008-05-21 23:08:01.000000000 -0400
+@@ -23,7 +23,7 @@
+ * Defines routines used for sorting items in folders.
+ */
+-int messageSortString(int, unsigned int, KMailListItem *, KMailListItem *);
+-int messageSortPixmap(int, unsigned int, KMailListItem *, KMailListItem *);
+-int messageSortDate(int, unsigned int, KMailListItem *, KMailListItem *);
++int messageSortString(int, void *, KMailListItem *, KMailListItem *);
++int messageSortPixmap(int, void *, KMailListItem *, KMailListItem *);
++int messageSortDate(int, void *, KMailListItem *, KMailListItem *);
+
+
+--- kiltdown/maildownload.cc 2001-05-13 23:25:23.000000000 -0400
++++ kiltdown/maildownload.cc 2008-05-21 23:48:46.000000000 -0400
+@@ -173,5 +173,5 @@
+ /**
+ * This is used globally.
+- * UNDONE: marcw, 2001.2.2 -- should this be TLS ??/
++ * UNDONE: marcw, 2001.2.2 -- should this be TLS ??
+ */
+ CrossThreadManager *far = NULL;
+--- kiltdown/mimeheader.cc 2001-05-13 23:25:23.000000000 -0400
++++ kiltdown/mimeheader.cc 2008-05-21 23:53:29.000000000 -0400
+@@ -1002,5 +1002,6 @@
+ while (sep[index] != '\n' && sep[index] != '\r'
+ && sep[index] != '\0' && (index + 2 < (int)sizeof(buf))) {
+- buf[index + 2] = sep[index++];
++ buf[index + 2] = sep[index];
++ index++;
+ }
+
+--- kiltdown/selectme.cc 2001-05-13 23:25:23.000000000 -0400
++++ kiltdown/selectme.cc 2008-05-21 22:55:50.000000000 -0400
+@@ -29,11 +29,11 @@
+
+ public:
+- ListBoxTextEx(QListBox *a, const QString &b, unsigned int c)
++ ListBoxTextEx(QListBox *a, const QString &b, void *c)
+ : QListBoxText(a, b, 0), itemData(c) { }
+
+- unsigned int getItemData() { return this->itemData; }
++ void * getItemData() { return this->itemData; }
+
+ private:
+- const unsigned int itemData;
++ void *itemData;
+ };
+
+@@ -79,5 +79,5 @@
+ * Parameters:
+ * const char * - [in] item.
+- * unsigned int - [in] item data.
++ * void * - [in] item data.
+ *
+ * Output:
+@@ -87,5 +87,5 @@
+ (
+ const char *item,
+- unsigned int itemData
++ void *itemData
+ )
+ {
+@@ -169,5 +169,5 @@
+ ERRCODE SelectMeDialog::getSelectedItems
+ (
+- LinkList<unsigned int> & results
++ LinkList<void *> & results
+ )
+ {
+--- kiltdown/selectme.h 2001-05-13 23:25:23.000000000 -0400
++++ kiltdown/selectme.h 2008-05-21 22:56:51.000000000 -0400
+@@ -41,6 +41,6 @@
+ */
+ ERRCODE initializeUI(const char *title, const char *caption, bool multi = true);
+- ERRCODE addItem(const char *item, unsigned int itemData);
+- ERRCODE getSelectedItems(LinkList<unsigned int> &);
++ ERRCODE addItem(const char *item, void * itemData);
++ ERRCODE getSelectedItems(LinkList<void *> &);
+ void selectAll();
+
+--- kiltdown/template.cc 2001-05-13 23:25:23.000000000 -0400
++++ kiltdown/template.cc 2008-05-21 23:41:20.000000000 -0400
+@@ -30,5 +30,5 @@
+ template class LinkList<QPopupMenu *>;
+ template class LinkList<MailFolder *>;
+-template class LinkList<unsigned int>;
++template class LinkList<void *>;
+ template class LinkList<const char **>;
+ template class LinkList<ISubsystem *>;
+--- include/kmaillist.h 2001-05-13 23:25:23.000000000 -0400
++++ include/kmaillist.h 2008-05-22 00:10:06.000000000 -0400
+@@ -75,6 +75,6 @@
+ ColumnWidth type;
+ ColumnSorting sort;
+- unsigned int itemData;
+- int (*sortfn)(int, unsigned int, KMailListItem *, KMailListItem *);
++ void * itemData;
++ int (*sortfn)(int, void *, KMailListItem *, KMailListItem *);
+ };
+
+@@ -99,5 +99,5 @@
+ int ccolumns;
+ bool boldEntry; // should all the text be bolded?
+- unsigned int itemData; // whatever you want.
++ void * itemData; // whatever you want.
+ };
+
+@@ -178,5 +178,5 @@
+ * just yet.
+ */
+- ERRCODE getSelectedRows(LinkList<unsigned int> &);
++ ERRCODE getSelectedRows(LinkList<void *> &);
+
+ /**
+@@ -191,5 +191,5 @@
+ * other identifiers.
+ */
+- ERRCODE removeRows(int count, unsigned int *itemDataArray);
++ ERRCODE removeRows(int count, void * *itemDataArray);
+
+ /**
+@@ -203,5 +203,5 @@
+ * Given an identifier for a row, select it.
+ */
+- ERRCODE selectRowFromItemData(unsigned int);
++ ERRCODE selectRowFromItemData(void *);
+
+ /**
+@@ -216,5 +216,5 @@
+ * the columns.
+ */
+- ERRCODE updateRowFromItemData(unsigned int, KMailListItem *rowData);
++ ERRCODE updateRowFromItemData(void *, KMailListItem *rowData);
+
+ /**
+@@ -223,6 +223,6 @@
+ * NULL if the item is no longer in the list, or at the end/beginning.
+ */
+- KMailListItem *nextItem(unsigned int);
+- KMailListItem *previousItem(unsigned int);
++ KMailListItem *nextItem(void *);
++ KMailListItem *previousItem(void *);
+
+ /**
diff --git a/mail/kiltdown/files/patch-kmaillist.cc b/mail/kiltdown/files/patch-kmaillist.cc
index 5e2bbd2fc7df..4dc7530b97f1 100644
--- a/mail/kiltdown/files/patch-kmaillist.cc
+++ b/mail/kiltdown/files/patch-kmaillist.cc
@@ -1,23 +1,18 @@
---- kiltdown/kmaillist.cc.orig Mon May 14 05:25:23 2001
-+++ kiltdown/kmaillist.cc Mon Sep 9 11:53:44 2002
-@@ -12,6 +12,7 @@
-
+--- kiltdown/kmaillist.cc 2001-05-13 23:25:23.000000000 -0400
++++ kiltdown/kmaillist.cc 2008-05-21 23:23:49.000000000 -0400
+@@ -13,4 +13,5 @@
#include <qdrawutil.h>
#include <qpainter.h>
+#include <qstyle.h>
#include <stdio.h>
#include <string.h>
-
-@@ -616,6 +617,7 @@
- int w = this->drawableWidth() - PAD;
+@@ -617,4 +618,5 @@
int colwidth, colleft = PAD;
int x;
+ QRect *rect;
/**
- * First thing we need to do is figure out how much space the fixed width
-@@ -646,8 +648,12 @@
- if (!_backgroundBrush) _backgroundBrush = new QBrush(cg.color(QColorGroup::Button));
+@@ -647,6 +649,10 @@
if (!_backgroundBrush) return;
- style().drawBevelButton(&painter, colleft, 0, colwidth, getRowHeight(),
@@ -30,9 +25,14 @@
+ delete rect;
/**
- * Next, draw the text or the image.
-@@ -1717,15 +1723,15 @@
- && (x < (w + PAD + 1))
+@@ -1252,5 +1258,5 @@
+ ERRCODE KMailList::getSelectedRows
+ (
+- LinkList<unsigned int> &list
++ LinkList<void *> &list
+ )
+ {
+@@ -1718,13 +1724,13 @@
&& (headers[z - 1].type != CW_FIXED)) {
- this->setCursor(SplitVCursor);
@@ -49,13 +49,45 @@
+ this->setCursor(arrowCursor);
}
}
- break;
-@@ -2471,7 +2477,7 @@
- /**
+@@ -1984,5 +1990,5 @@
+ KMailListItem *KMailList::nextItem
+ (
+- unsigned int itemData
++ void * itemData
+ )
+ {
+@@ -2301,5 +2307,5 @@
+ KMailListItem *KMailList::previousItem
+ (
+- unsigned int itemData
++ void * itemData
+ )
+ {
+@@ -2335,5 +2341,5 @@
+ (
+ int count,
+- unsigned int *itemDataArray
++ void **itemDataArray
+ )
+ {
+@@ -2472,5 +2478,5 @@
* Finally, reset the cursor, mode, and repaint ourself.
*/
- this->setCursor(ArrowCursor);
+ this->setCursor(arrowCursor);
this->mouseMode = MMNormal;
emitColumnsChanged();
- this->forceUpdate();
+@@ -2571,5 +2577,5 @@
+ ERRCODE KMailList::selectRowFromItemData
+ (
+- unsigned int itemData
++ void * itemData
+ )
+ {
+@@ -2779,5 +2785,5 @@
+ ERRCODE KMailList::updateRowFromItemData
+ (
+- unsigned int itemData,
++ void * itemData,
+ KMailListItem *newRow
+ )
diff --git a/mail/kiltdown/files/patch-mailfolder.cc b/mail/kiltdown/files/patch-mailfolder.cc
index 89968ebed2df..369d619f583e 100644
--- a/mail/kiltdown/files/patch-mailfolder.cc
+++ b/mail/kiltdown/files/patch-mailfolder.cc
@@ -1,7 +1,67 @@
---- kiltdown/mailfolder.cc.orig Mon May 14 05:25:23 2001
-+++ kiltdown/mailfolder.cc Mon Sep 9 12:04:36 2002
-@@ -1353,10 +1353,10 @@
- messagePreview->setFont(QFont(pstr, i));
+--- kiltdown/mailfolder.cc 2001-05-13 23:25:23.000000000 -0400
++++ kiltdown/mailfolder.cc 2008-05-21 23:27:13.000000000 -0400
+@@ -263,5 +263,5 @@
+
+ item.boldEntry = unread;
+- item.itemData = (unsigned int)(message);
++ item.itemData = (void *)(message);
+ er = populateColumnsFromInfo(&item.columns, ccolumns, columns, message);
+ RETURN_ON_FAILURE(er);
+@@ -354,5 +354,5 @@
+ K_ASSERT((int)hdr[x].itemData >= 0 && (int)hdr[x].itemData <= MC_LAST, "Bogus MC_ Code!!!");
+
+- info[x].which = (enum MailColumn)hdr[x].itemData;
++ info[x].which = (enum MailColumn)(uintptr_t)hdr[x].itemData;
+ info[x].fixed = hdr[x].type == CW_FIXED;
+ info[x].width = hdr[x].width;
+@@ -497,5 +497,5 @@
+ {
+ int fewerUnread = 0;
+- unsigned int *rg;
++ void **rg;
+ ReadStatus rs;
+ bool ignoreAsk = false;
+@@ -530,8 +530,8 @@
+ * First, try and remove them from the UI
+ */
+- rg = (unsigned int *)localAlloc(count * sizeof(unsigned int));
++ rg = (void **)localAlloc(count * sizeof(void *));
+ if (!rg) return E_OUTOFMEMORY;
+ for (int x = 0; x < count; x++)
+- rg[x] = (unsigned int)deleteme[x];
++ rg[x] = (void *)deleteme[x];
+ messageView->removeRows(count, rg);
+ localFree(rg);
+@@ -655,8 +655,8 @@
+ ERRCODE MailFolder::enableMailListPopupItems()
+ {
+- LinkList<unsigned int> selectedItemDataList;
++ LinkList<void *> selectedItemDataList;
+ bool enableUnread = false;
+ bool enableRead = false;
+- unsigned int ui;
++ void *ui;
+ ReadStatus rs;
+ ERRCODE er;
+@@ -1127,6 +1127,6 @@
+ )
+ {
+- LinkList<unsigned int> list;
+- unsigned int a;
++ LinkList<void *> list;
++ void *a;
+ ERRCODE er;
+ int x;
+@@ -1221,6 +1221,6 @@
+ )
+ {
+- LinkList<unsigned int> selectedItemDataList;
+- unsigned int itemData;
++ LinkList<void *> selectedItemDataList;
++ void * itemData;
+ MailMessage *message;
+ ReadStatus rs;
+@@ -1354,8 +1354,8 @@
localFree(pstr);
}
- messagePreview->setUndoEnabled(false);
@@ -12,4 +72,54 @@
+ //messagePreview->setUndoEnabled(true);
er = S_OK;
+@@ -1709,6 +1709,6 @@
+ )
+ {
+- LinkList<unsigned int> selectedItemDataList;
+- unsigned int itemData;
++ LinkList<void *> selectedItemDataList;
++ void * itemData;
+ ERRCODE er;
+
+@@ -1777,5 +1777,5 @@
+ KMailListItem *item;
+
+- item = messageView->nextItem((unsigned int)index);
++ item = messageView->nextItem((void *)index);
+
+ return item ? (MailMessage *)item->itemData : NULL;
+@@ -1802,5 +1802,5 @@
+ KMailListItem *item;
+
+- item = messageView->previousItem((unsigned int)index);
++ item = messageView->previousItem((void *)index);
+
+ return item ? (MailMessage *)item->itemData : NULL;
+@@ -2414,5 +2414,5 @@
+ {
+ // updateMessageStatus(m);
+- messageView->selectRowFromItemData((unsigned int)m);
++ messageView->selectRowFromItemData((void *)m);
+ }
+
+@@ -2470,5 +2470,5 @@
+ for (int x = 0; x < ccolumns; x++) {
+
+- headers[x].itemData = columns[x].which;
++ headers[x].itemData = (void *)(uintptr_t)columns[x].which;
+ headers[x].width = columns[x].width;
+ headers[x].type = columns[x].fixed ? CW_FIXED : CW_PERCENTAGE;
+@@ -2610,5 +2610,5 @@
+ break;
+ }
+- item.itemData = (unsigned int)(messages[x]);
++ item.itemData = (void *)(messages[x]);
+ er = populateColumnsFromInfo(&item.columns, ccolumns, columns, messages[x]);
+@@ -2750,5 +2750,5 @@
+ memset(&item, 0, sizeof(KMailListItem));
+ item.boldEntry = (rsNew == MSG_UNOPENED);
+- item.itemData = (unsigned int)(message);
++ item.itemData = (void *)(message);
+ er = populateColumnsFromInfo(&item.columns, ccolumns, columns, message);
+ GOTO_ON_FAILURE(er, Error);
diff --git a/mail/kiltdown/files/patch-mailviewer.cc b/mail/kiltdown/files/patch-mailviewer.cc
index ae761c748d8b..f918ab7fff7c 100644
--- a/mail/kiltdown/files/patch-mailviewer.cc
+++ b/mail/kiltdown/files/patch-mailviewer.cc
@@ -1,7 +1,6 @@
---- kiltdown/mailviewer.cc.orig Sun May 15 22:29:50 2005
-+++ kiltdown/mailviewer.cc Sun May 15 22:28:00 2005
-@@ -950,13 +950,13 @@ void MailViewer::layoutComponents()
- ? ID_LOW_PRIORITY_TEXT
+--- kiltdown/mailviewer.cc 2001-05-13 23:25:23.000000000 -0400
++++ kiltdown/mailviewer.cc 2008-05-21 23:27:52.000000000 -0400
+@@ -951,11 +951,11 @@
: ID_HIGH_PRIORITY_TEXT);
if (pstr) {
- QPixmap p(p == LowPriority ? lowpriIcon : priorityhdrIcon);
@@ -18,4 +17,21 @@
+ this->width() - qp.width() - 13,
ctlHeight);
top += ctlHeight + 5;
- priorityPixLabel->show();
+@@ -1563,8 +1563,8 @@
+ )
+ {
+- LinkList<unsigned int> list;
++ LinkList<void *> list;
+ const char *pstr, *pstr2;
+ SelectMeDialog *smd;
+- unsigned int ui;
++ void *ui;
+ Attachment *a;
+ ERRCODE er;
+@@ -1592,5 +1592,5 @@
+ a->getFileName(&pstr);
+ if (pstr) {
+- smd->addItem(pstr, (unsigned int)a);
++ smd->addItem(pstr, (void *)a);
+ localFree(pstr);
+ }