aboutsummaryrefslogtreecommitdiffstats
path: root/mail/lbdb/Makefile
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2004-02-24 07:40:47 +0800
committerobraun <obraun@FreeBSD.org>2004-02-24 07:40:47 +0800
commitf42093be6357f171aebf57d9b32c73dd8c51f820 (patch)
treeaad18444bb3576ec43c145c897103eb53ee64d01 /mail/lbdb/Makefile
parent8523c7343924b3e30ec1c929b49cc47ee949c343 (diff)
downloadfreebsd-ports-gnome-f42093be6357f171aebf57d9b32c73dd8c51f820.tar.gz
freebsd-ports-gnome-f42093be6357f171aebf57d9b32c73dd8c51f820.tar.zst
freebsd-ports-gnome-f42093be6357f171aebf57d9b32c73dd8c51f820.zip
* Upgrade to 0.29.
* Remove BROKEN. * Grab maintainership. * Add evolution support. * Make gpg, abook, and evolution support optional, but auto detect. * Build package with gpg and abook support for POLA reasons.
Diffstat (limited to 'mail/lbdb/Makefile')
-rw-r--r--mail/lbdb/Makefile48
1 files changed, 40 insertions, 8 deletions
diff --git a/mail/lbdb/Makefile b/mail/lbdb/Makefile
index 3b6f29dc26b3..2239c7214ed0 100644
--- a/mail/lbdb/Makefile
+++ b/mail/lbdb/Makefile
@@ -6,20 +6,52 @@
#
PORTNAME= lbdb
-PORTVERSION= 0.28.2
+PORTVERSION= 0.29
CATEGORIES= mail
MASTER_SITES= http://www.spinnaker.de/debian/
DISTNAME= ${PORTNAME}_${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= obraun@FreeBSD.org
COMMENT= Set of tools for use with mutt's external mail address query feature
-BUILD_DEPENDS= abook:${PORTSDIR}/mail/abook \
- gpg:${PORTSDIR}/security/gnupg
-RUN_DEPENDS= abook:${PORTSDIR}/mail/abook \
- gpg:${PORTSDIR}/security/gnupg
+.include <bsd.port.pre.mk>
-BROKEN= "Does not fetch"
+.if exists (${LOCALBASE}/bin/gpg)
+WITH_GPG= yes
+.endif
+.if exists (${LOCALBASE}/bin/abook)
+WITH_ABOOK= yes
+.endif
+.if exists (${X11BASE}/bin/evolution)
+WITH_EVOLUTION= yes
+.endif
+
+.if defined(PACKAGE_BUILDING)
+WITH_GPG= yes
+WITH_ABOOK= yes
+.endif
+
+.if defined(WITH_GPG)
+BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
+RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
+PLIST_SUB+= GPG=""
+.else
+PLIST_SUB+= GPG="@comment "
+.endif
+.if defined(WITH_ABOOK)
+BUILD_DEPENDS+= abook:${PORTSDIR}/mail/abook
+RUN_DEPENDS+= abook:${PORTSDIR}/mail/abook
+PLIST_SUB+= ABOOK=""
+.else
+PLIST_SUB+= ABOOK="@comment "
+.endif
+.if defined(WITH_EVOLUTION)
+BUILD_DEPENDS+= evolution:${PORTSDIR}/mail/evolution
+RUN_DEPENDS+= evolution:${PORTSDIR}/mail/evolution
+PLIST_SUB+= EVOLUTION=""
+.else
+PLIST_SUB+= EVOLUTION="@comment "
+.endif
WRKSRC= ${WRKDIR}/lbdb-${PORTVERSION}
GNU_CONFIGURE= YES
@@ -30,4 +62,4 @@ USE_PERL5= yes
MAN1= nodelist2lbdb.1 lbdbq.1 lbdb-fetchaddr.1 lbdb_dotlock.1 \
mutt_ldap_query.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>