aboutsummaryrefslogtreecommitdiffstats
path: root/mail/libdomainkeys/Makefile
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2005-05-23 17:51:05 +0800
committerskv <skv@FreeBSD.org>2005-05-23 17:51:05 +0800
commit28d2848288a8b5721962d3f9ae7d4aa842039daa (patch)
treea68a9632cdaa03f6299d1011e01e8253740bf4b2 /mail/libdomainkeys/Makefile
parent8c082729245e8622a98edd2e8ffb276322c54a67 (diff)
downloadfreebsd-ports-gnome-28d2848288a8b5721962d3f9ae7d4aa842039daa.tar.gz
freebsd-ports-gnome-28d2848288a8b5721962d3f9ae7d4aa842039daa.tar.zst
freebsd-ports-gnome-28d2848288a8b5721962d3f9ae7d4aa842039daa.zip
Add libdomainkeys 0.63, DomainKeys library.
Diffstat (limited to 'mail/libdomainkeys/Makefile')
-rw-r--r--mail/libdomainkeys/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/mail/libdomainkeys/Makefile b/mail/libdomainkeys/Makefile
new file mode 100644
index 000000000000..edae4f6e8c42
--- /dev/null
+++ b/mail/libdomainkeys/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: libdomainkeys
+# Date created: 16 May 2005
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdomainkeys
+PORTVERSION= 0.63
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= domainkeys
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= DomainKeys library
+
+MAKE_ENV= PREFIX=${PREFIX} OPENSSLBASE="${OPENSSLBASE}"
+INSTALLS_SHLIB= YES
+SHLIB_MAJOR= 1
+PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
+
+USE_OPENSSL= YES
+
+.if defined(NOPROFILE)
+PLIST_SUB+= PROFILE="@comment "
+.else
+PLIST_SUB+= PROFILE=""
+.endif
+
+post-patch:
+ ${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.prev
+ @${SED} -e "s=%%SHLIB_MAJOR%%=${SHLIB_MAJOR}=g" \
+ ${FILESDIR}/Makefile > ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>