aboutsummaryrefslogtreecommitdiffstats
path: root/mail/libesmtp
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-10-20 21:15:34 +0800
committerijliao <ijliao@FreeBSD.org>2001-10-20 21:15:34 +0800
commit0101d24972dab7819f3ebe20d8df9d6fcdabebd0 (patch)
tree3cef0218039685028a8cc0068932eaffcd663d48 /mail/libesmtp
parent3e7ec26e21e771e8c496fefbe6a77efde3657e2d (diff)
downloadfreebsd-ports-gnome-0101d24972dab7819f3ebe20d8df9d6fcdabebd0.tar.gz
freebsd-ports-gnome-0101d24972dab7819f3ebe20d8df9d6fcdabebd0.tar.zst
freebsd-ports-gnome-0101d24972dab7819f3ebe20d8df9d6fcdabebd0.zip
Fix Null-Pointer Dereference causing SEGV
PR: 31376 Submitted by: maintainer
Diffstat (limited to 'mail/libesmtp')
-rw-r--r--mail/libesmtp/Makefile1
-rw-r--r--mail/libesmtp/files/patch-headers.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/mail/libesmtp/Makefile b/mail/libesmtp/Makefile
index 34e692b8968d..7c9390f019bd 100644
--- a/mail/libesmtp/Makefile
+++ b/mail/libesmtp/Makefile
@@ -6,6 +6,7 @@
PORTNAME= libesmtp
PORTVERSION= 0.8.6
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.stafford.uklinux.net/libesmtp/ \
http://www.theochem.kth.se/~pawsa/balsa/ \
diff --git a/mail/libesmtp/files/patch-headers.c b/mail/libesmtp/files/patch-headers.c
new file mode 100644
index 000000000000..7223def401c8
--- /dev/null
+++ b/mail/libesmtp/files/patch-headers.c
@@ -0,0 +1,11 @@
+--- headers.c Wed Oct 17 00:16:54 2001
++++ headers.c.new Fri Oct 19 08:58:56 2001
+@@ -688,7 +688,7 @@
+ if ((print = action->print) == NULL)
+ print = print_string;
+ cat_reset (&message->hdr_buffer, 0);
+- (*print) (message, message->current_header);
++ (*print) (message, info->hdr);
+ header = cat_buffer (&message->hdr_buffer, len);
+ }
+ }