aboutsummaryrefslogtreecommitdiffstats
path: root/mail/libetpan
diff options
context:
space:
mode:
authorstefan <stefan@FreeBSD.org>2007-10-02 04:37:42 +0800
committerstefan <stefan@FreeBSD.org>2007-10-02 04:37:42 +0800
commita4ba3d9b49dddcfd56de9dd20ac82754056271b5 (patch)
tree57df39be0b3b9899b9c02dcd58a6792f6588c76f /mail/libetpan
parent268940051e6cd2d37c3134b280b42f9a5ace80d9 (diff)
downloadfreebsd-ports-gnome-a4ba3d9b49dddcfd56de9dd20ac82754056271b5.tar.gz
freebsd-ports-gnome-a4ba3d9b49dddcfd56de9dd20ac82754056271b5.tar.zst
freebsd-ports-gnome-a4ba3d9b49dddcfd56de9dd20ac82754056271b5.zip
- Fix build WITH_GNUTLS=yes.
- Unconditionally depend on curl, expat2 and cyrus-sasl2. PR: 115875 Submitted by: bf <bf2006a@yahoo.com> Patch by: maintainer
Diffstat (limited to 'mail/libetpan')
-rw-r--r--mail/libetpan/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/mail/libetpan/Makefile b/mail/libetpan/Makefile
index f51d3bd61b36..ae1db431cffe 100644
--- a/mail/libetpan/Makefile
+++ b/mail/libetpan/Makefile
@@ -8,6 +8,7 @@
PORTNAME= libetpan
PORTVERSION= 0.52
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,6 +16,10 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= c0rn@o2.pl
COMMENT= A mail library
+LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
+ expat:${PORTSDIR}/textproc/expat2 \
+ sasl2.2:${PORTSDIR}/security/cyrus-sasl2
+
USE_ICONV= yes
USE_AUTOTOOLS= libtool:15 autoconf:261
USE_LDCONFIG= yes
@@ -23,20 +28,16 @@ USE_GMAKE= yes
CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
.if defined(WITH_GNUTLS)
LIB_DEPENDS+= gnutls.13:${PORTSDIR}/security/gnutls
-CONFIGURE_ARGS+= --with-gnutls
+CONFIGURE_ARGS+= --without-openssl --with-gnutls
.else
USE_OPENSSL= yes
CONFIGURE_ARGS+= --without-gnutls
.endif
-.if defined(WITH_SASL)
-LIB_DEPENDS+= sasl2.2:${PORTSDIR}/security/cyrus-sasl2
-.else
-CONFIGURE_ARGS+= --without-sasl
-.endif
-
post-install:
@${FIND} ${PREFIX}/include/libetpan* ! -type d | ${SED} \
's,^${PREFIX}/,,' >> ${TMPPLIST}