aboutsummaryrefslogtreecommitdiffstats
path: root/mail/libetpan
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-27 16:41:04 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-27 16:41:04 +0800
commitfe3cf526999e21daa1c073642c41c886dabd5d7b (patch)
treede58fdba0f1d80a570a62f90f34a8b34fee8ac7e /mail/libetpan
parentbfad5d9442c6a247163103c53a45ccfe72f4c776 (diff)
downloadfreebsd-ports-gnome-fe3cf526999e21daa1c073642c41c886dabd5d7b.tar.gz
freebsd-ports-gnome-fe3cf526999e21daa1c073642c41c886dabd5d7b.tar.zst
freebsd-ports-gnome-fe3cf526999e21daa1c073642c41c886dabd5d7b.zip
add libetpan 0.25
libEtPan! - a mail library
Diffstat (limited to 'mail/libetpan')
-rw-r--r--mail/libetpan/Makefile26
-rw-r--r--mail/libetpan/distinfo1
-rw-r--r--mail/libetpan/pkg-comment1
-rw-r--r--mail/libetpan/pkg-descr6
-rw-r--r--mail/libetpan/pkg-plist66
5 files changed, 100 insertions, 0 deletions
diff --git a/mail/libetpan/Makefile b/mail/libetpan/Makefile
new file mode 100644
index 000000000000..476d53828260
--- /dev/null
+++ b/mail/libetpan/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: libEtPan!
+# Date created: Jun 27, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libetpan
+PORTVERSION= 0.25
+CATEGORIES= mail
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= iconv:${PORTSDIR}/converters/libiconv
+
+USE_OPENSSL= yes
+USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/mail/libetpan/distinfo b/mail/libetpan/distinfo
new file mode 100644
index 000000000000..be1ec43624b8
--- /dev/null
+++ b/mail/libetpan/distinfo
@@ -0,0 +1 @@
+MD5 (libetpan-0.25.tar.gz) = 2b0933e353f49f41bf1d6adfc74ba2ff
diff --git a/mail/libetpan/pkg-comment b/mail/libetpan/pkg-comment
new file mode 100644
index 000000000000..865e528bca40
--- /dev/null
+++ b/mail/libetpan/pkg-comment
@@ -0,0 +1 @@
+libEtPan! - a mail library
diff --git a/mail/libetpan/pkg-descr b/mail/libetpan/pkg-descr
new file mode 100644
index 000000000000..cfba82221187
--- /dev/null
+++ b/mail/libetpan/pkg-descr
@@ -0,0 +1,6 @@
+The purpose of this mail library is to provide a portable, efficient
+middleware for different kinds of mail access. When using the drivers
+interface, the interface is the same for all kinds of mail access, remote
+and local mailboxes.
+
+WWW: http://libetpan.sourceforge.net/
diff --git a/mail/libetpan/pkg-plist b/mail/libetpan/pkg-plist
new file mode 100644
index 000000000000..5b85c75cfa24
--- /dev/null
+++ b/mail/libetpan/pkg-plist
@@ -0,0 +1,66 @@
+bin/libetpan-config
+include/libetpan/carray.h
+include/libetpan/charconv.h
+include/libetpan/chash.h
+include/libetpan/cinthash.h
+include/libetpan/clist.h
+include/libetpan/imapdriver.h
+include/libetpan/imapdriver_cached.h
+include/libetpan/mail.h
+include/libetpan/maildriver.h
+include/libetpan/maildriver_types.h
+include/libetpan/mailimap.h
+include/libetpan/mailimap_helper.h
+include/libetpan/mailimap_socket.h
+include/libetpan/mailimap_ssl.h
+include/libetpan/mailimap_types.h
+include/libetpan/mailimap_types_helper.h
+include/libetpan/mailimf.h
+include/libetpan/mailimf_types.h
+include/libetpan/mailimf_types_helper.h
+include/libetpan/mailimf_write.h
+include/libetpan/mailmbox.h
+include/libetpan/mailmbox_types.h
+include/libetpan/mailmh.h
+include/libetpan/mailmime.h
+include/libetpan/mailmime_content.h
+include/libetpan/mailmime_decode.h
+include/libetpan/mailmime_disposition.h
+include/libetpan/mailmime_types.h
+include/libetpan/mailmime_types_helper.h
+include/libetpan/mailmime_write.h
+include/libetpan/mailpop3.h
+include/libetpan/mailpop3_helper.h
+include/libetpan/mailpop3_socket.h
+include/libetpan/mailpop3_ssl.h
+include/libetpan/mailpop3_types.h
+include/libetpan/mailsmtp.h
+include/libetpan/mailsmtp_helper.h
+include/libetpan/mailsmtp_socket.h
+include/libetpan/mailsmtp_ssl.h
+include/libetpan/mailsmtp_types.h
+include/libetpan/mailstream.h
+include/libetpan/mailstream_helper.h
+include/libetpan/mailstream_low.h
+include/libetpan/mailstream_socket.h
+include/libetpan/mailstream_ssl.h
+include/libetpan/mailstream_types.h
+include/libetpan/mailthread.h
+include/libetpan/mboxdriver.h
+include/libetpan/mboxdriver_cached.h
+include/libetpan/mhdriver.h
+include/libetpan/mhdriver_cached.h
+include/libetpan/mmapstring.h
+include/libetpan/newsnntp.h
+include/libetpan/newsnntp_socket.h
+include/libetpan/newsnntp_ssl.h
+include/libetpan/newsnntp_types.h
+include/libetpan/nntpdriver.h
+include/libetpan/nntpdriver_cached.h
+include/libetpan/pop3driver.h
+include/libetpan/pop3driver_cached.h
+@dirrm include/libetpan
+lib/libetpan.a
+lib/libetpan.la
+lib/libetpan.so
+lib/libetpan.so.0