aboutsummaryrefslogtreecommitdiffstats
path: root/mail/libpst/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-11-14 22:03:45 +0800
committerpav <pav@FreeBSD.org>2008-11-14 22:03:45 +0800
commita133725b7632401a0ccf5ed4238dfe53329a72a4 (patch)
tree91a12084c12a71be747c98216c9c437f7704a8a1 /mail/libpst/Makefile
parent7dbc172cd9f58ce34c00c143405fe973a94b8d1b (diff)
downloadfreebsd-ports-gnome-a133725b7632401a0ccf5ed4238dfe53329a72a4.tar.gz
freebsd-ports-gnome-a133725b7632401a0ccf5ed4238dfe53329a72a4.tar.zst
freebsd-ports-gnome-a133725b7632401a0ccf5ed4238dfe53329a72a4.zip
- Update to 0.6.17
PR: ports/126345 Submitted by: bf <bf2006a@yahoo.com> Approved by: maintainer timeout (1 month)
Diffstat (limited to 'mail/libpst/Makefile')
-rw-r--r--mail/libpst/Makefile39
1 files changed, 32 insertions, 7 deletions
diff --git a/mail/libpst/Makefile b/mail/libpst/Makefile
index 8616bd237587..dbf1c6032a25 100644
--- a/mail/libpst/Makefile
+++ b/mail/libpst/Makefile
@@ -6,17 +6,42 @@
#
PORTNAME= libpst
-PORTVERSION= 0.5.1
+PORTVERSION= 0.6.17
CATEGORIES= mail converters
-MASTER_SITES= http://alioth.debian.org/frs/download.php/844/
-EXTRACT_SUFX= .tgz
+MASTER_SITES= http://www.five-ten-sg.com/libpst/packages/
MAINTAINER= natey@natey.com
-COMMENT= A tool for converting Outlook .pst files to Unix mbox format
+COMMENT= A tool for converting Outlook .pst files to mbox and other formats
-USE_GMAKE= YES
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_ICONV= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -liconv
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-MAN1= readpst.1 readpstlog.1
-PLIST_FILES= bin/readpst bin/readpstlog bin/lspst
+.if exists(${LOCALBASE}/bin/convert) || defined(WITH_PST2DII)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/convert:${PORTSDIR}/graphics/ImageMagick
+RUN_DEPENDS+= ${LOCALBASE}/bin/convert:${PORTSDIR}/graphics/ImageMagick
+LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
+PLIST_SUB+= PST2DII=""
+.else
+PLIST_SUB+= PST2DII="@comment "
+.endif
+
+MAN1= lspst.1 pst2dii.1 pst2ldif.1 readpst.1 readpstlog.1
+MAN5= outlook.pst.5
+
+post-patch:
+ ${FIND} -X ${WRKSRC} -type f | ${XARGS} ${REINPLACE_CMD} -e 's/malloc.h/stdlib.h/g'
+ ${REINPLACE_CMD} -e 's;doc\/@PACKAGE@-@VERSION@;doc\/@PACKAGE@;g' ${WRKSRC}/Makefile.in \
+ ${WRKSRC}/html/Makefile.in
+
+.ifdef(NOPORTDOCS)
+INSTALL_TARGET= install-exec
+
+post-install:
+ @(cd ${WRKSRC}/man && ${GMAKE} ${MAKE_ARGS} install)
+.endif
.include <bsd.port.mk>