aboutsummaryrefslogtreecommitdiffstats
path: root/mail/libspf
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-13 13:55:02 +0800
committerbapt <bapt@FreeBSD.org>2012-06-13 13:55:02 +0800
commit818ed17bddcf2339d4165dbf978b07adf9ca9678 (patch)
tree9290ad281aeea9dc740177140c2842fb9f3789ca /mail/libspf
parentaaf14a1e63df682f8359db1ef5b7efbd954e91df (diff)
downloadfreebsd-ports-gnome-818ed17bddcf2339d4165dbf978b07adf9ca9678.tar.gz
freebsd-ports-gnome-818ed17bddcf2339d4165dbf978b07adf9ca9678.tar.zst
freebsd-ports-gnome-818ed17bddcf2339d4165dbf978b07adf9ca9678.zip
Convert to new options framework
Diffstat (limited to 'mail/libspf')
-rw-r--r--mail/libspf/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/mail/libspf/Makefile b/mail/libspf/Makefile
index 306cab0d2d28..df8bbaa9c82e 100644
--- a/mail/libspf/Makefile
+++ b/mail/libspf/Makefile
@@ -23,21 +23,21 @@ USE_LDCONFIG= yes
PORTDOCS= *
-OPTIONS= RFC_RECURSION "Change SPF recursion to 20 (as per RFC)" off \
- LOGFILE_STATS "Enables logfile stats" off \
- DEBUG "Enables debug option" off
+OPTIONS_DEFINE= RFC_RECURSION LOGFILE_STATS DEBUG DOCS
+RFC_RECURSION_DESC= Change SPF recursion to 20 (as per RFC)
+LOGFILE_STATS_DESC= Enables logfile stats
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_RFC_RECURSION)
+.if ${PORT_OPTIONS:MRFC_RECURSION}
CONFIGURE_ARGS+= --enable-rfc-recursion
.endif
-.if defined(WITH_LOGFILE_STATS)
+.if ${PORT_OPTIONS:MLOGFILE_STATS}
CONFIGURE_ARGS+= --enable-logfile-stats
.endif
-.if defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-debug
.endif
@@ -46,7 +46,7 @@ post-patch:
${WRKSRC}/src/libspf/Makefile.in ${WRKSRC}/src/spfqtool/Makefile.in
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${FIND} ${WRKSRC}/docs -type d -name CVS | ${XARGS} ${RM} -rf
.for i in docs docs/API docs/API/doxygen docs/API/doxygen/html docs/RFC docs/qmail \
@@ -78,4 +78,4 @@ post-install:
done
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>