aboutsummaryrefslogtreecommitdiffstats
path: root/mail/libvmime
diff options
context:
space:
mode:
authordelphij <delphij@FreeBSD.org>2009-12-09 01:59:00 +0800
committerdelphij <delphij@FreeBSD.org>2009-12-09 01:59:00 +0800
commitf1d43581705f7201679501fd9504398246f7700d (patch)
tree848283f1cccc9cf714585e4cdbd6b438070fc046 /mail/libvmime
parent8e509fe80af14748ca7f1de0ef6416fa9d2c3340 (diff)
downloadfreebsd-ports-gnome-f1d43581705f7201679501fd9504398246f7700d.tar.gz
freebsd-ports-gnome-f1d43581705f7201679501fd9504398246f7700d.tar.zst
freebsd-ports-gnome-f1d43581705f7201679501fd9504398246f7700d.zip
- Fix a possible segfault in stringUtils::countASCIIchars()
- Fix body contents not generating bug caused by stream::reset() won't reset EOF condition. Obtained from: vmime svn
Diffstat (limited to 'mail/libvmime')
-rw-r--r--mail/libvmime/Makefile2
-rw-r--r--mail/libvmime/files/patch-src__platforms__posix__posixFile.cpp11
-rw-r--r--mail/libvmime/files/patch-src__utility__stringUtils.cpp11
3 files changed, 23 insertions, 1 deletions
diff --git a/mail/libvmime/Makefile b/mail/libvmime/Makefile
index 75391ad29669..16f4afd9959e 100644
--- a/mail/libvmime/Makefile
+++ b/mail/libvmime/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libvmime
PORTVERSION= 0.9.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= mail
MASTER_SITES= SF/vmime/vmime/0.9
diff --git a/mail/libvmime/files/patch-src__platforms__posix__posixFile.cpp b/mail/libvmime/files/patch-src__platforms__posix__posixFile.cpp
new file mode 100644
index 000000000000..a2761a826c28
--- /dev/null
+++ b/mail/libvmime/files/patch-src__platforms__posix__posixFile.cpp
@@ -0,0 +1,11 @@
+--- ./src/platforms/posix/posixFile.cpp.orig 2008-10-12 02:42:23.000000000 -0700
++++ ./src/platforms/posix/posixFile.cpp 2009-12-08 09:48:30.536227969 -0800
+@@ -166,7 +166,7 @@
+ if ((c = ::read(m_fd, data, count)) == -1)
+ posixFileSystemFactory::reportError(m_path, errno);
+
+- if (c == 0)
++ if (c == 0 && count != 0)
+ m_eof = true;
+
+ return static_cast <size_type>(c);
diff --git a/mail/libvmime/files/patch-src__utility__stringUtils.cpp b/mail/libvmime/files/patch-src__utility__stringUtils.cpp
new file mode 100644
index 000000000000..c423178e521d
--- /dev/null
+++ b/mail/libvmime/files/patch-src__utility__stringUtils.cpp
@@ -0,0 +1,11 @@
+--- ./src/utility/stringUtils.cpp.orig 2008-10-12 02:11:24.000000000 -0700
++++ ./src/utility/stringUtils.cpp 2009-12-08 09:48:30.547226336 -0800
+@@ -142,7 +142,7 @@
+ {
+ if (parserHelpers::isAscii(*i))
+ {
+- if (*i != '=' || *(i + 1) != '?') // To avoid bad behaviour...
++ if (*i != '=' || ((i + 1) != end && *(i + 1) != '?')) // To avoid bad behaviour...
+ ++count;
+ }
+ }