aboutsummaryrefslogtreecommitdiffstats
path: root/mail/lmtpd/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-05-25 01:09:28 +0800
committerpav <pav@FreeBSD.org>2005-05-25 01:09:28 +0800
commit89a471226c24e7406aee9da0cebf03e40ecfdb61 (patch)
tree065807dfdf238f2202415a5cf8b7f5edcf91967a /mail/lmtpd/Makefile
parent4a90aed8d7b8fd7336ad4feeddb7823ff996597b (diff)
downloadfreebsd-ports-gnome-89a471226c24e7406aee9da0cebf03e40ecfdb61.tar.gz
freebsd-ports-gnome-89a471226c24e7406aee9da0cebf03e40ecfdb61.tar.zst
freebsd-ports-gnome-89a471226c24e7406aee9da0cebf03e40ecfdb61.zip
- Properly fix plist problems here. The symlinks are created dynamically
depending on content of share/nls which different between FreeBSD releases. Also remove empty directories according to present mtree.
Diffstat (limited to 'mail/lmtpd/Makefile')
-rw-r--r--mail/lmtpd/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/mail/lmtpd/Makefile b/mail/lmtpd/Makefile
index 23862fc30db6..e24efcc67eba 100644
--- a/mail/lmtpd/Makefile
+++ b/mail/lmtpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lmtpd
PORTVERSION= 0.9.24
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.oav.net/pll/ ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pll
@@ -85,5 +86,11 @@ post-install:
@${MKDIR} ${DOCSDIR}
cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
.endif
+ ${FIND} ${PREFIX}/share/nls -type d -name 'fr_*8859*' ! -name fr_FR.ISO_8859-1 -exec basename {} \; | ${XARGS} -n1 -I % echo share/nls/%/filtercheck.cat >> ${TMPPLIST}
+ ${FIND} ${PREFIX}/share/nls -type d -name 'fr_*.UTF-8' ! -name fr_FR.UTF-8 -exec basename {} \; | ${XARGS} -n1 -I % echo share/nls/%/filtercheck.cat >> ${TMPPLIST}
+ ${FIND} ${PREFIX}/share/nls -type d -name 'en_*' -exec basename {} \; | ${XARGS} -n1 -I % echo share/nls/%/filtercheck.cat >> ${TMPPLIST}
+ ${FIND} ${PREFIX}/share/nls -type d -name 'fr_*8859*' -exec basename {} \; | ${XARGS} -n1 -I _ -R 2 echo "@unexec if ! grep -q _ ${MTREE_FILE} ; then rmdir %D/share/nls/_ >/dev/null || true ; fi" >> ${TMPPLIST}
+ ${FIND} ${PREFIX}/share/nls -type d -name 'fr_*.UTF-8' -exec basename {} \; | ${XARGS} -n1 -I _ -R 2 echo "@unexec if ! grep -q _ ${MTREE_FILE} ; then rmdir %D/share/nls/_ >/dev/null || true ; fi" >> ${TMPPLIST}
+ ${FIND} ${PREFIX}/share/nls -type d -name 'en*' -exec basename {} \; | ${XARGS} -n1 -I _ -R 2 echo "@unexec if ! grep -q _ ${MTREE_FILE} ; then rmdir %D/share/nls/_ >/dev/null || true ; fi" >> ${TMPPLIST}
.include <bsd.port.post.mk>