aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mahogany/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-11-03 07:43:43 +0800
committermarcus <marcus@FreeBSD.org>2003-11-03 07:43:43 +0800
commite6d54a1bc336f4de798e821840d68d3030bb0f24 (patch)
treed5e2ee7123c4fc289e34505dc98a4515e2c97322 /mail/mahogany/Makefile
parent4dc0521253e23f59e29f08bb7527646f3a26557d (diff)
downloadfreebsd-ports-gnome-e6d54a1bc336f4de798e821840d68d3030bb0f24.tar.gz
freebsd-ports-gnome-e6d54a1bc336f4de798e821840d68d3030bb0f24.tar.zst
freebsd-ports-gnome-e6d54a1bc336f4de798e821840d68d3030bb0f24.zip
Update to 0.65.
* python interpreter works only with python 2.1 and older, and is no longer maintained by the authors, so i disabled it and changed CATEGORIES and COMMENT accordingly * removed latex dependency and not installing Manual it's weird to have to install whole latex just to build documentation to mail client. built docs in html are available on mahogany website. PR: 57589 Submitted by: Pav Lucistnik <pav@oook.cz> Approved by: maintainer
Diffstat (limited to 'mail/mahogany/Makefile')
-rw-r--r--mail/mahogany/Makefile38
1 files changed, 14 insertions, 24 deletions
diff --git a/mail/mahogany/Makefile b/mail/mahogany/Makefile
index 01c9dfe18f71..d71736da229d 100644
--- a/mail/mahogany/Makefile
+++ b/mail/mahogany/Makefile
@@ -6,40 +6,30 @@
#
PORTNAME= mahogany
-PORTVERSION= 0.60
-PORTREVISION= 1
-CATEGORIES= mail python
+PORTVERSION= 0.65
+CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= mahogany
MAINTAINER= sk-ports@vegamuse.org
-COMMENT= An X11 mail and news client with an embedded Python interpreter
+COMMENT= An X11 mail and news client
-BROKEN= "Does not compile"
+LIB_DEPENDS+= wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk-devel
-LIB_DEPENDS+= wx_gtk-2.2.2:${PORTSDIR}/x11-toolkits/wxgtk
-BUILD_DEPENDS+= swig:${PORTSDIR}/devel/swig11
-.if !defined(NOPORTDOCS)
-BUILD_DEPENDS+= latex2html:${PORTSDIR}/textproc/latex2html
-.endif
-
-USE_PYTHON= yes
-PYTHON_VERSION= python1.5
-USE_AUTOCONF_VER= 213
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_ENV+= OSTYPE=${OPSYS}
-
+USE_REINPLACE= yes
+ALL_TARGET= all locales
INSTALL_TARGET= install_bin install_locale
-.if !defined(NOPORTDOCS)
-INSTALL_TARGET+= install_doc
-.endif
-MAN1= mahogany.1
+MAN1= M.1 mahogany.1
-CONFIGURE_ARGS= --with-threads
+CONFIGURE_ARGS= --with-python=none
+CONFIGURE_ENV= OSTYPE=${OPSYS} CFLAGS="${CFLAGS}"
-post-install:
- @${STRIP_CMD} ${PREFIX}/bin/mahogany
- @${CAT} ${PKGMESSAGE}
+post-patch:
+ @${REINPLACE_CMD} -e 's|-DOPENSSL_NO_KRB5||' -e 's|-O2|${CFLAGS}|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|$$(DATADIR)/locale|$$(DESTDIR)/share/locale|' ${WRKSRC}/locale/Makefile
.include <bsd.port.mk>