aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mailagent
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-04-02 17:21:33 +0800
committerpav <pav@FreeBSD.org>2010-04-02 17:21:33 +0800
commitfe727bddcd3b70c77d47994eb8a1330c841334af (patch)
treed9072ad9d34472e7e2bffe3510826acd1ec535cb /mail/mailagent
parent52e8ba630a28e27dae7dc2685215c0b866053ede (diff)
downloadfreebsd-ports-gnome-fe727bddcd3b70c77d47994eb8a1330c841334af.tar.gz
freebsd-ports-gnome-fe727bddcd3b70c77d47994eb8a1330c841334af.tar.zst
freebsd-ports-gnome-fe727bddcd3b70c77d47994eb8a1330c841334af.zip
- Update to 3.1.65
PR: ports/144204 Submitted by: Yoshiaki Kasahara <kasahara@nc.kyushu-u.ac.jp>
Diffstat (limited to 'mail/mailagent')
-rw-r--r--mail/mailagent/Makefile9
-rw-r--r--mail/mailagent/distinfo6
-rw-r--r--mail/mailagent/files/patch-agent::pl::compress.pl13
3 files changed, 21 insertions, 7 deletions
diff --git a/mail/mailagent/Makefile b/mail/mailagent/Makefile
index 3f631b33e5b8..4021ff87332a 100644
--- a/mail/mailagent/Makefile
+++ b/mail/mailagent/Makefile
@@ -6,16 +6,16 @@
#
PORTNAME= mailagent
-PORTVERSION= 3.0.73
-PORTREVISION= 1
+PORTVERSION= 3.1.65
CATEGORIES= mail
-MASTER_SITES= CPAN
-MASTER_SITE_SUBDIR= ../../authors/id/RAM
+MASTER_SITES= http://eron.info/
MAINTAINER= ports@FreeBSD.org
COMMENT= A sophisticated automatic mail-processing tool
USE_PERL5= yes
+USE_BZIP2= yes
+
NO_PACKAGE= Correct FQDN needs to be hardcoded
IS_INTERACTIVE= yes
HAS_CONFIGURE= yes
@@ -26,6 +26,7 @@ CONFIGURE_ARGS= -dres \
-Dd_flockonly='define' \
-Dutmp='/var/run/utmp' \
-Dprefix='${PREFIX}' -Dmansrc='${PREFIX}/man/man1'
+MAKE_JOBS_UNSAFE= yes
MAKE_ENV= PATH=`dirname ${PERL5}`:${PATH}
INSTALL_TARGET= install install.man
diff --git a/mail/mailagent/distinfo b/mail/mailagent/distinfo
index da31f800284c..be1be3e4b7cb 100644
--- a/mail/mailagent/distinfo
+++ b/mail/mailagent/distinfo
@@ -1,3 +1,3 @@
-MD5 (mailagent-3.0.73.tar.gz) = bd1d450307956933c1465de79ef9e46d
-SHA256 (mailagent-3.0.73.tar.gz) = 99c42f7496d301d8655e859c253d803553f5e50bc085d089e617e0945e455c2e
-SIZE (mailagent-3.0.73.tar.gz) = 533579
+MD5 (mailagent-3.1.65.tar.bz2) = 8ba6f9f5bdf850b19d6f38e7d02a3322
+SHA256 (mailagent-3.1.65.tar.bz2) = 3212c1e0118ccdae5209950377debe70ec3fa15dbe2b1dc422568f3e5dcd8ba1
+SIZE (mailagent-3.1.65.tar.bz2) = 454295
diff --git a/mail/mailagent/files/patch-agent::pl::compress.pl b/mail/mailagent/files/patch-agent::pl::compress.pl
new file mode 100644
index 000000000000..1432df1294e9
--- /dev/null
+++ b/mail/mailagent/files/patch-agent::pl::compress.pl
@@ -0,0 +1,13 @@
+--- agent/pl/compress.pl.ORIG 2010-04-02 11:34:22.000000000 +0900
++++ agent/pl/compress.pl 2010-04-02 12:06:36.000000000 +0900
+@@ -63,9 +63,8 @@
+ unless (open(COMPSPEC, "$cf'compspec")) {
+ # Configure a set of defaults if the user hasn't specified them manually
+ # Fields are: tag extension compression_prog uncompress_prog cat_prog
+- # The following legacy line removed as modern systems lack compress:
+- # compress .Z compress uncompress zcat
+ &add_compressor(<<'EOT');
++compress .Z compress uncompress zcat
+ gzip .gz gzip gunzip gunzip -c
+ bzip2 .bz2 bzip2 bunzip2 bzcat
+ EOT