aboutsummaryrefslogtreecommitdiffstats
path: root/mail/maildrop
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2012-10-20 16:49:11 +0800
committermadpilot <madpilot@FreeBSD.org>2012-10-20 16:49:11 +0800
commit609656c809aaa93e3dfaf1a23a762ab48e15a3f8 (patch)
treee4b151d60ded9c1d59f39b71a776ce007bd02bc1 /mail/maildrop
parentfc318c4a89ab39845a2f529bd5933a85a5e50d83 (diff)
downloadfreebsd-ports-gnome-609656c809aaa93e3dfaf1a23a762ab48e15a3f8.tar.gz
freebsd-ports-gnome-609656c809aaa93e3dfaf1a23a762ab48e15a3f8.tar.zst
freebsd-ports-gnome-609656c809aaa93e3dfaf1a23a762ab48e15a3f8.zip
- Fix paths to html documentation in man pages [1]
- Bump PORTREVISION - While here perform a whitespace fix and move MAN* variables where they belong. Reported by: Bjoern Voigt <bjoernv@arcor.de> [1] Feature safe: yes
Diffstat (limited to 'mail/maildrop')
-rw-r--r--mail/maildrop/Makefile34
1 files changed, 25 insertions, 9 deletions
diff --git a/mail/maildrop/Makefile b/mail/maildrop/Makefile
index ff72344734ff..fbdb6be001c6 100644
--- a/mail/maildrop/Makefile
+++ b/mail/maildrop/Makefile
@@ -17,6 +17,7 @@
PORTNAME= maildrop
PORTVERSION= 2.6.0
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= SF/courier/${PORTNAME}/${PORTVERSION}
@@ -37,12 +38,30 @@ CONFIGURE_ARGS= --enable-syslog=1 \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-CONFLICTS= courier-0.65*
+CONFLICTS= courier-0.65*
LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
MAILDROP_LOG_COLUMNS?= 72 # lenght of 'File:' line in log
+FIXDOCPATH= liblock/lockmail.1 maildir/deliverquota.8.in \
+ maildir/maildir.5 maildir/maildiracl.1.in \
+ maildir/maildirkw.1 maildir/maildirmake.1.in \
+ maildir/maildirquota.7 maildrop/mailbot.1 \
+ maildrop/maildrop.1.in maildrop/maildropex.7 \
+ maildrop/maildropfilter.7.in maildrop/maildropgdbm.7 \
+ maildrop/makedat.1 maildrop/reformail.1 \
+ rfc2045/makemime.1 rfc2045/reformime.1 \
+ rfc2045/rfc2045.3 rfc822/rfc822.3
+
+MAN1+= lockmail.1 mailbot.1 maildrop-maildirmake.1 maildrop.1 makemime.1 \
+ reformail.1 reformime.1
+MAN5= maildir.5
+MAN7= maildirquota.7 maildropex.7 maildropfilter.7 maildropgdbm.7
+MAN8+= maildrop-deliverquota.8
+DOCS= AUTHORS INSTALL INSTALL.html README README.html README.postfix \
+ UPGRADE UPGRADE.html maildroptips.txt maildir/README.*
+
.if defined(WITH_AUTHLIB)
.if exists(${.CURDIR}/../../security/courier-authlib/Makefile.opt)
.include "${.CURDIR}/../../security/courier-authlib/Makefile.opt"
@@ -90,6 +109,11 @@ PLIST_SUB+= DOVECOTAUTH="@comment "
post-patch:
@${REINPLACE_CMD} -e "s/l= 72 - szbuf.Length();/l= ${MAILDROP_LOG_COLUMNS} - szbuf.Length();/" \
${WRKSRC}/maildrop/log.C
+.for f in ${FIXDOCPATH}
+ @${REINPLACE_CMD} -e "s|\\\%\[set \$$man\.base\.url\.for\.relative\.links\]|${DOCSDIR}|" \
+ -e "s/\(maildirmake.html\)/maildrop-\1/" \
+ -e "s/\(deliverquota.html\)/maildrop-\1/" ${WRKSRC}/${f}
+.endfor
.if defined(WITH_AUTHLIB)
@${REINPLACE_CMD} -e 's|@LIBS@|@LIBS@ -rpath=:${LOCALBASE}/lib/courier-authlib|' \
${WRKSRC}/maildrop/Makefile.in
@@ -110,14 +134,6 @@ INSTALL_TARGET= install-maildrop install-deliverquota install-man
INSTALL_TARGET= install-strip
.endif
-MAN1+= lockmail.1 mailbot.1 maildrop-maildirmake.1 maildrop.1 makemime.1 \
- reformail.1 reformime.1
-MAN5= maildir.5
-MAN7= maildirquota.7 maildropex.7 maildropfilter.7 maildropgdbm.7
-MAN8+= maildrop-deliverquota.8
-DOCS= AUTHORS INSTALL INSTALL.html README README.html README.postfix \
- UPGRADE UPGRADE.html maildroptips.txt maildir/README.*
-
post-install:
${INSTALL_DATA} ${WRKSRC}/maildir/quotawarnmsg \
${PREFIX}/etc/quotawarnmsg.sample