aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mailest
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2015-07-19 01:06:09 +0800
committerhrs <hrs@FreeBSD.org>2015-07-19 01:06:09 +0800
commit07516fc7045a0dae6ed025e6c390142e9bda0b01 (patch)
tree4101cae37abe93fff0b0275f02a9bf95998afe07 /mail/mailest
parent6889c3f7af8428162404bfa8a31c998f4015682a (diff)
downloadfreebsd-ports-gnome-07516fc7045a0dae6ed025e6c390142e9bda0b01.tar.gz
freebsd-ports-gnome-07516fc7045a0dae6ed025e6c390142e9bda0b01.tar.zst
freebsd-ports-gnome-07516fc7045a0dae6ed025e6c390142e9bda0b01.zip
- Correct LICENSE.
- Regenerate patch files to make portlint happy.
Diffstat (limited to 'mail/mailest')
-rw-r--r--mail/mailest/Makefile33
-rw-r--r--mail/mailest/files/patch-mailestd-Makefile8
-rw-r--r--mail/mailest/files/patch-mailestd.c14
3 files changed, 36 insertions, 19 deletions
diff --git a/mail/mailest/Makefile b/mail/mailest/Makefile
index 7e07d6e0fbc6..6da43615d062 100644
--- a/mail/mailest/Makefile
+++ b/mail/mailest/Makefile
@@ -2,16 +2,17 @@
PORTNAME= mailest
PORTVERSION= 0.9.20
+PORTREVISION= 1
CATEGORIES= mail
MAINTAINER= hrs@FreeBSD.org
COMMENT= Hyper Estraier backend for Mew
-LICENSE= BSD2CLAUSE ISCL LGPL21
+LICENSE= BSD2CLAUSE BSD3CLAUSE ISCL LGPL21
LICENSE_COMB= multi
-LICENSE_FILE_BSD2CLAUSE=${WRKSRC}/LICENSE.BSD2CLAUSE
-LICENSE_FILE_ISCL= ${WRKSRC}/LICENSE.ISCL
-LICENSE_FILE_LGPL21= ${WRKSRC}/LICENSE.LGPL21
+.for L in ${LICENSE}
+LICENSE_FILE_${L}= ${WRKSRC}/LICENSE.${L}
+.endfor
LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2 \
libqdbm.so:${PORTSDIR}/databases/qdbm \
@@ -25,10 +26,26 @@ GH_ACCOUNT= yasuoka
GH_TAGNAME= ${PORTNAME}-${PORTVERSION}
MAKE_ENV= USE_BSDMAKE=true WITH_INSTALL_AS_USER=true
+LICENSE_BSD2CLAUSE_SRC= bytebuf.c replace/sys/tree.h
+LICENSE_BSD3CLAUSE_SRC= replace/sys/queue.h
+LICENSE_ISCL_SRC= mailestctl.c parser.c parser.h \
+ replace/open_memstream.c \
+ replace/reallocarray.c \
+ replace/replace.h \
+ replace/strlcat.c \
+ replace/strtonum.c
+LICENSE_LGPL21_SRC= estdraft.c
+LICENSE_BSD2CLAUSE_REGEX="/ \* [Cc]opyright/,/ \*\//!d;s,^ \*,,;s,^/,,"
+LICENSE_BSD3CLAUSE_REGEX=${LICENSE_BSD2CLAUSE_REGEX}
+LICENSE_ISCL_REGEX= ${LICENSE_BSD2CLAUSE_REGEX}
+LICENSE_LGPL21_REGEX= "/^\/\*\*/,/\*\*\//!d;s,^ \*,,;s,^/,,"
+
post-extract:
- ${SED} "/\*-/,/*\//!d" ${WRKSRC}/bytebuf.c > ${LICENSE_FILE_BSD2CLAUSE}
- ${SED} "/^\/\*/,/ *\//!d" ${WRKSRC}/mailestctl.c > ${LICENSE_FILE_ISCL}
- ${SED} "/^\/\*\*/,/\*\*\//!d" ${WRKSRC}/estdraft.c \
- > ${LICENSE_FILE_LGPL21}
+.for L in ${LICENSE}
+.for F in ${LICENSE_${L}_SRC}
+ cd ${WRKSRC} && ${SED} -e ${LICENSE_${L}_REGEX} ${F} \
+ >> ${LICENSE_FILE_${L}}
+.endfor
+.endfor
.include <bsd.port.mk>
diff --git a/mail/mailest/files/patch-mailestd-Makefile b/mail/mailest/files/patch-mailestd-Makefile
index c1aee6e150b6..0de943750c62 100644
--- a/mail/mailest/files/patch-mailestd-Makefile
+++ b/mail/mailest/files/patch-mailestd-Makefile
@@ -1,6 +1,6 @@
---- mailestd/Makefile.orig 2015-05-27 12:18:27.000000000 +0900
-+++ mailestd/Makefile 2015-06-05 16:09:10.228594000 +0900
-@@ -2,9 +2,9 @@
+--- mailestd/Makefile.orig 2015-06-06 10:45:32 UTC
++++ mailestd/Makefile
+@@ -2,9 +2,9 @@ MAILESTD_MT= #
PROG= mailestd
SRCS= bytebuf.c mailestd.c mailestctl.c parse.y parser.c
@@ -12,7 +12,7 @@
LDFLAGS= -L${LOCALBASE}/lib
LDADD= -lestraier -levent -lqdbm
DPADD= ${LIBESTRAIER} ${LIBEVENT} ${LIBQDBM}
-@@ -21,13 +21,7 @@
+@@ -21,13 +21,7 @@ LDADD+= -lpthread
DPADD+= ${LIBPTHREAD}
.endif
diff --git a/mail/mailest/files/patch-mailestd.c b/mail/mailest/files/patch-mailestd.c
index 3421d0c49550..4766928d0f99 100644
--- a/mail/mailest/files/patch-mailestd.c
+++ b/mail/mailest/files/patch-mailestd.c
@@ -1,6 +1,6 @@
---- mailestd.c.orig 2015-05-27 12:18:27.000000000 +0900
-+++ mailestd.c 2015-06-05 16:21:58.350309000 +0900
-@@ -809,8 +809,6 @@
+--- mailestd.c.orig 2015-06-06 10:45:32 UTC
++++ mailestd.c
+@@ -809,8 +809,6 @@ mailestd_gather(struct mailestd *_this,
RB_INIT(&folders);
ctx = mailestd_get_gather(_this, task->gather_id);
@@ -9,7 +9,7 @@
if (folder[0] == '/')
strlcpy(rdir, folder, sizeof(rdir));
else {
-@@ -818,6 +816,8 @@
+@@ -818,6 +816,8 @@ mailestd_gather(struct mailestd *_this,
strlcat(rdir, "/", sizeof(rdir));
strlcat(rdir, folder, sizeof(rdir));
}
@@ -18,7 +18,7 @@
paths[0] = rdir;
paths[1] = NULL;
lrdir = strlen(rdir);
-@@ -853,7 +853,7 @@
+@@ -853,7 +853,7 @@ mailestd_gather(struct mailestd *_this,
}
mailestd_log(LOG_DEBUG, "Gathered %s (Total: %d Remove: %d Update: %d)",
@@ -27,7 +27,7 @@
total, delete, update);
out:
if (ctx != NULL) {
-@@ -2638,6 +2638,7 @@
+@@ -2647,6 +2647,7 @@ static void
mailestd_monitor_folder(struct mailestd *_this, const char *dirpath)
{
int fd = -1;
@@ -35,7 +35,7 @@
struct folder *fld, fld0;
MAILESTD_ASSERT(_thread_self() == _this->monitorworker.thread);
-@@ -2659,7 +2660,8 @@
+@@ -2668,7 +2669,8 @@ mailestd_monitor_folder(struct mailestd
fld->fd = fd;
fld->path = xstrdup(dirpath);
RB_INSERT(folder_tree, &_this->monitors, fld);