aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mailman/Makefile
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2011-06-14 03:22:25 +0800
committercrees <crees@FreeBSD.org>2011-06-14 03:22:25 +0800
commitf1b4802f507dd01c21197418040ffe85c2cd2b65 (patch)
tree1aba04a864870be09e1190492d1fe12fceab37b1 /mail/mailman/Makefile
parentc8f6aa91e53e4b6ed60a127db78786505073f400 (diff)
downloadfreebsd-ports-gnome-f1b4802f507dd01c21197418040ffe85c2cd2b65.tar.gz
freebsd-ports-gnome-f1b4802f507dd01c21197418040ffe85c2cd2b65.tar.zst
freebsd-ports-gnome-f1b4802f507dd01c21197418040ffe85c2cd2b65.zip
- Correct GROUP when postfix OPTION is selected [1]
- Add nobody user and group to UIDs/GIDs for mail/mailman [2] - Stop touching files outside WRKDIR before install [2] - Use USERS and GROUPS [2] - Change BROKEN to IGNORE for incorrect OPTIONS choices [2] - Use @stopdaemon [2] - Correct rc script to check for pidfile before attempting kill [2] PR: ports/142000 Submitted by: Adriaan <ratten.adriaan@gmail.com> [1], crees [2] Approved by: rene (mentor), wxs (maintainer)
Diffstat (limited to 'mail/mailman/Makefile')
-rw-r--r--mail/mailman/Makefile50
1 files changed, 22 insertions, 28 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index 30ee78bdf614..2102306026bd 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mailman
DISTVERSION= 2.1.14
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= mail
MASTER_SITES= ${MASTER_SITE_GNU} \
SF/${PORTNAME}/Mailman%202.1%20%28stable%29/${PORTVERSION}
@@ -27,13 +27,15 @@ OPTIONS= SENDMAIL "for use with sendmail" off \
HTDIG "htdig integration patches" off \
NAMAZU2 "make private archives searchable with namazu2" off
-HAS_CONFIGURE= yes
+USE_AUTOTOOLS= autoconf
+GNU_CONFIGURE_PREFIX= ${MAILMANDIR}
USE_PYTHON= yes
MAKE_JOBS_SAFE= yes
-CONFIGURE_ARGS+= --prefix=${MAILMANDIR} --with-python=${PYTHON_CMD} \
+CONFIGURE_ARGS+=--with-python=${PYTHON_CMD} \
--with-username=${MM_USERNAME} \
--with-groupname=${MM_GROUPNAME} \
- --with-mail-gid=${MAIL_GID} --with-cgi-gid=${CGI_GID}
+ --with-mail-gid=${MAIL_GID} --with-cgi-gid=${CGI_GID} \
+ --with-permcheck=no
SUB_FILES= pkg-message
SUB_LIST+= MAILMANDIR=${MAILMANDIR}
USE_RC_SUBR= mailman
@@ -51,6 +53,9 @@ IMGDIR?= www/icons
#
# End of user-configurable variables.
+USERS= ${MM_USERNAME}
+GROUPS= ${MM_GROUPNAME}
+
MAILMANDIR= ${PREFIX}/${MM_DIR}
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
@@ -69,7 +74,7 @@ IMGFILES= PythonPowered.png mailman.jpg mm-icon.png
.if defined(WITH_SENDMAIL)
.if defined(WITH_EXIM3) || defined(WITH_EXIM4) || defined(WITH_POSTFIX) || \
defined(WITH_COURIER)
-BROKEN= choose only one MTA integration
+IGNORE= can only have one MTA selected to integrate with
.endif
MAIL_GID?= mailnull
.endif
@@ -77,7 +82,7 @@ MAIL_GID?= mailnull
.if defined(WITH_EXIM3)
.if defined(WITH_SENDMAIL) || defined(WITH_EXIM4) || defined(WITH_POSTFIX) || \
defined(WITH_COURIER)
-BROKEN= choose only one MTA integration
+IGNORE= can only have one MTA selected to integrate with
.endif
MAIL_GID?= nobody
.endif
@@ -85,7 +90,7 @@ MAIL_GID?= nobody
.if defined(WITH_EXIM4)
.if defined(WITH_SENDMAIL) || defined(WITH_EXIM3) || defined(WITH_POSTFIX) || \
defined(WITH_COURIER)
-BROKEN= choose only one MTA integration
+IGNORE= can only have one MTA selected to integrate with
.endif
MAIL_GID?= mail
.endif
@@ -93,16 +98,16 @@ MAIL_GID?= mail
.if defined(WITH_POSTFIX)
.if defined(WITH_SENDMAIL) || defined(WITH_EXIM3) || defined(WITH_EXIM4) || \
defined(WITH_COURIER)
-BROKEN= choose only one MTA integration
+IGNORE= can only have one MTA selected to integrate with
.endif
-MAIL_GID?= mailman
+MAIL_GID?= nobody
EXTRA_PATCHES+= ${FILESDIR}/postfix-verp.diff
.endif
.if defined(WITH_COURIER)
.if defined(WITH_SENDMAIL) || defined(WITH_EXIM3) || defined(WITH_EXIM4) || \
defined(WITH_POSTFIX)
-BROKEN= choose only one MTA integration
+IGNORE= can only have one MTA selected to integrate with
.endif
MAIL_GID?= courier
.endif
@@ -149,29 +154,18 @@ pre-fetch:
post-patch:
@${REINPLACE_CMD} -e 's#%%LOCALBASE%%#${LOCALBASE}#g' \
${WRKSRC}/Mailman/Defaults.py.in
-
-pre-configure::
-# Mailman's configure script needs the "mailman" user/group to exist, so
-# $PKGINSTALL has to be patched before the do-configure target executes.
+# Disable username check in configure -- we promise to make the users!
+ @${REINPLACE_CMD} \
+ -e 's#^MM_FIND_\([^_]*\)_NAME.*#MAILMAN_\1=$${\1NAME}#' \
+ ${WRKSRC}/configure.in
@${SED} \
- -e 's#%%USER%%#${MM_USERNAME}#g' -e 's#%%UID%%#${MM_USERID}#g' \
- -e 's#%%GROUP%%#${MM_GROUPNAME}#g' -e 's#%%GID%%#${MM_GROUPID}#g' \
- -e 's#%%MAILMANDIR%%#${MAILMANDIR}#g' ${MASTERDIR}/pkg-install > \
- ${PKGINSTALL}
- @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
-post-configure:
+ -e 's#%%USER%%#${MM_USERNAME}#g' \
+ -e 's#%%MAILMANDIR%%#${MAILMANDIR}#g' \
+ ${MASTERDIR}/pkg-install > ${PKGINSTALL}
@${SED} \
-e 's#%%USER%%#${MM_USERNAME}#g' -e 's#%%GROUP%%#${MM_GROUPNAME}#g' \
-e 's#%%PREFIX%%#${PREFIX}#g' -e 's#%%MAILMANDIR%%#${MAILMANDIR}#g' \
${MASTERDIR}/pkg-deinstall > ${PKGDEINSTALL}
-# port system auditors complain if dir is created prior to install
-# but configure demands it be there. we delete it now if empty,
-# so it will be re-created. For existing installs, this is ignored
- @- ${RMDIR} ${MAILMANDIR} 2> /dev/null
-
-pre-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
@${RM} -f ${MAILMANDIR}/pythonlib/*.egg-info