aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mailman
diff options
context:
space:
mode:
authorwjv <wjv@FreeBSD.org>2003-01-20 21:02:39 +0800
committerwjv <wjv@FreeBSD.org>2003-01-20 21:02:39 +0800
commitfd79a34e440e2468600365824e497318e25857ac (patch)
tree20e8e62094cac03647822e6dd1e162c97a452d10 /mail/mailman
parentb978f924785c488ac8ee58f8f5bd0586d260d08a (diff)
downloadfreebsd-ports-gnome-fd79a34e440e2468600365824e497318e25857ac.tar.gz
freebsd-ports-gnome-fd79a34e440e2468600365824e497318e25857ac.tar.zst
freebsd-ports-gnome-fd79a34e440e2468600365824e497318e25857ac.zip
- Add dependency on www/lynx, required for Mailman's mail filtering feature.
- Add patch to Mailman/Defaults.py.in, to correct path to lynx and various MTAs. - Change default $MAIL_GID and $CGI_GID values from numerical GIDs to group names. - Minor change to $PLIST to ensure clean deinstallation. - Bump $PORTREVISION Submitted by: Jan Siml <jsi@jules.de> (Lynx dependency)
Diffstat (limited to 'mail/mailman')
-rw-r--r--mail/mailman/Makefile19
-rw-r--r--mail/mailman/files/pkg-opts29
-rw-r--r--mail/mailman/pkg-plist2
3 files changed, 29 insertions, 21 deletions
diff --git a/mail/mailman/Makefile b/mail/mailman/Makefile
index 7e6cf6ae56d8..ae9f72bb0ee8 100644
--- a/mail/mailman/Makefile
+++ b/mail/mailman/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mailman
PORTVERSION= 2.1
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://www.list.org/ \
${MASTER_SITE_GNU} \
@@ -16,10 +17,11 @@ EXTRACT_SUFX= .tgz
MAINTAINER= wjv@FreeBSD.org
+RUN_DEPENDS= lynx:${PORTSDIR}/www/lynx
.if defined(WITH_APACHE13)
-RUN_DEPENDS= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache13
+RUN_DEPENDS+= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache13
.else
-RUN_DEPENDS= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache2
+RUN_DEPENDS+= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache2
.endif
.if defined(WITH_CHINESE)
RUN_DEPENDS+= ${PYTHONPREFIX_LIBDIR}/encodings/chinesecn/__init__.py:${PORTSDIR}/chinese/pycodec
@@ -27,11 +29,11 @@ RUN_DEPENDS+= ${PYTHONPREFIX_LIBDIR}/encodings/chinesecn/__init__.py:${PORTSDIR}
HAS_CONFIGURE= yes
USE_PYTHON= yes
+USE_REINPLACE= yes
CONFIGURE_ARGS= --prefix=${MAILMANDIR} --with-python=${PYTHON_CMD} \
--with-username=${MM_USERNAME} \
--with-groupname=${MM_GROUPNAME} \
--with-mail-gid=${MAIL_GID} --with-cgi-gid=${CGI_GID}
-PKGOPTS= ${FILESDIR}/pkg-opts
.include <bsd.port.pre.mk>
@@ -45,11 +47,11 @@ MM_GROUPNAME?= ${MM_USERNAME}
MM_GROUPID?= ${MM_USERID}
MM_DIR?= mailman
.if ${OSVERSION} >= 450000
-MAIL_GID?= 26
+MAIL_GID?= mailnull
.else
-MAIL_GID?= 1
+MAIL_GID?= daemon
.endif
-CGI_GID?= 80
+CGI_GID?= www
IMGDIR= www/icons
#
# End of user-configurable variables.
@@ -58,6 +60,7 @@ MAILMANDIR= ${PREFIX}/${MM_DIR}
PKGMESSAGE= ${WRKDIR}/pkg-message
PKGINSTALL= ${WRKDIR}/pkg-install
PKGDEINSTALL= ${WRKDIR}/pkg-deinstall
+PKGOPTS= ${FILESDIR}/pkg-opts
PLIST_SUB+= MMDIR=${MM_DIR} IMGDIR=${IMGDIR}
options:
@@ -72,6 +75,10 @@ post-extract:
${ECHO_MSG} '-------------------------------------------------------------------------')
.endif
+post-patch:
+ @ ${REINPLACE_CMD} -e 's#%%LOCALBASE%%#${LOCALBASE}#g' \
+ ${WRKSRC}/Mailman/Defaults.py.in
+
pre-configure:
# Mailman's configure script needs the "mailman" user/group to exist, so
# $PKGINSTALL has to be patched before the do-configure target executes.
diff --git a/mail/mailman/files/pkg-opts b/mail/mailman/files/pkg-opts
index 4584332f699e..270e5fd197f7 100644
--- a/mail/mailman/files/pkg-opts
+++ b/mail/mailman/files/pkg-opts
@@ -18,24 +18,25 @@
* MM_DIR [mailman]
Mailman will be installed in ${PREFIX}/${MM_DIR}
-* MAIL_GID [26]
- The group id under which your MTA performs mail delivery
+* MAIL_GID [mailnull]
+ The group name or id under which your MTA performs mail delivery
Getting the value of MAIL_GID right is crucial to getting Mailman to work
with your MTA. By default this port works with sendmail. If you're
using an alternative MTA installed from ports, you should set MAIL_GID at
- build time according to the following table. (Please contact this port's
- maintainer if you wish to fill in the blanks or report mistakes!)
-
- ----------------------------------------------
- MTA | MAIL_GID | Submitted by
- Exim | 65534 | <wjv>
- Postfix | 65534 | <shamrock@cypherpunks.to>
- Qmail | ??? |
- ----------------------------------------------
-
-* CGI_GID [80]
- The group id under which your web server executes CGI scripts
+ build time according to the following table. You may use either the
+ group name or the numerical GID. (Please contact this port's maintainer
+ if you wish to fill in the blanks or report mistakes!)
+
+ ----------------------------------------------------
+ MTA | MAIL_GID | Submitted by
+ Exim | nobody (65534) | <wjv@FreeBSD.org>
+ Postfix | nobody (65534) | <shamrock@cypherpunks.to>
+ Qmail | ??? |
+ ----------------------------------------------------
+
+* CGI_GID [www]
+ The group name or id under which your web server executes CGI scripts
By default, this port works with the current port of Apache2. If your
WWW server executes CGI scripts under a different GID, you'll have to
diff --git a/mail/mailman/pkg-plist b/mail/mailman/pkg-plist
index 9d80208db23c..f658972cc041 100644
--- a/mail/mailman/pkg-plist
+++ b/mail/mailman/pkg-plist
@@ -1432,7 +1432,6 @@ etc/rc.d/mailman.sh
@dirrm %%MMDIR%%/messages
@dirrm %%MMDIR%%/mail
@dirrm %%MMDIR%%/icons
-@dirrm %%MMDIR%%/data
@dirrm %%MMDIR%%/cron
@dirrm %%MMDIR%%/cgi-bin
@dirrm %%MMDIR%%/bin
@@ -1452,6 +1451,7 @@ etc/rc.d/mailman.sh
@unexec rmdir %D/%%MMDIR%%/logs 2>/dev/null || true
@unexec rmdir %D/%%MMDIR%%/locks 2>/dev/null || true
@unexec rmdir %D/%%MMDIR%%/lists 2>/dev/null || true
+@unexec rmdir %D/%%MMDIR%%/data 2>/dev/null || true
@unexec rmdir %D/%%MMDIR%%/archives/public 2>/dev/null || true
@unexec rmdir %D/%%MMDIR%%/archives/private 2>/dev/null || true
@unexec rmdir %D/%%MMDIR%%/archives 2>/dev/null || true