aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mailscanner/Makefile
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-08-31 21:19:02 +0800
committergarga <garga@FreeBSD.org>2005-08-31 21:19:02 +0800
commitf3f71e76a98f78062ddca72f2b392d143612c5fd (patch)
tree918a9a8f7f082714d88addb287de1b40d2d5a6a0 /mail/mailscanner/Makefile
parent17898826971da5fac795e84b616eead6ddf89082 (diff)
downloadfreebsd-ports-gnome-f3f71e76a98f78062ddca72f2b392d143612c5fd.tar.gz
freebsd-ports-gnome-f3f71e76a98f78062ddca72f2b392d143612c5fd.tar.zst
freebsd-ports-gnome-f3f71e76a98f78062ddca72f2b392d143612c5fd.zip
- Update to 4.44.6
* New Features and Improvements * - Published new version of the book, but advise you don't purchase until 3rd week of August so I get to check a copy off the press first. - Optimised situation where spam archive is being kept clean but many messages are being deleted. Thanks to yavor.trapkov@wipe.int for that. - Improved logging to show what sort of HTML tags have been disarmed. - Added "Scan Messages" option (intended to be a ruleset) which is an easy way of disabling all scanning and processing of messages. Great for customers who don't want scanning of any sort on their messages. - More phishing net improvements and additions to the safe sites list. * Fixes * - Resolved dependency problems by "tweaking" /usr/lib/rpm/perl.req to produce no output. - Added more Postfix temporarily-invalid-message checks. This is working perfectly reliably now. - Added disk full checks for MailScanner/incoming space. - Added missing object instantiate in the generic spam scanner. - Fixed reporting and scoring bugs in Custom Spam Scanner. - Made Postfix hash depth measurement more tolerant of stray files such as Razor logs appearing in the hold queue directories. - Delete temporary TNEF files created by internal TNEF decoder/expander. - Removed stray tar.gz files from tar distribution that shouldn't be there. PR: ports/85218 Submitted by: maintainer
Diffstat (limited to 'mail/mailscanner/Makefile')
-rw-r--r--mail/mailscanner/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/mail/mailscanner/Makefile b/mail/mailscanner/Makefile
index 39a84ad0a1df..00c4fe393678 100644
--- a/mail/mailscanner/Makefile
+++ b/mail/mailscanner/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= MailScanner
-PORTVERSION= 4.43.8
+PORTVERSION= 4.44.6
CATEGORIES= mail
MASTER_SITES= http://www.sng.ecs.soton.ac.uk/mailscanner/files/4/tar/
DISTNAME= ${PORTNAME}-install-${PORTVERSION}-${PATCHLEVEL}
@@ -41,7 +41,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS} \
CONFLICTS= MailScanner-devel-[0-9]*
-PATCHLEVEL= 1
+PATCHLEVEL= 2
USE_PERL5= yes
@@ -154,10 +154,11 @@ do-install:
# Step 3: Install files in share
#
@${MKDIR} ${DATADIR}
- cd ${WRKSRC}/etc && ${FIND} reports -type d -exec \
+ cd ${WRKSRC}/etc && ${FIND} reports -type d ! -name "*.old" -exec \
${MKDIR} ${DATADIR}/{} \;
- cd ${WRKSRC}/etc && ${FIND} reports -type f ! -name "*.orig" -exec \
- ${INSTALL_DATA} {} ${DATADIR}/{}.sample \;
+ # cd ${WRKSRC}/etc && ${FIND} reports -type f ! -name "*.orig" -exec ...
+ cd ${WRKSRC}/etc && ${FIND} reports \( -type d -name "*.old" -prune \) \
+ -o \( -type f ! -name "*.orig" -exec ${INSTALL_DATA} {} ${DATADIR}/{}.sample \; \)
${CHMOD} -R ${BINMODE} ${DATADIR}/reports
#
# Step 4: Install lib