aboutsummaryrefslogtreecommitdiffstats
path: root/mail/milter-skem
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2004-08-16 02:42:18 +0800
committermi <mi@FreeBSD.org>2004-08-16 02:42:18 +0800
commit919c0ca9f4d36a8b531bbe93d257c966f927de4a (patch)
tree7db110b6a9e8b9ee33504728964d4760631059ae /mail/milter-skem
parent058e990f1ba8ed6da943afaa54a3e7daec145cb7 (diff)
downloadfreebsd-ports-gnome-919c0ca9f4d36a8b531bbe93d257c966f927de4a.tar.gz
freebsd-ports-gnome-919c0ca9f4d36a8b531bbe93d257c966f927de4a.tar.zst
freebsd-ports-gnome-919c0ca9f4d36a8b531bbe93d257c966f927de4a.zip
For the first time, add a port of my own piece of code...
This milter does not itself filter spam, instead it memorizes the verdicts issued by your other anti-spam defenses to reduce the system load and resource consumption, by temporarily rejecting the relays suspected of spamming (banned) and, optionally, by permanently rejecting the relays "convicted" of spamming (blacklisted). The idea is to stem the spam from real spam sources, while reducing the ill effects of false-positives to merely delaying, rather than rejecting future messages. WWW: http://virtual-estates.net/skem/
Diffstat (limited to 'mail/milter-skem')
-rw-r--r--mail/milter-skem/Makefile44
-rw-r--r--mail/milter-skem/distinfo2
-rw-r--r--mail/milter-skem/pkg-descr23
-rw-r--r--mail/milter-skem/pkg-message8
4 files changed, 77 insertions, 0 deletions
diff --git a/mail/milter-skem/Makefile b/mail/milter-skem/Makefile
new file mode 100644
index 000000000000..c041ca5d9051
--- /dev/null
+++ b/mail/milter-skem/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: milter-skem
+# Date created: 14 July 2004
+# Whom: Mikhail Teterin
+#
+# $FreeBSD$
+#
+
+PORTNAME= skem
+PORTVERSION= 1.0
+CATEGORIES= mail
+MASTER_SITES= http://virtual-estates.net/skem/
+
+MAINTAINER= mi@aldan.algebra.com
+COMMENT= Cache earlier sendmail's verdicts for the relays
+
+USE_BZIP2= yes
+
+PLIST_FILES= sbin/skem
+MAN8= skem.8
+MANCOMPRESSED= maybe
+
+OPTIONS= SKEM_MILTER421 "Sendmail was built with -D_FFR_MILTER_421" off \
+ SKEM_NO_CLEANUP "Omit the auto-cleanup module" off \
+ SKEM_NO_LOGWATCHER "Omit the log-watching module" off \
+ SKEM_NETINET6 "Support IPv6 addresses (not tested)" off \
+ SKEM_NETINET "Support IPv4 addresses" on
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
+
+.if defined(PTHREAD_LIBS)
+MAKE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}"
+.endif
+.if defined(PTHREAD_CFLAGS)
+MAKE_ENV+= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
+.endif
+
+.for o in ${OPTIONS:MSKEM_*}
+. if defined(WITH_$o)
+MAKE_ARGS+= -D$o
+. endif
+.endfor
diff --git a/mail/milter-skem/distinfo b/mail/milter-skem/distinfo
new file mode 100644
index 000000000000..d9228be95baf
--- /dev/null
+++ b/mail/milter-skem/distinfo
@@ -0,0 +1,2 @@
+MD5 (skem-1.0.tar.bz2) = 1bb58d6380e6abae930c933cf0de8f80
+SIZE (skem-1.0.tar.bz2) = 14075
diff --git a/mail/milter-skem/pkg-descr b/mail/milter-skem/pkg-descr
new file mode 100644
index 000000000000..ba8aae7489aa
--- /dev/null
+++ b/mail/milter-skem/pkg-descr
@@ -0,0 +1,23 @@
+The skem utility is a sendmail milter, that checks and maintains a list
+of whitelisted, temporary banned, and permanently blacklisted
+IP-addresses. How you obtain the entries is up to you, but the included
+logwatcher module provides one possibility.
+
+The list is stored in a directory, each entry being a file (usually --
+zero sized) or a symlink (usually -- a "broken" one). Such entries are
+stored efficiently (within the directory itself) and the directories are
+searched using the hash tables on modern file systems. At the same time,
+they can be listed, added, and removed with the simple ls(1), touch(1),
+and rm(1).
+
+This milter does not itself filter spam, instead it memorizes the
+verdicts issued by your other anti-spam defenses to reduce the system
+load and resource consumption, by temporarily rejecting the relays
+suspected of spamming (banned) and, optionally, by permanently rejecting
+the relays "convicted" of spamming (blacklisted).
+
+The idea is to stem the spam from real spam sources, while reducing the
+ill effects of false-positives to merely delaying, rather than rejecting
+future messages.
+
+WWW: http://virtual-estates.net/skem/
diff --git a/mail/milter-skem/pkg-message b/mail/milter-skem/pkg-message
new file mode 100644
index 000000000000..7304aad33b96
--- /dev/null
+++ b/mail/milter-skem/pkg-message
@@ -0,0 +1,8 @@
+
+
+ The milter-skem port does not (yet?) provide the
+ milter-starting script(s).
+
+ Please, read the manual page (skem(8)) to determine,
+ what's best for your environment -- it can be configured
+ to be automaticly launched by syslogd(8), for example.