aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mixminion
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-13 13:55:02 +0800
committerbapt <bapt@FreeBSD.org>2012-06-13 13:55:02 +0800
commit818ed17bddcf2339d4165dbf978b07adf9ca9678 (patch)
tree9290ad281aeea9dc740177140c2842fb9f3789ca /mail/mixminion
parentaaf14a1e63df682f8359db1ef5b7efbd954e91df (diff)
downloadfreebsd-ports-gnome-818ed17bddcf2339d4165dbf978b07adf9ca9678.tar.gz
freebsd-ports-gnome-818ed17bddcf2339d4165dbf978b07adf9ca9678.tar.zst
freebsd-ports-gnome-818ed17bddcf2339d4165dbf978b07adf9ca9678.zip
Convert to new options framework
Diffstat (limited to 'mail/mixminion')
-rw-r--r--mail/mixminion/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/mail/mixminion/Makefile b/mail/mixminion/Makefile
index f4cc7d5a0905..bbc4e47e1432 100644
--- a/mail/mixminion/Makefile
+++ b/mail/mixminion/Makefile
@@ -25,11 +25,13 @@ MAN8= mixminiond.8
PORTDOCS= statusfd.txt tutorial.txt
-OPTIONS= SERVER "Also install the server" on
+OPTIONS_DEFINE= SERVER DOCS
+OPTIONS_DEFAULT= SERVER
+SERVER_DESC= Also install the server
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_SERVER)
+.if ${PORT_OPTIONS:MSERVER}
USE_RC_SUBR+= mixminiond
SUB_FILES+= pkg-message
PLIST_SUB+= SERVER=""
@@ -43,7 +45,7 @@ post-patch:
@${REINPLACE_CMD} -e "s|share/man|man|g" ${WRKSRC}/setup.py
post-install:
-.if !defined(WITHOUT_SERVER)
+.if ${PORT_OPTIONS:MSERVER}
@${INSTALL_DATA} ${WRKSRC}/etc/mixminiond.conf \
${PREFIX}/etc/mixminiond.conf.sample
@${INSTALL_DATA} ${WRKSRC}/etc/blacklist.conf \
@@ -59,11 +61,11 @@ post-install:
@${CHMOD} 0700 /var/log/mixminion
@${CAT} ${PKGMESSAGE}
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
@${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>