aboutsummaryrefslogtreecommitdiffstats
path: root/mail/mmc/files
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-07-21 22:06:25 +0800
committersobomax <sobomax@FreeBSD.org>2000-07-21 22:06:25 +0800
commit3159a4cdda74ab3252003322ed7f3b85a729d3dc (patch)
tree248a5884c400d8d2fa7bda6ec68e1ed8b336f808 /mail/mmc/files
parent6efa4681ed571c547f84ca3a52a08c182cb8f86e (diff)
downloadfreebsd-ports-gnome-3159a4cdda74ab3252003322ed7f3b85a729d3dc.tar.gz
freebsd-ports-gnome-3159a4cdda74ab3252003322ed7f3b85a729d3dc.tar.zst
freebsd-ports-gnome-3159a4cdda74ab3252003322ed7f3b85a729d3dc.zip
Add mmc - a tiny mail client for Gnome desktop.
Diffstat (limited to 'mail/mmc/files')
-rw-r--r--mail/mmc/files/patch-ab11
-rw-r--r--mail/mmc/files/patch-ac13
-rw-r--r--mail/mmc/files/patch-ad10
-rw-r--r--mail/mmc/files/patch-ae10
4 files changed, 44 insertions, 0 deletions
diff --git a/mail/mmc/files/patch-ab b/mail/mmc/files/patch-ab
new file mode 100644
index 000000000000..537275ed1336
--- /dev/null
+++ b/mail/mmc/files/patch-ab
@@ -0,0 +1,11 @@
+--- src/Makefile.in 2000/07/21 13:35:12 1.1
++++ src/Makefile.in 2000/07/21 13:35:38
+@@ -115,7 +115,7 @@
+ mmc_SOURCES = main.cc main.h msg.cc msg.h pop3.cc pop3.h mime.cc mime.h compose.cc compose.h smtp.cc smtp.h address.cc progressbar.cc protocols.h protocols.cc folders.cc folders.h address.h progress.h
+
+
+-mmc_LDADD = $(GNOMEUI_LIBS) $(GNOME_LIBDIR) $(INTLLIBS) -ldb
++mmc_LDADD = $(GNOMEUI_LIBS) $(GNOME_LIBDIR) $(INTLLIBS)
+
+ EXTRA_DIST = logo.png
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/mail/mmc/files/patch-ac b/mail/mmc/files/patch-ac
new file mode 100644
index 000000000000..28f201be2b53
--- /dev/null
+++ b/mail/mmc/files/patch-ac
@@ -0,0 +1,13 @@
+--- src/address.h 2000/07/21 13:28:27 1.1
++++ src/address.h 2000/07/21 13:30:50
+@@ -23,8 +23,8 @@
+ #ifndef __MMC_ADDRESS_H
+ #define __MMC_ADDRESS_H
+
+-#include <alloca.h>
+-#include <db1/db.h>
++/*#include <alloca.h>*/
++#include <db.h>
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <stdio.h>
diff --git a/mail/mmc/files/patch-ad b/mail/mmc/files/patch-ad
new file mode 100644
index 000000000000..ac391ca228e9
--- /dev/null
+++ b/mail/mmc/files/patch-ad
@@ -0,0 +1,10 @@
+--- src/pop3.cc 2000/07/21 13:31:58 1.1
++++ src/pop3.cc 2000/07/21 13:32:56
+@@ -26,6 +26,7 @@
+ */
+
+ #include <sys/types.h>
++#include <sys/socket.h>
+ #include <sys/stat.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
diff --git a/mail/mmc/files/patch-ae b/mail/mmc/files/patch-ae
new file mode 100644
index 000000000000..a371e75d7962
--- /dev/null
+++ b/mail/mmc/files/patch-ae
@@ -0,0 +1,10 @@
+--- src/smtp.cc 2000/07/21 13:33:45 1.1
++++ src/smtp.cc 2000/07/21 13:34:24
+@@ -20,6 +20,7 @@
+ For the complete License see the file COPYING.
+ */
+
++#include <sys/types.h>
+ #include<sys/socket.h>
+ #include<gnome.h>
+